net-libs/rb_libtorrent: Backport upstream patch to fix debug builds. Thanks to Eugene...
authorMarkos Chandras <hwoarang@gentoo.org>
Fri, 11 Sep 2015 21:35:50 +0000 (22:35 +0100)
committerMarkos Chandras <hwoarang@gentoo.org>
Fri, 11 Sep 2015 21:36:20 +0000 (22:36 +0100)
Package-Manager: portage-2.2.20.1

net-libs/rb_libtorrent/files/rb_libtorrent-1.0.6-fix-debug-build.patch [new file with mode: 0644]
net-libs/rb_libtorrent/rb_libtorrent-1.0.6.ebuild

diff --git a/net-libs/rb_libtorrent/files/rb_libtorrent-1.0.6-fix-debug-build.patch b/net-libs/rb_libtorrent/files/rb_libtorrent-1.0.6-fix-debug-build.patch
new file mode 100644 (file)
index 0000000..62429e7
--- /dev/null
@@ -0,0 +1,26 @@
+Signed-off-by: Markos Chandras <hwoarang@gentoo.org>
+X-Gentoo-Bug: 559728
+X-Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=559728
+
+From 06ce6a2d8b048c5791e2cc5acd1dfe8845680a84 Mon Sep 17 00:00:00 2001
+From: Chocobo1 <Chocobo1@users.noreply.github.com>
+Date: Sat, 1 Aug 2015 20:29:43 +0800
+Subject: [PATCH] Fix typo
+
+---
+ src/torrent.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/torrent.cpp b/src/torrent.cpp
+index d2da131..2e276ec 100644
+--- a/src/torrent.cpp
++++ b/src/torrent.cpp
+@@ -675,7 +675,7 @@ namespace libtorrent
+               }
+ #if defined TORRENT_VERBOSE_LOGGING || defined TORRENT_LOGGING
+-              debug_log("*** LEAVING SEED MODE (%s)", seed ? "as seed" : "as non-seed");
++              debug_log("*** LEAVING SEED MODE (%s)", m_seed_mode ? "as seed" : "as non-seed");
+ #endif
+               m_seed_mode = false;
+               // seed is false if we turned out not
index 9bad389857652b1c41bf1b13aa3f0d25323d7cd0..45085823a62a6ef59192c7044a0fbf8027722343 100644 (file)
@@ -41,7 +41,10 @@ DEPEND="${RDEPEND}
 
 RESTRICT="test"
 
-PATCHES=( "${FILESDIR}"/${PN}-1.0.2-python.patch )
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.0.2-python.patch
+       "${FILESDIR}"/${P}-fix-debug-build.patch
+)
 
 AUTOTOOLS_IN_SOURCE_BUILD=1