dev-python/testscenarios: Add pypy* support
authorJustin Lecher <jlec@gentoo.org>
Mon, 24 Aug 2015 06:06:30 +0000 (08:06 +0200)
committerJustin Lecher <jlec@gentoo.org>
Mon, 24 Aug 2015 10:12:08 +0000 (12:12 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/testscenarios/testscenarios-0.5.0.ebuild

index 5a70e5f2727d5ab0025d324acfbecbb0f1b8fc09..82002ed2318743a6bbd81828227b89c28c5b09b2 100644 (file)
@@ -3,7 +3,8 @@
 # $Id$
 
 EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
 
 inherit distutils-r1
 
@@ -17,8 +18,8 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linu
 
 RDEPEND="dev-python/testtools[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
-               dev-python/setuptools[${PYTHON_USEDEP}]
-               >=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       >=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
 
 python_prepare_all() {
        # Remove a faulty file from tests, missing a required attribute