Version bump
authorMarkus Ullmann <jokey@gentoo.org>
Wed, 20 Dec 2006 14:33:50 +0000 (14:33 +0000)
committerMarkus Ullmann <jokey@gentoo.org>
Wed, 20 Dec 2006 14:33:50 +0000 (14:33 +0000)
Package-Manager: portage-2.1.2_rc3-r7

dev-python/PyQt4/ChangeLog
dev-python/PyQt4/PyQt4-4.1.1.ebuild [new file with mode: 0644]
dev-python/PyQt4/files/digest-PyQt4-4.1.1 [new file with mode: 0644]
dev-python/sip/ChangeLog
dev-python/sip/files/digest-sip-4.5.2 [new file with mode: 0644]
dev-python/sip/sip-4.5.2.ebuild [new file with mode: 0644]

index 136ffd50fdaab828f67d275562932d2e9d697cd9..e97998a58601bddba91220c3dff3ff43c2f805b5 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/PyQt4
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.6 2006/11/15 19:01:24 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.7 2006/12/20 14:33:50 jokey Exp $
+
+*PyQt4-4.1.1 (20 Dec 2006)
+
+  20 Dec 2006; Markus Ullmann <jokey@gentoo.org> -PyQt4-4.1.ebuild,
+  +PyQt4-4.1.1.ebuild:
+  Version bump
 
   15 Nov 2006; Caleb Tennis <caleb@gentoo.org> -PyQt4-4.0_beta1.ebuild:
   remove old version
diff --git a/dev-python/PyQt4/PyQt4-4.1.1.ebuild b/dev-python/PyQt4/PyQt4-4.1.1.ebuild
new file mode 100644 (file)
index 0000000..6792d52
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.1.1.ebuild,v 1.1 2006/12/20 14:33:50 jokey Exp $
+
+inherit distutils
+
+MY_P="PyQt-x11-gpl-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PyQt is a set of Python bindings for the Qt toolkit."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+#SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+SRC_URI="http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/${MY_P}.tar.gz"
+#SRC_URI="http://www.riverbankcomputing.com/Downloads/Snapshots/PyQt3/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples"
+
+RDEPEND="=x11-libs/qt-4*
+       >=dev-python/sip-4.5"
+DEPEND="${RDEPEND}
+       sys-devel/libtool"
+
+
+src_unpack() {
+       unpack ${A}
+       sed -i -e "s:^[ \t]*check_license():# check_license():" ${S}/configure.py
+       sed -i -e "s:join(qt_dir, \"mkspecs\":join(\"/usr/share/qt4\",  \"mkspecs\":g" ${S}/configure.py
+       sed -i -e "s:\"QT_INSTALL_HEADERS\"\:   os.path.join(qt_dir, \"include\":\"QT_INSTALL_HEADERS\"\:   os.path.join(qt_dir, \"include/qt4\":g" ${S}/configure.py
+       sed -i -e "s:\"QT_INSTALL_LIBS\"\:      os.path.join(qt_dir, \"lib\":\"QT_INSTALL_LIBS\"\:      os.path.join(qt_dir, \"lib/qt4\":g" ${S}/configure.py
+}
+
+src_compile() {
+       distutils_python_version
+       addpredict ${QTDIR}/etc/settings
+
+       local myconf="-d ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/PyQt4 \
+                       -b ${ROOT}/usr/bin \
+                       -v ${ROOT}/usr/share/sip" #\
+#                      -n ${ROOT}/usr/include \
+#                      -o ${ROOT}/usr/$(get_libdir) \
+#                      -w -y qt-mt"
+       use debug && myconf="${myconf} -u"
+
+       python configure.py ${myconf}
+       emake || die "emake failed"
+}
+
+src_install() {
+       make DESTDIR=${D} install || die "install failed"
+       dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
+       use doc && dohtml doc/PyQt.html
+       if use examples ; then
+               dodir /usr/share/doc/${PF}/examples
+               cp -r examples/* ${D}/usr/share/doc/${PF}/examples
+       fi
+}
diff --git a/dev-python/PyQt4/files/digest-PyQt4-4.1.1 b/dev-python/PyQt4/files/digest-PyQt4-4.1.1
new file mode 100644 (file)
index 0000000..ed79afd
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 0e7cb6191603cd18f6f4767e1867f7bc PyQt-x11-gpl-4.1.1.tar.gz 5475244
+RMD160 7bd37cc89a9180484a84126fb927806c066e764b PyQt-x11-gpl-4.1.1.tar.gz 5475244
+SHA256 354b5d6723c88601aff9db3403ad9f6cd5e235e733d211b416f41d869e7eea89 PyQt-x11-gpl-4.1.1.tar.gz 5475244
index 970b20a2eb3f57fe94fac6fc73e7a17472d07a66..f8d2f8b9f5791a1551c6eb3b68b244cd7acd4793 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/sip
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.84 2006/11/15 18:54:02 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.85 2006/12/20 14:28:50 jokey Exp $
+
+*sip-4.5.2 (20 Dec 2006)
+
+  20 Dec 2006; Markus Ullmann <jokey@gentoo.org> -sip-4.5.ebuild,
+  +sip-4.5.2.ebuild:
+  Version bump
 
   15 Nov 2006; Caleb Tennis <caleb@gentoo.org> -sip-4.3.1.ebuild,
   -sip-4.4.1.ebuild, -sip-4.4.3.ebuild, -sip-4.4.5.ebuild:
diff --git a/dev-python/sip/files/digest-sip-4.5.2 b/dev-python/sip/files/digest-sip-4.5.2
new file mode 100644 (file)
index 0000000..60d1e3f
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 0fdb0cbdcbbe158009196437711eb8bd sip-4.5.2.tar.gz 417298
+RMD160 82efbb024e5a5be222173ca8c0e2629e7b909258 sip-4.5.2.tar.gz 417298
+SHA256 4344f50a3cedb83859c9015e71880ddd58be0c689de895e0e05546531923ee36 sip-4.5.2.tar.gz 417298
diff --git a/dev-python/sip/sip-4.5.2.ebuild b/dev-python/sip/sip-4.5.2.ebuild
new file mode 100644 (file)
index 0000000..1b1d299
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.5.2.ebuild,v 1.1 2006/12/20 14:28:50 jokey Exp $
+
+inherit distutils
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="SIP is a tool for generating bindings for C++ classes so that they can be used by Python."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/sip/"
+#SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+SRC_URI="http://www.riverbankcomputing.com/Downloads/sip4/${MY_P}.tar.gz"
+#SRC_URI="http://www.riverbankcomputing.com/Downloads/Snapshots/sip4//${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="sip"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc"
+
+DEPEND="virtual/libc
+       x11-libs/qt
+       >=dev-lang/python-2.3"
+
+src_compile(){
+       distutils_python_version
+
+       local myconf="-b ${ROOT}/usr/bin -d ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages -e ${ROOT}/usr/include/python${PYVER} -v ${ROOT}/usr/share/sip"
+       use debug && myconf="${myconf} -u"
+
+       python configure.py ${myconf} "CFLAGS+=${CFLAGS}" "CXXFLAGS+=${CXXFLAGS}"
+       emake || die "emake failed"
+}
+
+src_install() {
+       make DESTDIR=${D} install || die "install failed"
+       dodoc ChangeLog LICENSE NEWS README THANKS TODO
+       if use doc ; then dohtml doc/* ; fi
+}