Removed sed for hash_function and making sure sed for ccache is done behind an if...
authorChris Gianelloni <wolf31o2@gentoo.org>
Tue, 14 Mar 2006 20:02:52 +0000 (20:02 +0000)
committerChris Gianelloni <wolf31o2@gentoo.org>
Tue, 14 Mar 2006 20:02:52 +0000 (20:02 +0000)
Package-Manager: portage-2.1_pre6-r2

dev-util/catalyst/ChangeLog
dev-util/catalyst/Manifest
dev-util/catalyst/catalyst-2.0_rc40.ebuild

index 3c244c61217319dd99da7dec41f894e0d5d20729..e79ec19cdb4ac2648a35492f2bf9ca91aee6837f 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-util/catalyst
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.139 2006/03/13 19:45:14 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.140 2006/03/14 20:02:52 wolf31o2 Exp $
+
+  14 Mar 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+  catalyst-2.0_rc40.ebuild:
+  Removed sed for hash_function and making sure sed for ccache is done behind
+  an if statement.
 
 *catalyst-2.0_rc40 (13 Mar 2006)
 
index f373c024c1b0eaba63ac1cc229aff5ac0c279f6b..abae7ee2648a2786ab771e4137889b30ed612320 100644 (file)
@@ -1,12 +1,12 @@
-MD5 f6689bb13450539bf061045c422a3889 ChangeLog 30442
-RMD160 4f61af0a123be29e408bf3c1edf93bacdf6cb8cf ChangeLog 30442
-SHA256 f9aa03e10a0e0941b2f09f62fc964463e7919253decc8cab99713d428d70913d ChangeLog 30442
+MD5 8370335df2ed319e842b2b437b1e897b ChangeLog 30622
+RMD160 77564044a42eab0c5fd72241b98cdb10cb7ad643 ChangeLog 30622
+SHA256 e3fc8b2dabdafe58f82a944911e1a2e450e773c49ce8c2286aabf07fd50cfa47 ChangeLog 30622
 MD5 0b8c46e78330bff6ba7a248924ac4341 catalyst-1.1.10.10.ebuild 2281
 RMD160 19feac92aaa71ed004fca0ac0e27dc24fbfbc6f9 catalyst-1.1.10.10.ebuild 2281
 SHA256 6ce7c505db9bd2a546bc8f627503891928d3c9eb745e73de513e9e2c203ec38b catalyst-1.1.10.10.ebuild 2281
-MD5 4ce146d9649e0f598a5e99093338404f catalyst-2.0_rc40.ebuild 3269
-RMD160 76711b3e70779380944a142dd7aeb3a4bca24ab8 catalyst-2.0_rc40.ebuild 3269
-SHA256 5bc0928a0ed1856e822ff69b3665a7b34570c41957be60a24e9f2fc549538999 catalyst-2.0_rc40.ebuild 3269
+MD5 d12387bda844f6e11f8325581c49315a catalyst-2.0_rc40.ebuild 3149
+RMD160 c99380136c445158b79ff59f2bb62378ba250494 catalyst-2.0_rc40.ebuild 3149
+SHA256 978a966a71bc7e5e8580ec15719bb1b8be19bd74c949547a18937c0f53b77d3e catalyst-2.0_rc40.ebuild 3149
 MD5 051a387d3dcac9e45b8bc547e41c4f7b files/catalyst-2.0_rc40-slot.patch 1267
 RMD160 8fc8d03c92674cefd2e645eb0da44874be04de38 files/catalyst-2.0_rc40-slot.patch 1267
 SHA256 2e04de2147d30ba30c2b7051c77fab1965d2486d920035a75e6640a15b4f9ee5 files/catalyst-2.0_rc40-slot.patch 1267
index 11ed6102848622952a9b633d01f5111cb05395bc..78089f3cecd450309b9159c22d454e64d0ccb755 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0_rc40.ebuild,v 1.1 2006/03/13 19:45:15 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0_rc40.ebuild,v 1.2 2006/03/14 20:02:52 wolf31o2 Exp $
 
 inherit eutils
 
@@ -88,12 +88,12 @@ src_install() {
                /etc/catalyst2/catalyst2.conf
        dosed "s:/var/tmp/catalyst:/var/tmp/catalyst2:" \
                /etc/catalyst2/catalyst2.conf
-       # This is the dirty hack for missing dev-perl/Archive-Zip
-       dosed 's:hash_function="crc32":hash_function="md5":' \
-               /etc/catalyst2/catalyst2.conf
        # Here is where we actually enable ccache
-       dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
-               /etc/catalyst2/catalyst2.conf
+       if use ccache
+       then
+               dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+                       /etc/catalyst2/catalyst2.conf
+       fi
 }
 
 pkg_postinst() {