mail-client/bower: upstream release 0.10
authorRalph Seichter <github@seichter.de>
Thu, 14 Feb 2019 16:27:13 +0000 (17:27 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 2 Mar 2019 00:02:58 +0000 (01:02 +0100)
See https://notmuchmail.org/pipermail/notmuch/2019/027349.html
for the official announcement text.

Signed-off-by: Ralph Seichter <gentoo@seichter.de>
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Closes: https://github.com/gentoo/gentoo/pull/11052
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
mail-client/bower/Manifest
mail-client/bower/bower-0.10.ebuild [new file with mode: 0644]

index a59a5cb049f5c8e0493ba16235d359b59162920a..8952d7b80368273bd35224e7ea6ae5ec6350f178 100644 (file)
@@ -1 +1,2 @@
+DIST bower-0.10.tar.gz 261487 BLAKE2B 861ee1e17787586f12795fb507cb32fd2d63b8831083354aed9f710c06cc8714ede7421d64c7aa6f2a52aec954be89fe15f1a4a2292d044c9b6a754c754d9667 SHA512 54ba7492008f1f6f1495b0d8a7585965ecf6ba16701bd19234dc761190db701d7cdc9a4e0e5995846f2feb08018a217a0e405dea0dacb3fbfb5681ed66529b9a
 DIST bower-0.9.tar.gz 256921 BLAKE2B b8bd1f179209051e5c870ceeb9efec0345a488726497775b81a87329ce6ee3b0aa0c0f6c5be8b8c2481cb9469977b549af15e1ddc302d360f3e6a79cbf560eb8 SHA512 697b5e221356cac8284da9002053e6289df25ba82f0039301643e16e40a1bda6010c9d54dd4c7a3e4c47cdbe9373713248ef2bd182df56bb035db93d089798c2
diff --git a/mail-client/bower/bower-0.10.ebuild b/mail-client/bower/bower-0.10.ebuild
new file mode 100644 (file)
index 0000000..002d3f1
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing
+
+DESCRIPTION="A curses terminal client for the Notmuch email system"
+HOMEPAGE="https://github.com/wangp/bower"
+SRC_URI="https://github.com/wangp/bower/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND="app-crypt/gpgme:=
+       sys-libs/ncurses:0="
+DEPEND="${COMMON_DEPEND}
+       >=dev-lang/mercury-11.07"
+RDEPEND="${COMMON_DEPEND}
+       net-mail/notmuch
+       sys-apps/coreutils"
+
+src_prepare() {
+       default
+       if has_version "sys-libs/ncurses:0[tinfo]" ; then
+               echo "MLLIBS-bower += -ltinfow" >> src/Mercury.params || die
+       fi
+}
+
+src_compile() {
+       emake PARALLEL="--jobs $(makeopts_jobs) --no-strip --very-verbose"
+}
+
+src_install() {
+       dobin bower
+       dodoc AUTHORS NEWS README.md bower.conf.sample
+}