app-backup/duplicity: version bump to 0.7.10
authorTim Harder <radhermit@gentoo.org>
Mon, 22 Aug 2016 02:41:10 +0000 (22:41 -0400)
committerTim Harder <radhermit@gentoo.org>
Mon, 22 Aug 2016 02:41:10 +0000 (22:41 -0400)
app-backup/duplicity/Manifest
app-backup/duplicity/duplicity-0.7.10.ebuild [new file with mode: 0644]

index 09e7b8c5994d1daf0e8403318d69f562c12ad685..9e482621a507110c88be9b3ca1a6546dd1218205 100644 (file)
@@ -1,2 +1,3 @@
 DIST duplicity-0.6.26.tar.gz 1270436 SHA256 8bef8a5d805b79ae177e54d42152238bce1b2aaf9ad32e03a2c3a20cbd4e074a SHA512 0cd02984eda99c81a30c9ac9926c41df0597f8f287a3e8ccd7d6fb9d420159028112be6b3fc8acf9b413940c07d0e754b2a509b6bca52965d2c333d4bcec8689 WHIRLPOOL 873b9fc9e035ed31cef996ace747c6a97b9434b50945578b019627c94e8eb7ba0861909e74b95db143ddb50dfdb23241a3ddfe712a97e0cd1f29c324c5d99c16
 DIST duplicity-0.7.07.1.tar.gz 1539310 SHA256 594c6d0e723e56f8a7114d57811c613622d535cafdef4a3643a4d4c89c1904f8 SHA512 363266232763791bac9e84a9e345dda6ffa278a89597a094540088e12e47b56cb2459f72073c0020b77504514149b1ccb9bed7a67e516443a674975954f49129 WHIRLPOOL 041ea4dcc127e7cf5cca04c2037776fdf224cabe741f18a4de4e6e18fe1c4260eeed20892f91c43b7dbb0a04d246b67e8f52ab364b5bbc43a765e50ea05be092
+DIST duplicity-0.7.10.tar.gz 1543523 SHA256 485fef15526d163c061e00ec08de216cf7d652e67d41de5dc3bed9fb42214842 SHA512 d04273384749c88d0a4f46bc1dcdcbb945ec1a78fb21064f12f0ca6c92cc73ad36fc3149461dbe0a660cd752a1147b2fa5d2b4056a5414c7790747eb5983e0bd WHIRLPOOL 1532b1e5ffc764951155ce248662d3ebf23fff71c538270ee1b2d37c7ad0a90705361b34418a323dfb4947ede42cd356e0daba18e4124e7342e5baadc5d0af22
diff --git a/app-backup/duplicity/duplicity-0.7.10.ebuild b/app-backup/duplicity/duplicity-0.7.10.ebuild
new file mode 100644 (file)
index 0000000..758b48f
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Secure backup system using gnupg to encrypt data"
+HOMEPAGE="http://www.nongnu.org/duplicity/"
+SRC_URI="https://code.launchpad.net/${PN}/$(get_version_component_range 1-2)-series/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="s3 test"
+
+CDEPEND="
+       net-libs/librsync
+       app-crypt/gnupg
+       dev-python/lockfile
+"
+DEPEND="${CDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+RDEPEND="${CDEPEND}
+       dev-python/paramiko[${PYTHON_USEDEP}]
+       s3? ( dev-python/boto[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+       # workaround until failing test is fixed
+       local PATCHES=( "${FILESDIR}"/${PN}-0.6.24-skip-test.patch )
+
+       distutils-r1_python_prepare_all
+
+       sed -i "s/'COPYING',//" setup.py || die
+}
+
+python_test() {
+       esetup.py test
+}
+
+pkg_postinst() {
+       einfo "Duplicity has many optional dependencies to support various backends."
+       einfo "Currently it's up to you to install them as necessary."
+}