www-client/firefox: fix style
authorThomas Deutschmann <whissi@gentoo.org>
Sat, 28 Mar 2020 15:50:42 +0000 (16:50 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 30 Mar 2020 11:45:09 +0000 (13:45 +0200)
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
www-client/firefox/firefox-68.6.0-r2.ebuild
www-client/firefox/firefox-74.0-r2.ebuild

index d610d428cc59c7fbfe25a40e4b43bd1d1138b4bb..eb63ae0f71d5d0b04084caaf445675fe174a90f8 100644 (file)
@@ -708,7 +708,7 @@ PROFILE_EOF
        newins "${FILESDIR}"/disable-auto-update.policy.json policies.json
 
        # Install icons and .desktop for menu entry
-       for size in ${sizes}; do
+       for size in ${sizes} ; do
                insinto "/usr/share/icons/hicolor/${size}x${size}/apps"
                newins "${icon_path}/default${size}.png" "${icon}.png"
        done
@@ -734,7 +734,7 @@ PROFILE_EOF
        dosym firefox ${MOZILLA_FIVE_HOME}/firefox-bin
 
        # Required in order to use plugins and even run firefox on hardened.
-       pax-mark m "${ED}"${MOZILLA_FIVE_HOME}/{firefox,plugin-container}
+       pax-mark m "${ED%/}"${MOZILLA_FIVE_HOME}/{firefox,plugin-container}
 }
 
 pkg_preinst() {
index 739761cdb2f26eee099a1e4f2ed9118c00dc241c..b6ff763a5bfc38c1248534c7cc3cd124af82c1e6 100644 (file)
@@ -727,7 +727,7 @@ PROFILE_EOF
        newins "${FILESDIR}"/disable-auto-update.policy.json policies.json
 
        # Install icons and .desktop for menu entry
-       for size in ${sizes}; do
+       for size in ${sizes} ; do
                insinto "/usr/share/icons/hicolor/${size}x${size}/apps"
                newins "${icon_path}/default${size}.png" "${icon}.png"
        done
@@ -753,7 +753,7 @@ PROFILE_EOF
        dosym firefox ${MOZILLA_FIVE_HOME}/firefox-bin
 
        # Required in order to use plugins and even run firefox on hardened.
-       pax-mark m "${ED}"${MOZILLA_FIVE_HOME}/{firefox,plugin-container}
+       pax-mark m "${ED%/}"${MOZILLA_FIVE_HOME}/{firefox,plugin-container}
 }
 
 pkg_preinst() {