media-libs/vulkan-loader: Bump vulkan-loader-1.1.125
authorPeter Levine <plevine457@gmail.com>
Mon, 21 Oct 2019 03:25:04 +0000 (23:25 -0400)
committerNick Sarnie <sarnex@gentoo.org>
Mon, 21 Oct 2019 22:48:20 +0000 (18:48 -0400)
Closes: https://github.com/gentoo/gentoo/pull/13369
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Peter Levine <plevine457@gmail.com>
Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
media-libs/vulkan-loader/Manifest
media-libs/vulkan-loader/vulkan-loader-1.1.125.ebuild [new file with mode: 0644]

index 9144c1944d862e838c5a4844935505037b3416a1..c3a2fe7b59883d22070b15903224c8a88f8c1fc5 100644 (file)
@@ -1 +1,2 @@
 DIST vulkan-loader-1.1.114.tar.gz 1343624 BLAKE2B 1212c837d86f29160b19bbc14a82564d57722d0d8b540e9360af0a470db59d8c5ad76a1f9f5f892a09b7f43ae62792262b1713c8cabace087c37c2cbb103215b SHA512 90fe8fa7b0a0028faaf8e3aea0724799eb57989a0297e416b3b651a81e0de99b0506eb6b17f84bfc1a6ed33edcc806a5b6c1b187d0d49ea0c8d99ae9dcb5338c
+DIST vulkan-loader-1.1.125.tar.gz 1398802 BLAKE2B 7cf1f99f60b4b37bfad12580fc8809012a0540d928366b465a532fbf90e7d87bf42eeeff70b1a46efeadef9c599cad6009b122ed9c5c7298973207f05acc1032 SHA512 40e1e5c16491f0549eae3efc065c375c258b475d81e1c781a756c71ec329f390e2aba55ced5ed2005e938f9d074dffc1692e7e1e330a35f55460cae1606fdf2e
diff --git a/media-libs/vulkan-loader/vulkan-loader-1.1.125.ebuild b/media-libs/vulkan-loader/vulkan-loader-1.1.125.ebuild
new file mode 100644 (file)
index 0000000..7b03900
--- /dev/null
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+
+if [[ "${PV}" == "9999" ]]; then
+       EGIT_REPO_URI="https://github.com/KhronosGroup/Vulkan-Loader.git"
+       EGIT_SUBMODULES=()
+       inherit git-r3
+else
+       if [[ -z ${SNAPSHOT_COMMIT} ]]; then
+               MY_PV=v${PV}
+               MY_P=Vulkan-Loader-${PV}
+       else
+               MY_PV=${SNAPSHOT_COMMIT}
+               MY_P=Vulkan-Loader-${SNAPSHOT_COMMIT}
+       fi
+       KEYWORDS="~amd64 ~x86"
+       SRC_URI="https://github.com/KhronosGroup/Vulkan-Loader/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}"/${MY_P}
+fi
+
+inherit toolchain-funcs python-any-r1 cmake-multilib
+
+DESCRIPTION="Vulkan Installable Client Driver (ICD) Loader"
+HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Loader"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="layers wayland X"
+
+PDEPEND="layers? ( media-libs/vulkan-layers:=[${MULTILIB_USEDEP}] )"
+DEPEND="${PYTHON_DEPS}
+       >=dev-util/vulkan-headers-${PV}
+       wayland? ( dev-libs/wayland:=[${MULTILIB_USEDEP}] )
+       X? (
+               x11-libs/libX11:=[${MULTILIB_USEDEP}]
+               x11-libs/libXrandr:=[${MULTILIB_USEDEP}]
+       )"
+
+multilib_src_configure() {
+       # Integrated clang assembler doesn't work with x86 - Bug #698164
+       if [[ tc-is-clang && ${ABI} == x86 ]]; then
+               append-cflags -fno-integrated-as
+       fi
+
+       local mycmakeargs=(
+               -DCMAKE_SKIP_RPATH=True
+               -DBUILD_TESTS=False
+               -DBUILD_LOADER=True
+               -DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
+               -DBUILD_WSI_XCB_SUPPORT=$(usex X)
+               -DBUILD_WSI_XLIB_SUPPORT=$(usex X)
+               -DVULKAN_HEADERS_INSTALL_DIR="/usr"
+       )
+       cmake-utils_src_configure
+}
+
+multilib_src_install() {
+       keepdir /etc/vulkan/icd.d
+
+       cmake-utils_src_install
+}
+
+pkg_postinst() {
+       einfo "USE=demos has been dropped as per upstream packaging"
+       einfo "vulkaninfo is now available in the dev-util/vulkan-tools package"
+}