determine compression suffix correctly and finally
authorChristian Faulhammer <fauli@gentoo.org>
Sat, 3 Feb 2007 11:25:24 +0000 (11:25 +0000)
committerChristian Faulhammer <fauli@gentoo.org>
Sat, 3 Feb 2007 11:25:24 +0000 (11:25 +0000)
Package-Manager: portage-2.1.1-r2

app-editors/emacs-cvs/ChangeLog
app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild
app-editors/emacs-cvs/emacs-cvs-22.0.9999-r2.ebuild
app-editors/emacs/ChangeLog
app-editors/emacs/emacs-21.4-r6.ebuild

index b6a6759fd64a274ac6ee88761c5118bda4196178..5f16a773d39a09176a8854b5345bfc6bdaeb9c8e 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for app-editors/emacs-cvs
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.77 2007/02/02 20:38:07 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.78 2007/02/03 11:21:02 opfer Exp $
+
+  03 Feb 2007; Christian Faulhammer <opfer@gentoo.org>
+  emacs-cvs-22.0.93-r2.ebuild, emacs-cvs-22.0.9999-r2.ebuild:
+  determine compression suffix correctly and finally
 
   02 Feb 2007; Christian Faulhammer <opfer@gentoo.org>
   emacs-cvs-22.0.93-r2.ebuild, emacs-cvs-22.0.9999-r2.ebuild:
index 7888f73bf1e818f3e18fc3fb62df1c6fe316457d..f1452dd5a83d935d296b3e8e407ed6075ed3dcb0 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild,v 1.3 2007/02/02 20:38:07 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.93-r2.ebuild,v 1.4 2007/02/03 11:21:02 opfer Exp $
 
 WANT_AUTOCONF="latest"
 WANT_AUTOMAKE="latest"
@@ -167,6 +167,9 @@ EOF
 }
 
 update-alternatives() {
+       # extract the suffix of the manpages to determine the correct compression program
+       local suffix=`ls /usr/share/man/man1/emacs.emacs-* |sed s/".*\."//g|tail -n 1`
+
        # this creates symlinks for binaries and man pages, so the correct ones in a slotted
        # environment can be accessed
        for i in emacs emacsclient etags ctags b2m ebrowse \
@@ -177,7 +180,7 @@ update-alternatives() {
 
        for j in emacs emacsclient etags ctags
        do
-               alternatives_auto_makesym "/usr/share/man/man1/$j.1.gz" "/usr/share/man/man1/$j.emacs-${SLOT}*"
+               alternatives_auto_makesym "/usr/share/man/man1/$j.1.${suffix}" "/usr/share/man/man1/$j.emacs-*"
        done
 }
 
index 660ffd152db3a7adc14078450425864f06b15e55..95ccbb49aaeaf7aaf4d77902e252eee15a9072cc 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r2.ebuild,v 1.3 2007/02/02 20:38:07 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.9999-r2.ebuild,v 1.4 2007/02/03 11:21:02 opfer Exp $
 
 ECVS_AUTH="pserver"
 ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
@@ -172,6 +172,9 @@ EOF
 }
 
 update-alternatives() {
+       # extract the suffix of the manpages to determine the correct compression program
+       local suffix=`ls /usr/share/man/man1/emacs.emacs-* |sed s/".*\."//g|tail -n 1`
+
        # this creates symlinks for binaries and man pages, so the correct ones in a slotted
        # environment can be accessed
        for i in emacs emacsclient etags ctags b2m ebrowse \
@@ -182,7 +185,7 @@ update-alternatives() {
 
        for j in emacs emacsclient etags ctags
        do
-               alternatives_auto_makesym "/usr/share/man/man1/$j.1.gz" "/usr/share/man/man1/$j.emacs-${SLOT}*"
+               alternatives_auto_makesym "/usr/share/man/man1/$j.1.${suffix}" "/usr/share/man/man1/$j.emacs-*"
        done
 }
 
index 179e97a5f8dcd877b8f99dd5e6bf4e80663d59f0..a6daf0d1a04e2323de6927ad2f4371fd34273f5d 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for app-editors/emacs
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.115 2007/02/02 20:14:12 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.116 2007/02/03 11:25:24 opfer Exp $
+
+  03 Feb 2007; Christian Faulhammer <opfer@gentoo.org> emacs-21.4-r6.ebuild:
+  determine compression suffix correctly and finally
 
   02 Feb 2007; Christian Faulhammer <opfer@gentoo.org> emacs-21.4-r6.ebuild:
   hopefully fix man page symlinks again, part II
index 4491936c1a16ac9a05b79ec8c457384b03bf1dc2..804fd2529cbcb1d7c92f64196379cd05f5b1df0e 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r6.ebuild,v 1.3 2007/02/02 20:14:12 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r6.ebuild,v 1.4 2007/02/03 11:25:24 opfer Exp $
 
 inherit flag-o-matic eutils alternatives toolchain-funcs
 
@@ -159,6 +159,9 @@ src_install() {
 }
 
 update-alternatives() {
+       # extract the suffix of the manpages to determine the correct compression program
+       local suffix=`ls /usr/share/man/man1/emacs.emacs-* |sed s/".*\."//g|tail -n 1`
+
        # this creates symlinks for binaries and man pages, so the correct ones in a slotted
        # environment can be accessed
        for i in emacs emacsclient etags ctags b2m ebrowse \
@@ -168,7 +171,7 @@ update-alternatives() {
 
        for j in emacs emacsclient etags ctags
        do
-               alternatives_auto_makesym "/usr/share/man/man1/$j.1.gz" "/usr/share/man/man1/$j.emacs-${SLOT}*"
+               alternatives_auto_makesym "/usr/share/man/man1/$j.1.${suffix}" "/usr/share/man/man1/$j.emacs-*"
        done
 }