dev-python/futurist: 1.8.1 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 06:14:02 +0000 (01:14 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 9 Apr 2019 07:05:18 +0000 (02:05 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/futurist/Manifest
dev-python/futurist/futurist-1.8.1.ebuild [new file with mode: 0644]

index 09607c161c1fd4f1a8ec77d021d98421655f9188..5afa53aebcdeb32d39de3ed7628d6d23a55b86bf 100644 (file)
@@ -1,2 +1,3 @@
 DIST futurist-1.3.1.tar.gz 40927 BLAKE2B 7a746bc7dbdfe1ac9ff2fcdd02a0f4f6e0caccadb52b46439620bc5daf736545de906d0a8d159d39fe7d0ab8eda05767aff4723607dc777ec5c1b43a1670c277 SHA512 88b3af8922542d0bcc3e3e1ba8c456adb6233a616c1e14b3b49b11162be5b65855e7088ae6ce573d42bc80675f51070270533fea65e70935304954a3889db3e3
 DIST futurist-1.6.0.tar.gz 40372 BLAKE2B 295a2a274de8a613025c6c46f6abd048cc6d988e9f4c5dc2de9559d295d88f2d93e5afc017dbd8c9c20a6bb50a63567d42f3ac46c61fd9b0d08a028dbdb2c5bf SHA512 fdbd93e3ffa61661218e4a3f180a448b1d8c75126847c50a36264543bac02f50984d4e493031c0ce3257d16661f7b4a4463b5b3dfd7ae7e2f974410e0d1234a1
+DIST futurist-1.8.1.tar.gz 42430 BLAKE2B 4584d37dd2a5de41be576b1233a50202c9c134b0a7e6c231e028224413f2a0c6e2ab22e1685e5fc974cded3e70c4fee6cbb9ae1262f167455a40a39eeec8c904 SHA512 4ec292284a1a6a7675bd9970f391bfcc47841c42beedac8348b23755481c4f87a2467dbb0f8c963c4b9fc8148a8aaca43e3c166878d07c9e48720481b0f73d9b
diff --git a/dev-python/futurist/futurist-1.8.1.ebuild b/dev-python/futurist/futurist-1.8.1.ebuild
new file mode 100644 (file)
index 0000000..d665202
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Useful additions to futures, from the future"
+HOMEPAGE="https://pypi.org/project/futurist/ http://docs.openstack.org/developer/futurist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools
+       ${CDEPEND}"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
+       virtual/python-futures[${PYTHON_USEDEP}]
+       >=dev-python/contextlib2-0.4.0[${PYTHON_USEDEP}]
+       >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+       <dev-python/prettytable-0.8[${PYTHON_USEDEP}]"