app-editors/gedit: version bump 3.20.2 → 3.22.0
authorGilles Dartiguelongue <eva@gentoo.org>
Tue, 1 Nov 2016 16:11:28 +0000 (17:11 +0100)
committerGilles Dartiguelongue <eva@gentoo.org>
Tue, 1 Nov 2016 17:07:34 +0000 (18:07 +0100)
Disable update checker plugin as it only makes sense for upstream released binaries.

Package-Manager: portage-2.3.2

app-editors/gedit/Manifest
app-editors/gedit/gedit-3.22.0.ebuild [new file with mode: 0644]

index 7b899432b60639a90e51677fccf768481a4a3241..38d83cc3db64bd15b95d3df3a428483493df5024 100644 (file)
@@ -2,3 +2,4 @@ DIST gedit-3.16.4.tar.xz 2925984 SHA256 210937ea9143d8a6c9580a7ab11acf60d478f516
 DIST gedit-3.18.2.tar.xz 2915772 SHA256 856e451aec29ee45980011de57cadfe89c3cbc53968f6cc865f8efe0bd0d49b1 SHA512 e81382b74749c4592565bab25d47784a3206e033e6b0e5d5a557403590dafd130e41b31bcecc820a3d9823a48f8e94907bc9bb0335121e369abaca1360a95b30 WHIRLPOOL 87b40323caa707a4ce68d5efc299075883a1fc01e1def15f9052802bccae9075c3aa8c50d36062bb96060421008c510d3c0600fd359950a06ae651e3b56553e5
 DIST gedit-3.18.3.tar.xz 2933132 SHA256 6762ac0d793b0f754a2da5f88739d04fa39daa7491c5c46401d24bcef76c32e7 SHA512 8866bc0958dfcf59e5eac0f3c39f2b5f252ffac78a25551968f539f73ebc25cc792ded93899c066339e9b6927f86d6e5ac583df9b9c4d7f0b07d1cc7683e7eb2 WHIRLPOOL fc60b4d251519057eab978a454a2eb0f6741fd097b58f1ac9614413bdab93e15a5f83132ed14f53ae6a6a49a94e9b78a8acce855d229a8f964fefae044a796e8
 DIST gedit-3.20.2.tar.xz 3135004 SHA256 32a1276a71a0d4a5af4e20a87bc273170ba8e075fc1ca7f51c8d3a6c150463f8 SHA512 3a224a5e0789760f0840b902fd7fa3c1d56b8100e3c502cf9a1c26336cc922192ba7bb37c1c7fd2069c71ccd0483fb692439d73fcb464117f520ec0d140aaf6d WHIRLPOOL 2128fda00474c197b4a85478cd676ae99d929871635b44d2641ffc5c58b47aceb943906c6a8ee3fcd1bbd309e217090a44ea4d83530adf6daab055f410c0796c
+DIST gedit-3.22.0.tar.xz 2957520 SHA256 063b5a0b5dcc8f540f6e8c3ea1c22cf8a3a19edffc25315a1b6bc51d462b3f45 SHA512 7137fe96cca072c294dea545cb7fafee7ca2da84d8b7756e03a5f5dde6cdca8a3eec6f58136cec0aeeb49c294acd000f01bf3a44447411924aff107dbab26efb WHIRLPOOL 621a9ef89bdaafc490e6b05ac00d91978f175953c37c3d6c141b0513a99bc77b05907dab665d48022f56d0c6a8b9ad8e935c2279d58356d691490b16e533135e
diff --git a/app-editors/gedit/gedit-3.22.0.ebuild b/app-editors/gedit/gedit-3.22.0.ebuild
new file mode 100644 (file)
index 0000000..755b101
--- /dev/null
@@ -0,0 +1,97 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+GNOME2_LA_PUNT="yes" # plugins are dlopened
+PYTHON_COMPAT=( python3_{3,4,5} )
+VALA_MIN_API_VERSION="0.26"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils gnome2 multilib python-r1 vala virtualx
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="+introspection +python spell vala"
+# python-single-r1 would request disabling PYTHON_TARGETS on libpeas
+# we need to fix that
+REQUIRED_USE="
+       python? ( introspection )
+       python? ( ^^ ( $(python_gen_useflags '*') ) )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+
+# X libs are not needed for OSX (aqua)
+COMMON_DEPEND="
+       >=dev-libs/libxml2-2.5.0:2
+       >=dev-libs/glib-2.44:2[dbus]
+       >=x11-libs/gtk+-3.21.3:3[introspection?]
+       >=x11-libs/gtksourceview-3.21.2:3.0[introspection?]
+       >=dev-libs/libpeas-1.14.1[gtk]
+
+       gnome-base/gsettings-desktop-schemas
+       gnome-base/gvfs
+
+       x11-libs/libX11
+
+       introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
+       python? (
+               ${PYTHON_DEPS}
+               dev-python/pycairo[${PYTHON_USEDEP}]
+               >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
+               dev-libs/libpeas[${PYTHON_USEDEP}] )
+       spell? ( >=app-text/gspell-0.2.5:0= )
+"
+RDEPEND="${COMMON_DEPEND}
+       x11-themes/adwaita-icon-theme
+"
+DEPEND="${COMMON_DEPEND}
+       ${vala_depend}
+       app-text/docbook-xml-dtd:4.1.2
+       app-text/yelp-tools
+       >=dev-util/gtk-doc-am-1
+       >=dev-util/intltool-0.50.1
+       >=sys-devel/gettext-0.18
+       virtual/pkgconfig
+"
+# yelp-tools, gnome-common needed to eautoreconf
+
+pkg_setup() {
+       use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+}
+
+src_prepare() {
+       vala_src_prepare
+       gnome2_src_prepare
+}
+
+src_configure() {
+       DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+       gnome2_src_configure \
+               --disable-deprecations \
+               --disable-updater \
+               --enable-gvfs-metadata \
+               $(use_enable introspection) \
+               $(use_enable spell) \
+               $(use_enable python) \
+               $(use_enable vala)
+}
+
+src_test() {
+       "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+       GSETTINGS_SCHEMA_DIR="${S}/data" virtx emake check
+}
+
+src_install() {
+       local args=()
+       # manually set pyoverridesdir due to bug #524018 and AM_PATH_PYTHON limitations
+       use python && args+=( pyoverridesdir="$(python_get_sitedir)/gi/overrides" )
+
+       gnome2_src_install "${args[@]}"
+}