sys-apps/semodule-utils: bump to 3.0_rc2
authorJason Zaman <perfinion@gentoo.org>
Fri, 29 Nov 2019 10:30:45 +0000 (18:30 +0800)
committerJason Zaman <perfinion@gentoo.org>
Mon, 2 Dec 2019 14:49:22 +0000 (22:49 +0800)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Jason Zaman <perfinion@gentoo.org>
sys-apps/semodule-utils/Manifest
sys-apps/semodule-utils/semodule-utils-3.0_rc2.ebuild [new file with mode: 0644]

index f3b138fa09272ecb71d255087a5c9257b8f7733f..0b6571bde3e15ae73031920bb7972972df0695f5 100644 (file)
@@ -1,2 +1,3 @@
 DIST semodule-utils-2.8.tar.gz 12536 BLAKE2B 93a2f8fee887eba72b009071549a687fe86045344979e31493b3f17041ddf3f31c29ea3c754a31f6029847798dfe26d63b02fadc1042bc68aa414050b283d208 SHA512 13d79a22115f5448dafc5202dc3dec66b9ad826051d61d7c126defe823407959511db35713d97c7dfe9e79de96193fec91a10b98c13743e06a1213f5734f4ae7
 DIST semodule-utils-2.9.tar.gz 14259 BLAKE2B f72630c520504596171ac6f678b1fde2bb8482b620f0d8f6374c59b85d634ee8c407e3e4b268dae4d6cecfa2749b26f8808dd56f7c5391e7d1ba11f4a8a789e5 SHA512 688f1fcb34042b837019302debda76847691657709130b99bf937a85774a0ae69d789ee82b0633a4d2dc661dc6d0a1706a878ac681317df2abe68418bec3f952
+DIST semodule-utils-3.0-rc2.tar.gz 14269 BLAKE2B 161b0c62045f199bb1acef83fde138307b8095681a2da0a995a42d89e87bb6a0319067d18cd340da354a9ae764b2fa5704b48b0c972ec11df0d9ea6960a71641 SHA512 2f4fd71a255bd03d1fb3b341d96192058005634fcfdd9d07611f4bfec80d4b3e3a033cf1ad9223dd9e2c6fe6708910de021652e577e3ca1ff51997e0147b3413
diff --git a/sys-apps/semodule-utils/semodule-utils-3.0_rc2.ebuild b/sys-apps/semodule-utils/semodule-utils-3.0_rc2.ebuild
new file mode 100644 (file)
index 0000000..73361dc
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+MY_RELEASEDATE="20191122"
+SEPOL_VER="${PV}"
+SELNX_VER="${PV}"
+
+MY_P="${P//_/-}"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+       S="${WORKDIR}/${MY_P}/${PN}"
+else
+       SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+       S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="SELinux policy module utilities"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${SEPOL_VER}:="
+
+RDEPEND="${DEPEND}
+       !<sys-apps/policycoreutils-2.7_pre"
+
+src_prepare() {
+       default
+
+       sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+       emake CC="$(tc-getCC)"
+}
+
+src_install() {
+       emake DESTDIR="${D}" \
+               install
+}