sci-mathematics/spass: Remove last-rited pkg
authorMichał Górny <mgorny@gentoo.org>
Sat, 14 Sep 2019 15:42:42 +0000 (17:42 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 14 Sep 2019 15:42:42 +0000 (17:42 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
profiles/package.mask
sci-mathematics/spass/Manifest [deleted file]
sci-mathematics/spass/metadata.xml [deleted file]
sci-mathematics/spass/spass-3.9.ebuild [deleted file]

index 4fc51877934c0a7f9121c37541c27b36430fb73e..5839f915bbe1bc1deda19dfbfd22d3be9bcd35f1 100644 (file)
@@ -1125,7 +1125,6 @@ sci-chemistry/jmol
 sci-mathematics/cvc3
 sci-mathematics/e
 sci-mathematics/kodkodi
-sci-mathematics/spass
 
 # Michał Górny <mgorny@gentoo.org> (2019-08-14)
 # No longer builds.  Homepage is gone, and its keep-alive fork is also
diff --git a/sci-mathematics/spass/Manifest b/sci-mathematics/spass/Manifest
deleted file mode 100644 (file)
index 00c5827..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST spass39.tgz 554633 BLAKE2B ca2215f205215805eace6abae82ad281bdadd75f2a52cfe3fed43cb15a4955a4e4d2375fc73a546592315540a7596494bc0df4c53996fd9299e901f68a81ddc8 SHA512 d7ea0697426c476f2e03b2f9078b7e060671067a67fad7144bb5887a2dd3f39e19e1888f121fce546b5d6ea9a4dc458d1cbec56b59c93507e7dc2d0afa25a89b
diff --git a/sci-mathematics/spass/metadata.xml b/sci-mathematics/spass/metadata.xml
deleted file mode 100644 (file)
index 93ca493..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <maintainer type="person">
-               <email>gienah@gentoo.org</email>
-       </maintainer>
-       <maintainer type="project">
-               <email>sci-mathematics@gentoo.org</email>
-               <name>Gentoo Mathematics Project</name>
-       </maintainer>
-       <longdescription lang="en">
-               SPASS: An Automated Theorem Prover for First-Order Logic with Equality.
-       </longdescription>
-       <use>
-               <flag name="isabelle">Add integration support for the Isabelle/HOL theorem prover.</flag>
-       </use>
-</pkgmetadata>
diff --git a/sci-mathematics/spass/spass-3.9.ebuild b/sci-mathematics/spass/spass-3.9.ebuild
deleted file mode 100644 (file)
index c702dea..0000000
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-MY_PV=$(ver_rs 1- '' "${PV}")
-MY_P="${PN}${MY_PV}"
-
-DESCRIPTION="An Automated Theorem Prover for First-Order Logic with Equality"
-HOMEPAGE="http://www.spass-prover.org/"
-SRC_URI="http://www.spass-prover.org/download/sources/${MY_P}.tgz"
-
-LICENSE="BSD-2"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="isabelle"
-
-RDEPEND="isabelle? (
-                       sci-mathematics/isabelle:=
-               )"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
-       mkdir -p "${P}" || die
-       cd "${S}" || die
-       unpack "${MY_P}.tgz"
-}
-
-src_compile() {
-       einfo "generating parsers"
-       bison -d -p pro_ -o proparser.c proparser.y || die
-       bison -d -p tptp_ -o tptpparser.c tptpparser.y || die
-       bison -d -p ia_ -o iaparser.c iaparser.y || die
-
-       einfo "generating lexers"
-       flex -Ppro_ -o proscanner.c proscanner.l || die
-       flex -Ptptp_ -o tptpscanner.c tptpscanner.l || die
-       flex -Pia_ -o iascanner.c iascanner.l || die
-
-       einfo "compiling sources"
-       local x
-       for x in *.c
-       do
-               $(tc-getCC) \
-                       ${CPPFLAGS} ${CFLAGS} \
-                       -c -o ${x/.c/.o} ${x} || die "compile ${x} failed"
-       done
-
-       einfo "linking tptp2dfg"
-       $(tc-getCC) \
-               ${LDFLAGS} -o tptp2dfg \
-               array.o clause.o cmdline.o context.o description.o dfg_diagnostic.o \
-               dfg_string_table.o dfg_token.o dfgparser.o dfglexer.o  \
-               tptpparser.o tptpscanner.o eml.o flags.o foldfg.o hashmap.o kbo.o \
-               list.o memory.o misc.o order.o rpos.o sharing.o st.o stack.o \
-               strings.o subst.o symbol.o term.o unify.o tptp2dfg.o -lm \
-               || die "link tptp2dfg failed"
-
-       einfo "linking dfg2ascii"
-       $(tc-getCC) \
-               ${LDFLAGS} -o dfg2ascii \
-               array.o clause.o cmdline.o context.o description.o dfg_diagnostic.o \
-               dfg_string_table.o dfg_token.o dfgparser.o dfglexer.o \
-               tptpparser.o tptpscanner.o eml.o flags.o foldfg.o hashmap.o kbo.o \
-               list.o memory.o misc.o order.o rpos.o sharing.o st.o stack.o \
-               strings.o subst.o symbol.o term.o unify.o dfg2ascii.o -lm \
-               || die "link dfg2ascii failed"
-
-       einfo "linking dfg2dfg"
-       $(tc-getCC) \
-               ${LDFLAGS} -o dfg2dfg \
-               array.o clause.o cmdline.o context.o description.o dfg_diagnostic.o \
-               dfg_string_table.o dfg_token.o dfgparser.o dfglexer.o \
-               tptpparser.o tptpscanner.o eml.o flags.o foldfg.o hashmap.o kbo.o \
-               list.o memory.o misc.o order.o rpos.o sharing.o st.o stack.o \
-               strings.o subst.o symbol.o term.o unify.o approx.o dfg2dfg.o -lm \
-               || die "link dfg2dfg failed"
-
-       einfo "linking SPASS"
-       $(tc-getCC) \
-               ${LDFLAGS} -o SPASS \
-               array.o clause.o cmdline.o context.o description.o dfg_diagnostic.o \
-               dfg_string_table.o dfg_token.o dfgparser.o dfglexer.o \
-               tptpparser.o tptpscanner.o eml.o flags.o foldfg.o hashmap.o kbo.o \
-               list.o memory.o misc.o order.o rpos.o sharing.o st.o stack.o \
-               strings.o subst.o symbol.o term.o unify.o analyze.o clock.o \
-               closure.o cnf.o component.o condensing.o defs.o doc-proof.o graph.o \
-               hash.o hasharray.o iaparser.o iascanner.o partition.o proofcheck.o \
-               ras.o renaming.o resolution.o rules-inf.o rules-red.o rules-sort.o \
-               rules-split.o rules-ur.o search.o sort.o subsumption.o table.o \
-               tableau.o terminator.o top.o vector.o -lm \
-               || die "link SPASS failed"
-}
-
-src_install() {
-       exeinto /usr/bin
-       local x
-       for x in tptp2dfg dfg2ascii dfg2dfg SPASS
-       do
-               doexe ${x}
-       done
-
-       if use isabelle; then
-               ewarn "All open source versions of spass are broken with Isabelle 2016.1"
-               ISABELLE_HOME="$(isabelle getenv ISABELLE_HOME | cut -d'=' -f 2)"
-               [[ -n "${ISABELLE_HOME}" ]] || die "ISABELLE_HOME empty"
-               dodir "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
-               cat <<- EOF >> "${S}/settings"
-                       SPASS_HOME="${EROOT}/usr/bin"
-                       SPASS_VERSION="${PV}"
-               EOF
-               insinto "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
-               doins "${S}/settings"
-       fi
-}
-
-pkg_postinst() {
-       if use isabelle; then
-               if [ -f "${EROOT}/etc/isabelle/components" ]; then
-                       if egrep "contrib/${PN}-[0-9.]*" "${EROOT}/etc/isabelle/components"; then
-                               sed -e "/contrib\/${PN}-[0-9.]*/d" \
-                                       -i "${EROOT}/etc/isabelle/components"
-                       fi
-                       cat <<- EOF >> "${EROOT}/etc/isabelle/components"
-                               contrib/${PN}-${PV}
-                       EOF
-               fi
-       fi
-}
-
-pkg_postrm() {
-       if use isabelle; then
-               if [ ! -f "${EROOT}/usr/bin/SPASS" ]; then
-                       if [ -f "${EROOT}/etc/isabelle/components" ]; then
-                               # Note: this sed should only match the version of this ebuild
-                               # Which is what we want as we do not want to remove the line
-                               # of a new spass being installed during an upgrade.
-                               sed -e "/contrib\/${PN}-${PV}/d" \
-                                       -i "${EROOT}/etc/isabelle/components"
-                       fi
-               fi
-       fi
-}