dev-ada/gnat-suite-bin: version bump tp 2019
authorTupone Alfredo <tupone@gentoo.org>
Fri, 7 Feb 2020 18:33:57 +0000 (19:33 +0100)
committerTupone Alfredo <tupone@gentoo.org>
Fri, 7 Feb 2020 18:34:34 +0000 (19:34 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-ada/gnat-suite-bin/Manifest
dev-ada/gnat-suite-bin/gnat-suite-bin-2019.ebuild [new file with mode: 0644]

index 596defa1e822837df7241a35439f8afb07696d23..7e40913c9dc23b476adece5318411502ddafb528 100644 (file)
@@ -3,3 +3,4 @@ DIST gnat-gpl-2014-x86_64-linux-bin.tar.gz 236253400 BLAKE2B c1db70db9442ba24688
 DIST gnat-gpl-2016-x86_64-linux-bin.tar.gz 372813330 BLAKE2B a0374ad730ae275aaedcf5663c30f8e0221af32f14391fe87a3ce0630d4498a1e90671c02830d62f78857571a5a521af91f6db409a7b3c367c7b0f059571eefd SHA512 5115ac3be0badc5125ee048a98230f18363d72107da3325ce602c0e618cee2e3646a0decc00a2388f14bc61bfed51dd0622f365f5f7ee8b0cec2187ebcf8e075
 DIST gnat-gpl-2017-x86_64-linux-bin.tar.gz 496338280 BLAKE2B b3eee6d311fb9c20bc8fa7217c0731ca1e91ced38700df1d63d91a16c3fa28dfd44c7c8e867c3a857b88e4f0c8b2a7200fb6a8a630b8403538c4784f8914d1a5 SHA512 01a8f3be9b7b7e83cc5bd4a45137b1d35c6448bc22a88bcaf5d312cd63e11081b6b2fe9f09ad2a27d8f0b6471fc5c1a99573bf3bcee1589329054074eaeef04f
 DIST gnat-suite-bin-2018.txz 337235688 BLAKE2B cf1b8f0253907b8fc97b9c7218b23dcda8f1557be5e12293eab59e09427418a8814c1bafbcb3f89c1e5dd755a161c5dfa8a852631d137f17acb3167bf51dadbb SHA512 9b57709c05a121b0a0adabe3232128e3f27659d1928857fbd6883b73a7487c3d457317e8f236df3d16ced635514af8afbafc584cc74d865e11288820ac9c4f77
+DIST gnat-suite-bin-2019.txz 518461388 BLAKE2B 31ca194d15cafd66abe1d0896f1444e746c1484149db26545855561512c251b84eea5b4d0932860dfed23cac7f0b3c94a9884c586f509ceb6da8b9becd29e913 SHA512 a640e451a1badc2a9c64abb80f1ae1b49b5389e265d14dfe9b22891d23b3d13a9770841a43cc50ceba81c2728777ed9da854654afe6198c79dd4e0fed536907c
diff --git a/dev-ada/gnat-suite-bin/gnat-suite-bin-2019.ebuild b/dev-ada/gnat-suite-bin/gnat-suite-bin-2019.ebuild
new file mode 100644 (file)
index 0000000..587a7e9
--- /dev/null
@@ -0,0 +1,86 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MYP=gnat-gpl-${PV}
+DESCRIPTION="GNAT Ada suite"
+HOMEPAGE="http://libre.adacore.com/"
+# Extracted and repacked from gnat-community-2019-20190517-x86_64-linux-bin
+SRC_URI="https://dev.gentoo.org/~tupone/distfiles/${P}.txz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+       sys-devel/binutils
+       sys-devel/gdb"
+
+PREFIX=/opt/${P}
+
+src_prepare() {
+       default
+       rm Makefile
+       cd share/examples/gnat
+       cat header.xml \
+               full_project/full.xml \
+               options/options.xml \
+               other_languages/cpp_main/cpp_main.xml \
+               other_languages/cpp_pragmas/cpp_pragmas.xml \
+               other_languages/import_from_c/import_from_c.xml \
+               plugins/plugins.xml \
+               stream_io/stream_io.xml \
+               simple_project/simple_project.xml \
+               starter/starter.xml \
+               xml_stream/xml_stream.xml \
+               containers/anagram/anagram.xml \
+               containers/genealogy/genealogy.xml \
+               containers/hash/hash.xml \
+               containers/library/library.xml \
+               containers/shapes/shapes.xml \
+               containers/spellcheck/spellcheck.xml \
+               containers/wordcount/wordcount.xml \
+               containers/wordfreq/wordfreq.xml \
+               oo_interfaces/oo_interfaces.xml \
+               oo_airline/oo_airline.xml \
+               altivec/altivec.xml \
+               footer.xml \
+               > gnat-examples.xml \
+               || die
+       sed -i \
+               -e "s:PREFIX:${PREFIX}:" \
+               gnat-examples.xml || die
+}
+
+src_install() {
+       into ${PREFIX}
+       dobin bin/*
+       insinto ${PREFIX}
+       doins -r etc include lib* share
+       insinto ${PREFIX}/share/gps/plug-ins
+       doins share/examples/gnat/gnat-examples.xml
+       basever=8.3.1
+       machine=x86_64-pc-linux-gnu
+       fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/cc1
+       fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/cc1plus
+       fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/collect2
+       fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/gnat1
+       fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/liblto_plugin.so.0.0.0
+       fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/lto1
+       fperms 755 ${PREFIX}/libexec/gcc/${machine}/${basever}/lto-wrapper
+       fperms 755 ${PREFIX}/libexec/gprbuild/gprbind
+       fperms 755 ${PREFIX}/libexec/gprbuild/gprlib
+}
+
+pkg_postinst () {
+       einfo "GNAT GPL is now installed. To launch it, you must put"
+       einfo "      ${PREFIX}/bin"
+       einfo "in front of your PATH environment variable. The following"
+       einfo "commands enable you to do this:"
+       einfo "      PATH=${PREFIX}/bin:\$PATH; export PATH  (Bourne shell)"
+       einfo "      setenv PATH ${PREFIX}/bin:\$PATH        (C shell)"
+       einfo "   Thank you for installing GNAT GPL Edition"
+}