app-crypt/libb2: USE=static -> USE=static-libs
authorFabian Groffen <grobian@gentoo.org>
Thu, 6 Jun 2019 16:26:51 +0000 (18:26 +0200)
committerFabian Groffen <grobian@gentoo.org>
Thu, 6 Jun 2019 16:34:28 +0000 (18:34 +0200)
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

app-crypt/libb2/libb2-0.98.1-r1.ebuild [moved from app-crypt/libb2/libb2-0.98.1.ebuild with 91% similarity]

similarity index 91%
rename from app-crypt/libb2/libb2-0.98.1.ebuild
rename to app-crypt/libb2/libb2-0.98.1-r1.ebuild
index 29d440d64d0aff868bb3d020e9f4fb92e3d2ba5c..2925f4c30b4a5f4423c858de606fc2bc0f48e05e 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/BLAKE2/libb2/archive/${GITHASH}.tar.gz -> ${P}.tar.g
 LICENSE="CC0-1.0"
 SLOT="0"
 KEYWORDS="~amd64 ~hppa ~ppc64 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x64-solaris"
-IUSE="static native-cflags openmp"
+IUSE="static-libs native-cflags openmp"
 
 DEPEND="
        openmp? (
@@ -42,7 +42,7 @@ src_prepare() {
 
 src_configure() {
        econf \
-               $(use_enable static) \
+               $(use_enable static-libs static) \
                $(use_enable native-cflags native) \
                $(use_enable openmp)
 }
@@ -63,5 +63,5 @@ src_test() {
 
 src_install() {
        default
-       use static || find "${ED}" -name '*.la' -type f -delete || die
+       use static-libs || find "${ED}" -name '*.la' -type f -delete || die
 }