x11-drivers/xf86-video-voodoo: Add patch to fix compilation.
authorMatt Turner <mattst88@gentoo.org>
Sat, 29 Aug 2015 23:36:19 +0000 (16:36 -0700)
committerMatt Turner <mattst88@gentoo.org>
Sat, 29 Aug 2015 23:36:37 +0000 (16:36 -0700)
Bug: https://bugs.gentoo.org/550642

x11-drivers/xf86-video-voodoo/files/xf86-video-voodoo-1.2.5-no-PCITAG.patch [new file with mode: 0644]
x11-drivers/xf86-video-voodoo/xf86-video-voodoo-1.2.5.ebuild

diff --git a/x11-drivers/xf86-video-voodoo/files/xf86-video-voodoo-1.2.5-no-PCITAG.patch b/x11-drivers/xf86-video-voodoo/files/xf86-video-voodoo-1.2.5-no-PCITAG.patch
new file mode 100644 (file)
index 0000000..31e7079
--- /dev/null
@@ -0,0 +1,26 @@
+From 9172ae566a0e85313fc80ab62b4455393eefe593 Mon Sep 17 00:00:00 2001
+From: Dave Airlie <airlied@redhat.com>
+Date: Mon, 22 Sep 2014 10:56:02 +1000
+Subject: [PATCH] don't use PCITAG in struct anymore
+
+---
+ src/voodoo.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/voodoo.h b/src/voodoo.h
+index bfed497..c3eb64e 100644
+--- a/src/voodoo.h
++++ b/src/voodoo.h
+@@ -23,7 +23,9 @@ typedef struct {
+   
+   Bool                      Voodoo2;          /* Set if Voodoo2 */
+   pciVideoPtr       PciInfo;          /* PCI data */
++#ifndef XSERVER_LIBPCIACCESS
+   PCITAG            PciTag;
++#endif
+   CARD32            PhysBase;
+   
+   CARD32            Width;            /* Current width */
+-- 
+2.4.6
+
index 2917b2f9bffa0d63651985eaabf31d2de7f9ba89..dffd9e8dd27a50cbf94e980f7b3b22df4b239dba 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -12,3 +12,7 @@ IUSE=""
 RDEPEND=">=x11-base/xorg-server-1.0.99"
 DEPEND="${RDEPEND}
        x11-proto/xf86dgaproto"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-no-PCITAG.patch
+)