version bumpy-bump
authorKurt Lieber <klieber@gentoo.org>
Wed, 14 Apr 2004 00:19:15 +0000 (00:19 +0000)
committerKurt Lieber <klieber@gentoo.org>
Wed, 14 Apr 2004 00:19:15 +0000 (00:19 +0000)
net-misc/cfengine/ChangeLog
net-misc/cfengine/cfengine-2.1.5.ebuild [new file with mode: 0644]
net-misc/cfengine/files/digest-cfengine-2.1.5 [new file with mode: 0644]

index 50eb5ac8e1b0eaf12f7b8dae14ab9b23a7374812..c59c4cb7eecae912b7c27b8fb7161238ca247e79 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for net-misc/cfengine
 # Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/ChangeLog,v 1.26 2004/04/06 12:41:41 klieber Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cfengine/ChangeLog,v 1.27 2004/04/14 00:19:15 klieber Exp $
+
+*cfengine-2.1.5 (13 Apr 2004)
+
+  13 Apr 2004; Kurt Lieber <klieber@gentoo.org> cfengine-2.1.5.ebuild:
+  bump to 2.1.5 to fix a minor bug.
 
 *cfengine-2.1.4 (06 Apr 2004)
 
diff --git a/net-misc/cfengine/cfengine-2.1.5.ebuild b/net-misc/cfengine/cfengine-2.1.5.ebuild
new file mode 100644 (file)
index 0000000..c7d0473
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $
+
+DESCRIPTION="An agent/software robot and a high level policy language for building expert systems to administrate and configure large computer networks"
+HOMEPAGE="http://www.iu.hio.no/cfengine/"
+SRC_URI="ftp://ftp.iu.hio.no/pub/cfengine/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="virtual/glibc
+       >=sys-libs/db-3.2
+       >=dev-libs/openssl-0.9.6k"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+
+       # Enforce /var/cfengine for historical compatibility
+       econf \
+               --with-workdir=/var/cfengine \
+               --with-berkeleydb=/usr || die
+
+       # Fix Makefile to skip doc & inputs install to wrong locations
+       sed -i -e 's/\(SUBDIRS.*\) inputs doc/\1/' Makefile
+
+       emake || die
+}
+
+src_install() {
+       make DESTDIR=${D} install || die
+       dodoc AUTHORS ChangeLog COPYING README TODO
+
+       # Manually install doc and inputs
+       doinfo doc/*.info*
+       dohtml doc/*.html
+       dodoc inputs/*.example
+
+       # Create cfengine working directory
+       mkdir -p ${D}/var/cfengine
+       fperms 700 /var/cfengine
+       keepdir /var/cfengine/bin
+       keepdir /var/cfengine/inputs
+}
+
+pkg_postinst() {
+       if [ ! -f "/var/cfengine/ppkeys/localhost.priv" ]
+               then
+               einfo "Generating keys for localhost."
+               /usr/sbin/cfkey
+       fi
+
+
+       # Copy cfagent into the cfengine tree otherwise cfexecd won't
+       # find it. Most hosts cache their copy of the cfengine
+       # binaries here. This is the default search location for the
+       # binaries.
+
+       cp /usr/sbin/cf{agent,servd,execd} /var/cfengine/bin/
+}
diff --git a/net-misc/cfengine/files/digest-cfengine-2.1.5 b/net-misc/cfengine/files/digest-cfengine-2.1.5
new file mode 100644 (file)
index 0000000..be834b2
--- /dev/null
@@ -0,0 +1 @@
+MD5 0c7c15d646defe23123708ee836b4040 cfengine-2.1.5.tar.gz 1852357