Version bumped to 20060701. Bug #145321
authorAlfredo Tupone <tupone@gentoo.org>
Sun, 8 Oct 2006 21:29:47 +0000 (21:29 +0000)
committerAlfredo Tupone <tupone@gentoo.org>
Sun, 8 Oct 2006 21:29:47 +0000 (21:29 +0000)
Package-Manager: portage-2.1.1

games-fps/alephone/ChangeLog
games-fps/alephone/alephone-20060701.ebuild [new file with mode: 0644]
games-fps/alephone/files/digest-alephone-20060701 [new file with mode: 0644]

index 960eebec804d15559d2f85be730b3dfdbce6aedf..2e23a4eb1cfd2fb117ff073b8cd54d89d7902ce6 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for games-fps/alephone
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.13 2006/09/19 14:10:23 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.14 2006/10/08 21:29:47 tupone Exp $
+
+*alephone-20060701 (08 Oct 2006)
+
+  08 Oct 2006; <tupone@gentoo.org> -files/alephone-20051119-gcc41.patch,
+  +alephone-20060701.ebuild:
+  Version bumped to 20060701. Bug #145321 by Pawel Suchanecki
 
   19 Sep 2006; Chris Gianelloni <wolf31o2@gentoo.org>
   -alephone-20050118.ebuild, -alephone-20051119.ebuild,
diff --git a/games-fps/alephone/alephone-20060701.ebuild b/games-fps/alephone/alephone-20060701.ebuild
new file mode 100644 (file)
index 0000000..954cafb
--- /dev/null
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20060701.ebuild,v 1.1 2006/10/08 21:29:47 tupone Exp $
+
+inherit eutils games
+
+DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
+HOMEPAGE="http://source.bungie.org/"
+SRC_URI="mirror://sourceforge/marathon/AlephOne-${PV}-nolibs.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua opengl speex"
+
+DEPEND="lua? ( dev-lang/lua )
+       opengl? ( virtual/opengl )
+       speex? ( media-libs/speex )
+       dev-libs/boost
+       >=media-libs/libsdl-1.2
+       media-libs/sdl-image
+       media-libs/sdl-net"
+
+S=${WORKDIR}/AlephOne-${PV}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       cp ${FILESDIR}/alephone.png ./
+       cp ${FILESDIR}/alephone.sh ./
+       sed -i -e "s:GAMES_DATADIR:${GAMES_DATADIR}:g" \
+               alephone.sh || die
+}
+
+src_compile() {
+       egamesconf \
+               --disable-dependency-tracking \
+               $(use_enable opengl) || die
+       if ! use lua ; then
+               # stupid configure script doesnt have an option
+               dosed -i \
+                       -e '/HAVE_LUA/d' config.h \
+                       || die "sed HAVE_LUA"
+               dosed -i \
+                       -e '/^LIBS/s:-llua -llualib::' $(find -name Makefile) \
+                       || die "sed -llua"
+       fi
+       if ! use speex ; then
+               # stupid configure script doesnt have an option
+               dosed -i \
+                       -e '/SPEEX/d:' config.h \
+                       || die "sed SPEEX"
+               dosed -i \
+                       -e '/^LIBS/s:-lspeex::' $(find -name Makefile) \
+                       || die "sed -lspeex"
+       fi
+       emake || die "emake failed"
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die "make install failed"
+       dogamesbin alephone.sh || die "failed to install wrapper"
+       dodoc AUTHORS README docs/Cheat_Codes
+       dohtml docs/MML.html
+       doicon alephone.png
+       prepgamesdirs
+}
+
+pkg_postinst() {
+       games_pkg_postinst
+       echo
+       einfo "Read the docs and install the data files accordingly to play."
+       echo
+       einfo "If you only want to install one scenario, read"
+       einfo "http://traxus.jjaro.net/traxus/AlephOne:Install_Guide#Single_scenario_3"
+       einfo "If you want to install multiple scenarios, read"
+       einfo "http://traxus.jjaro.net/traxus/AlephOne:Install_Guide#Multiple_scenarios_3"
+       echo
+}
diff --git a/games-fps/alephone/files/digest-alephone-20060701 b/games-fps/alephone/files/digest-alephone-20060701
new file mode 100644 (file)
index 0000000..b4112af
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 55adc626db175f9312613055a53276f2 AlephOne-20060701-nolibs.tar.bz2 1259392
+RMD160 e8b47276162e56e57a79822fee2d970dbe729d50 AlephOne-20060701-nolibs.tar.bz2 1259392
+SHA256 d68635020c91cfed4a703879c84aefdfbd97064798bf91a3dec954ff5fc593cd AlephOne-20060701-nolibs.tar.bz2 1259392