sci-libs/cantera: Fix site-packages install paths
authorSergey Torokhov <torokhov-s-a@yandex.ru>
Tue, 21 Apr 2020 01:17:42 +0000 (04:17 +0300)
committerMatthias Maier <tamiko@gentoo.org>
Tue, 5 May 2020 16:49:57 +0000 (11:49 -0500)
Python 3.7 and 3.8 site-packages dirs are located under /lib
for amd64 arch now (instead of /lib64 like for python2.7 and python3.6)
so the changes for python installation patch is required.

Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
sci-libs/cantera/cantera-2.4.0-r5.ebuild
sci-libs/cantera/files/cantera_2.4.0_env_python_install_prefix.patch [new file with mode: 0644]

index 78f23ee905bbce38122bcb221dab9079c247feac..e4d8b7de2c0b43f3eef2670b3506900f7936aad4 100644 (file)
@@ -52,9 +52,9 @@ DEPEND="
 
 PATCHES=(
        "${FILESDIR}/${PN}_${PV}_env.patch"
-       "${FILESDIR}/${PN}_${PV}_env_python_install.patch"
+       "${FILESDIR}/${PN}_${PV}_env_python_install_prefix.patch"
        "${FILESDIR}/${PN}_${PV}_sundials4.patch"
-       )
+)
 
 pkg_setup() {
        fortran-2_pkg_setup
@@ -107,7 +107,7 @@ src_test() {
 }
 
 src_install() {
-       escons install stage_dir="${D}" libdirname="$(get_libdir)"
+       escons install stage_dir="${D}" libdirname="$(get_libdir)" python3_prefix="$(python_get_sitedir)"
        if ! use cti ; then
                rm -r "${D}/usr/share/man" || die "Can't remove man files."
        else
diff --git a/sci-libs/cantera/files/cantera_2.4.0_env_python_install_prefix.patch b/sci-libs/cantera/files/cantera_2.4.0_env_python_install_prefix.patch
new file mode 100644 (file)
index 0000000..8389079
--- /dev/null
@@ -0,0 +1,17 @@
+diff -Nur old/interfaces/cython/SConscript new/interfaces/cython/SConscript
+--- old/interfaces/cython/SConscript   2018-08-24 16:24:45.000000000 +0300
++++ new/interfaces/cython/SConscript   2019-08-14 04:28:41.000000000 +0300
+@@ -83,10 +83,10 @@
+             extra = ''
+         elif localenv['OS'] == 'Darwin':
+             extra = localenv.subst(' --prefix=${python%s_prefix}' % major)
+-        elif localenv['libdirname'] == 'lib64':
+-            # 64-bit RHEL / Fedora
++        elif localenv['libdirname'] != 'lib':
++            # 64-bit RHEL / Fedora etc. or e.g. x32 Gentoo profile
+             extra = localenv.subst(
+-                ' --prefix=${python%s_prefix} --install-lib=${python%s_prefix}/lib64/python%s.%s/site-packages' % (major, major, major, minor))
++                ' --prefix=${stage_dir}${prefix} --install-lib=${python%s_prefix}' % (major))
+         else:
+             extra = '--user'
+             localenv.AppendENVPath(