mail-client/alpine: don't call cc directly
authorRobert Siebeck <gentoo.2019@r123.de>
Sun, 19 Apr 2020 22:02:26 +0000 (00:02 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 22 Apr 2020 13:38:38 +0000 (16:38 +0300)
Closes: https://bugs.gentoo.org/718368
Signed-off-by: Robert Siebeck <gentoo.2019@r123.de>
Closes: https://github.com/gentoo/gentoo/pull/15424
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
mail-client/alpine/alpine-2.22.ebuild
mail-client/alpine/files/alpine-2.22-cc.patch [new file with mode: 0644]

index 75f6d6673383a5995f0a56de29efe34c6a59c048..c2b83e1187b56cc524b70e1d60235a23c896e00e 100644 (file)
@@ -27,9 +27,15 @@ RDEPEND="${DEPEND}
        app-misc/mime-types
 "
 
+PATCHES=(
+       "${FILESDIR}/${P}-cc.patch"
+)
+
 src_prepare() {
        default
        eautoreconf
+       tc-export CC RANLIB AR
+       export CC_FOR_BUILD=$(tc-getBUILD_CC)
 }
 
 src_configure() {
diff --git a/mail-client/alpine/files/alpine-2.22-cc.patch b/mail-client/alpine/files/alpine-2.22-cc.patch
new file mode 100644 (file)
index 0000000..87132bd
--- /dev/null
@@ -0,0 +1,24 @@
+--- ./imap/tools/Makefile      2020-04-19 23:45:13.080083548 +0200
++++ ./imap/tools/Makefile      2020-04-19 23:45:24.525083844 +0200
+@@ -21,7 +21,6 @@
+ #              Internet: MRC@CAC.Washington.EDU
+-CC=cc
+ RM=rm -f
+
+
+--- ./imap/src/osdep/unix/Makefile     2020-04-19 23:54:55.454098598 +0200
++++ ./imap/src/osdep/unix/Makefile     2020-04-19 23:54:55.454098598 +0200
+@@ -132,10 +132,8 @@
+
+ # Commands possibly overridden by the individual port
+
+-ARRC=ar rc
+-CC=cc
++ARRC=$(AR) rc
+ LN=ln -s
+-RANLIB=ranlib
+
+
+ # Standard distribution build parameters