dev-python/zope-deprecation: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 12:15:03 +0000 (14:15 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 29 Mar 2020 12:20:06 +0000 (14:20 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/zope-deprecation/Manifest
dev-python/zope-deprecation/zope-deprecation-4.2.0.ebuild [deleted file]

index 2f8a9720eaf44c5f8b5a50e40a36077943ba5a93..2a4b6b01e9090721cda7f47487a1e76b5168fec4 100644 (file)
@@ -1,2 +1 @@
-DIST zope.deprecation-4.2.0.tar.gz 223338 BLAKE2B 377ac7708d686aaa5b461a11a8088b52dbda303464f34aa990d7f7ae52cbdec3aee70fb05ea685b44279c9ef8a4b88cee4a39c364ed8c9c2ca6c04ff685bc090 SHA512 8ae5428d8e76014aaf17bfc05c88e7423be892f35bc9ec61f2f2919bb043fe0937cb592eec81763d9b6841ba3afa938e047cbecfacb9e4d29350e99f6ed417e6
 DIST zope.deprecation-4.4.0.tar.gz 24737 BLAKE2B 993959f47e7808ad9d024d5df9d141cdbce3a1a3c281acc0d90bdb20747743936411714b52a29fcac6968cea50d5ab54820954f74c3f59081ce98f097715b9a3 SHA512 62371dc45fad6715f24cdcac1d25b559ed5248da774b5ecd215fb4d0b6fc0ab655bfb9e0fbceda964e8ffb7d70536e43f8fcf09d9f2742904717a6473869fa4a
diff --git a/dev-python/zope-deprecation/zope-deprecation-4.2.0.ebuild b/dev-python/zope-deprecation/zope-deprecation-4.2.0.ebuild
deleted file mode 100644 (file)
index fcdf3e8..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 pypy3 )
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Zope Deprecation Infrastructure"
-HOMEPAGE="https://github.com/zopefoundation/zope.deprecation"
-SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
-# note: nosetests are not actually used or enforced via test_requires
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}/${MY_P}
-
-python_test() {
-       esetup.py test
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-
-       find "${ED}" -name '*.pth' -delete || die
-}