Fix broken tests. Bug #162044
authorDaniel Gryniewicz <dang@gentoo.org>
Fri, 26 Jan 2007 22:52:12 +0000 (22:52 +0000)
committerDaniel Gryniewicz <dang@gentoo.org>
Fri, 26 Jan 2007 22:52:12 +0000 (22:52 +0000)
Package-Manager: portage-2.1.2-r4

net-libs/libsoup/ChangeLog
net-libs/libsoup/files/libsoup-2.2.99-fix-tests.patch [new file with mode: 0644]
net-libs/libsoup/libsoup-2.2.99.ebuild

index f22568be3fa026c420a80b955c80b762b4ecd488..deafd1f27518ac22d23f1fae6c8557e79cec3c37 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for net-libs/libsoup
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.114 2007/01/23 21:37:58 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.115 2007/01/26 22:52:12 dang Exp $
+
+  26 Jan 2007; Daniel Gryniewicz <dang@gentoo.org>
+  +files/libsoup-2.2.99-fix-tests.patch, libsoup-2.2.99.ebuild:
+  Fix broken tests.  Bug #162044
 
   23 Jan 2007; Bryan Ã˜stergaard <kloeri@gentoo.org> libsoup-2.2.99.ebuild:
   Stable on Alpha + IA64.
diff --git a/net-libs/libsoup/files/libsoup-2.2.99-fix-tests.patch b/net-libs/libsoup/files/libsoup-2.2.99-fix-tests.patch
new file mode 100644 (file)
index 0000000..a873dca
--- /dev/null
@@ -0,0 +1,21 @@
+diff --exclude-from=/home/dang/.diffrc -up -ruN libsoup-2.2.99.orig/tests/header-parsing.c libsoup-2.2.99/tests/header-parsing.c
+--- libsoup-2.2.99.orig/tests/header-parsing.c 2007-01-06 13:11:03.000000000 -0500
++++ libsoup-2.2.99/tests/header-parsing.c      2007-01-26 17:47:03.000000000 -0500
+@@ -456,6 +456,8 @@ do_request_tests (void)
+       SoupHttpVersion version;
+       GHashTable *headers;
++      errors = 0;
++
+       printf ("Request tests\n");
+       for (i = 0; i < num_reqtests; i++) {
+               gboolean ok = TRUE;
+@@ -537,6 +539,8 @@ do_response_tests (void)
+       SoupHttpVersion version;
+       GHashTable *headers;
++      errors = 0;
++
+       printf ("Response tests\n");
+       for (i = 0; i < num_resptests; i++) {
+               gboolean ok = TRUE;
index 36a245dc46f49e935c756716d792f54871c827f7..6a78a61330e3f8ae45061384ac852b6b98411958 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.2.99.ebuild,v 1.8 2007/01/23 21:37:58 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.2.99.ebuild,v 1.9 2007/01/26 22:52:12 dang Exp $
 
-inherit gnome2
+inherit gnome2 eutils
 
 DESCRIPTION="An HTTP library implementation in C"
 HOMEPAGE="http://www.gnome.org/"
@@ -11,7 +11,6 @@ LICENSE="LGPL-2"
 SLOT="2.2"
 KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 ~sh sparc x86"
 IUSE="doc ssl"
-RESTRICT="test"
 
 RDEPEND=">=dev-libs/glib-2.6
        >=dev-libs/libxml2-2
@@ -27,3 +26,9 @@ DOCS="AUTHORS ChangeLog NEWS README"
 pkg_setup() {
        G2CONF="$(use_enable ssl)"
 }
+
+src_unpack() {
+       gnome2_src_unpack
+
+       epatch "${FILESDIR}"/${P}-fix-tests.patch
+}