dev-python/docker-py: Version bump to 3.5.1
authorManuel Rüger <mrueg@gentoo.org>
Wed, 7 Nov 2018 12:50:12 +0000 (13:50 +0100)
committerManuel Rüger <mrueg@gentoo.org>
Wed, 7 Nov 2018 12:50:12 +0000 (13:50 +0100)
Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-python/docker-py/Manifest
dev-python/docker-py/docker-py-3.5.1.ebuild [new file with mode: 0644]

index 0ce3a0d815e0bc26a201a8208ffa4a1a8dc9a515..2a6181b712378e26371a8837c2c9ee4dba6e78f8 100644 (file)
@@ -2,3 +2,4 @@ DIST docker-py-2.4.2.tar.gz 180890 BLAKE2B 57518a0c8481fde0198100354225cd8a2908a
 DIST docker-py-2.7.0.tar.gz 196369 BLAKE2B dd181dbf32f5afda06e748cb49f15d5fc6ff4a579c64b505308ad0d96913ddc8065d165090ec2b20e1f17a4519988a5665dd7a8c7643ca53aaa4385ceecb1341 SHA512 15cf1d8949d71e472f7636ff975cbc4c5f3e18e2d193cb603ade1397a56d0c1ec239167b71be325af99105bc36590a0f0faa1ab010f36fe8baca7807ddfa191b
 DIST docker-py-3.4.1.tar.gz 207885 BLAKE2B 472f5dde4761b02a2b55c64762a0529dbaecc8aa9f0e24c67770f533341a5ca9c7322bfacba81f99f9305f09d4e5f7d7ccf37201f5e987777c33c6f81552a807 SHA512 447dccb9129d549886882e6cf0a8ac56d91f7ed57b6aa1dca1942c62d70dc78b92184cbdd9ac5f3445be04cfaadf0b4fba191fb70e223e93c6d1cfbfd334a397
 DIST docker-py-3.5.0.tar.gz 209142 BLAKE2B 56e4400e1f67c870274eb2fdaf84edeac966a1486366355f2697f0fc4e5f37c5e4f3f8163e9187219a4fa27cd43be2bc19370a99755fa880c9e089d6af9bcc9e SHA512 c5ebc99df66d49f53c39ff897bd95afcbb92ced3ec6fd61148b6775cddf9e830454b1da5ac79ea0bba76f143f35f29dec66e7db5c6df33ca5157d3fe40cd4e93
+DIST docker-py-3.5.1.tar.gz 209381 BLAKE2B de0992aff9af240eeb79b66f0f7ca11aca4132cbef0ca9796cfa778b0f44e2ebf83858d0e4df2b9dd813caa83e1c301829152362a6983e5ee96dd5806815ee6f SHA512 8e927794cd308e17fc75f3c6569026c9b9c9f44eb2aa1c191dcfc6d1aabc36bdd341795ba9a2243ae2a27c428868c9f45e8bfabd7c1c798f3f4c85b7855eda6d
diff --git a/dev-python/docker-py/docker-py-3.5.1.ebuild b/dev-python/docker-py/docker-py-3.5.1.ebuild
new file mode 100644 (file)
index 0000000..2f675a4
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+       >=dev-python/docker-pycreds-0.3.0[${PYTHON_USEDEP}]
+       !~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+       >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_4' )
+       $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+               dev-python/pytest-runner[${PYTHON_USEDEP}]
+               >=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
+       )
+       doc? (
+               dev-python/recommonmark[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
+       )
+"
+
+python_compile_all() {
+       if use doc; then
+               sphinx-build docs html || die "docs failed to build"
+               HTML_DOCS=( html/. )
+       fi
+}
+
+python_test() {
+       py.test tests/unit/ || die "tests failed under ${EPYTHON}"
+}