dev-python/pycurl: Replace distutils-r1 EXAMPLES use
authorDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:58 +0000 (10:56 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 20 Mar 2020 09:56:58 +0000 (10:56 +0100)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/pycurl/pycurl-7.43.0.ebuild

index 709ce8c1f28c1b90ca8e03d671bc5f5b40cac95c..6d0938ac010108f266fae4ec23b4117e8204d444 100644 (file)
@@ -72,6 +72,10 @@ python_test() {
 
 python_install_all() {
        local HTML_DOCS=( doc/. )
-       use examples && local EXAMPLES=( examples/. )
+       if use examples; then
+               dodoc -r examples
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+
        distutils-r1_python_install_all
 }