sys-cluster/glusterfs: bump to 6.1
authorTomas Mozes <tmozes@sygic.com>
Wed, 8 May 2019 03:03:09 +0000 (03:03 +0000)
committerAlexys Jacob <ultrabug@gentoo.org>
Wed, 8 May 2019 16:55:19 +0000 (18:55 +0200)
Closes: https://bugs.gentoo.org/685208
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/11934
Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
sys-cluster/glusterfs/Manifest
sys-cluster/glusterfs/glusterfs-6.1.ebuild [new file with mode: 0644]

index 41f0afcee319439744f57ad4565d1f2bbce237df..8a76bec054aff15eb5779dad47e07d85f976fcd9 100644 (file)
@@ -1,3 +1,4 @@
 DIST glusterfs-4.1.5.tar.gz 7783999 BLAKE2B ac1e7732430fe25eec34a8b85b9cd5ce4f43076befec2d91c0156959887d8a0589adb8afb1ee9290e436ce40ab7e5567c3c4ec90017b4398919637e2047f18b9 SHA512 ae557472b6a263e815b8c4d630b606f8e1334b6604799e499e6f53ea6ff60c2a696160fa427943cc3d01ffee91a57787c91f93a1b914179679038e63d291401f
 DIST glusterfs-4.1.8.tar.gz 7835272 BLAKE2B 2546b9c0fe38989df71b8f72b193ce42c499621dcaaa4c5e3deeacfba68179f2280fc699cebeb87486171442152fa8b56b42a0d17465b739769eb227c82307d7 SHA512 950cd2fd774e3eb00f1ec06d54566736b6fbe8d1aed54477a19d9b2727eff8a70ef7ac32815cc7e01d45b5d357fc01af786e16c451f6ad314d472e61ba04ce85
 DIST glusterfs-6.0.tar.gz 7495110 BLAKE2B 89fde01732dbbcecdf514d196e3bac683caaaaefb3658b4e92f1bbf73ca09defa4de9366066a00528564acfbe93c3f65cfabbeb0d830c00f29ee9c99ed7bf08a SHA512 fc4f4ee75b3936469b7c4be146545eb88d2cf3583d5f101bcacb2805c842aa95f69d1c023dee4dac32ebe01cdc9ede4814f9364482e8815e451e43660e6c74b9
+DIST glusterfs-6.1.tar.gz 7510074 BLAKE2B 8002597f8f695d11578be250cafb3f32358ac29d873b27f87bb26edd38b64d896050322d9591b156793fe6ee7af111904961d5a3e7a933f7c5176cf0c6793305 SHA512 53f4195ecb565a8dcc0d66e74d07dd7334e3c8b1cc1671517612be32a00e9e9bbfb5e983955c4f116b25f7df990bcd1c05bbd3d0b740e9f8c76a16b9b16bec00
diff --git a/sys-cluster/glusterfs/glusterfs-6.1.ebuild b/sys-cluster/glusterfs/glusterfs-6.1.ebuild
new file mode 100644 (file)
index 0000000..e9acb97
--- /dev/null
@@ -0,0 +1,207 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit autotools elisp-common python-single-r1 systemd user
+
+if [[ ${PV#9999} != ${PV} ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/gluster/glusterfs.git"
+else
+       SRC_URI="https://download.gluster.org/pub/gluster/${PN}/$(ver_cut 1)/${PV}/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="GlusterFS is a powerful network/cluster filesystem"
+HOMEPAGE="https://www.gluster.org/"
+
+LICENSE="|| ( GPL-2 LGPL-3+ )"
+SLOT="0"
+IUSE="debug emacs +fuse +georeplication infiniband ipv6 libressl +libtirpc rsyslog static-libs +syslog test vim-syntax +xml"
+
+REQUIRED_USE="georeplication? ( ${PYTHON_REQUIRED_USE} )
+       ipv6? ( libtirpc )"
+
+# the tests must be run as root
+RESTRICT="test"
+
+# sys-apps/util-linux is required for libuuid
+RDEPEND="!elibc_glibc? ( sys-libs/argp-standalone )
+       emacs? ( virtual/emacs )
+       fuse? ( >=sys-fs/fuse-2.7.0:0 )
+       georeplication? ( ${PYTHON_DEPS} )
+       infiniband? ( sys-fabric/libibverbs:* sys-fabric/librdmacm:* )
+       libtirpc? ( net-libs/libtirpc:= )
+       !libtirpc? ( elibc_glibc? ( sys-libs/glibc[rpc(-)] ) )
+       xml? ( dev-libs/libxml2 )
+       sys-libs/readline:=
+       dev-libs/libaio
+       !libressl? ( dev-libs/openssl:=[-bindist] )
+       libressl? ( dev-libs/libressl:= )
+       dev-libs/userspace-rcu:=
+       net-libs/rpcsvc-proto
+       sys-apps/util-linux"
+DEPEND="${RDEPEND}
+       virtual/acl
+       virtual/pkgconfig
+       sys-devel/bison
+       sys-devel/flex
+       test? ( >=dev-util/cmocka-1.0.1
+               app-benchmarks/dbench
+               dev-vcs/git
+               net-fs/nfs-utils
+               virtual/perl-Test-Harness
+               dev-libs/yajl
+               sys-fs/xfsprogs
+               sys-apps/attr )"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )
+
+# Maintainer notes:
+# * The build system will always configure & build argp-standalone but it'll never use it
+#   if the argp.h header is found in the system. Which should be the case with
+#   glibc or if argp-standalone is installed.
+
+pkg_setup() {
+       python_setup "python3*"
+       python-single-r1_pkg_setup
+
+       # Needed for statedumps
+       # https://github.com/gluster/glusterfs/commit/0e50c4b3ea734456c14e2d7a578463999bd332c3
+       enewgroup gluster
+       enewuser gluster -1 -1 "${EPREFIX}"/var/run/gluster gluster
+}
+
+src_prepare() {
+       default
+
+       # build rpc-transport and xlators only once as shared libs
+       find rpc/rpc-transport xlators -name Makefile.am |
+               xargs sed -i 's|.*$(top_srcdir).*\.sym|\0 -shared|' || die
+
+       # fix execution permissions
+       chmod +x libglusterfs/src/gen-defaults.py || die
+
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --disable-dependency-tracking \
+               --disable-silent-rules \
+               --disable-fusermount \
+               $(use_enable debug) \
+               $(use_enable fuse fuse-client) \
+               $(use_enable georeplication) \
+               $(use_enable infiniband ibverbs) \
+               $(use_enable static-libs static) \
+               $(use_enable syslog) \
+               $(use_enable test cmocka) \
+               $(use_enable xml xml-output) \
+               $(use libtirpc || echo --without-libtirpc) \
+               $(use ipv6 && echo --with-ipv6-default) \
+               --with-tmpfilesdir="${EPREFIX}"/etc/tmpfiles.d \
+               --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+               --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+       default
+       use emacs && elisp-compile extras/glusterfs-mode.el
+}
+
+src_install() {
+       default
+
+       rm \
+               "${ED}"/etc/glusterfs/glusterfs-{georep-,}logrotate \
+               "${ED}"/etc/glusterfs/gluster-rsyslog-*.conf \
+               "${ED}"/usr/share/doc/${PF}/glusterfs{-mode.el,.vim} || die "removing false files failed"
+
+       insinto /etc/logrotate.d
+       newins "${FILESDIR}"/glusterfs.logrotate glusterfs
+
+       if use rsyslog ; then
+               insinto /etc/rsyslog.d
+               newins extras/gluster-rsyslog-7.2.conf 60-gluster.conf
+       fi
+
+       if use emacs ; then
+               elisp-install ${PN} extras/glusterfs-mode.el*
+               elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+       fi
+
+       if use vim-syntax ; then
+               insinto /usr/share/vim/vimfiles/ftdetect; doins "${FILESDIR}"/${PN}.vim
+               insinto /usr/share/vim/vimfiles/syntax; doins extras/${PN}.vim
+       fi
+
+       # insert some other tools which might be useful
+       insinto /usr/share/glusterfs/scripts
+       doins \
+               extras/backend-{cleanup,xattr-sanitize}.sh \
+               extras/clear_xattrs.sh \
+               extras/migrate-unify-to-distribute.sh
+
+       # correct permissions on installed scripts
+       # fperms 0755 /usr/share/glusterfs/scripts/*.sh
+       chmod 0755 "${ED}"/usr/share/glusterfs/scripts/*.sh || die
+
+       if use georeplication ; then
+               # move the gsync-sync-gfid tool to a binary path
+               # and set a symlink to be compliant with all other distros
+               mv "${ED}"/usr/{share/glusterfs/scripts/gsync-sync-gfid,libexec/glusterfs/} || die
+               dosym ../../../libexec/glusterfs/gsync-sync-gfid /usr/share/glusterfs/scripts/gsync-sync-gfid
+       fi
+
+       newinitd "${FILESDIR}/${PN}-r1.initd" glusterfsd
+       newinitd "${FILESDIR}/glusterd-r3.initd" glusterd
+       newconfd "${FILESDIR}/${PN}.confd" glusterfsd
+
+       keepdir /var/log/${PN}
+       keepdir /var/lib/glusterd/{events,glusterfind/.keys}
+
+       # QA
+       rm -r "${ED}/var/run/" || die
+       if ! use static-libs; then
+               find "${D}" -type f -name '*.la' -delete || die
+       fi
+}
+
+src_test() {
+       ./run-tests.sh || die
+}
+
+pkg_postinst() {
+       elog "Starting with ${PN}-3.1.0, you can use the glusterd daemon to configure your"
+       elog "volumes dynamically. To do so, simply use the gluster CLI after running:"
+       elog "  /etc/init.d/glusterd start"
+       echo
+       elog "For static configurations, the glusterfsd startup script can be multiplexed."
+       elog "The default startup script uses /etc/conf.d/glusterfsd to configure the"
+       elog "separate service.  To create additional instances of the glusterfsd service"
+       elog "simply create a symlink to the glusterfsd startup script."
+       echo
+       elog "Example:"
+       elog "    # ln -s glusterfsd /etc/init.d/glusterfsd2"
+       elog "    # ${EDITOR} /etc/glusterfs/glusterfsd2.vol"
+       elog "You can now treat glusterfsd2 like any other service"
+       echo
+       ewarn "You need to use a ntp client to keep the clocks synchronized across all"
+       ewarn "of your servers. Setup a NTP synchronizing service before attempting to"
+       ewarn "run GlusterFS."
+       echo
+       elog "If you are upgrading from a previous version of ${PN}, please read:"
+       elog "  http://docs.gluster.org/en/latest/Upgrade-Guide/upgrade_to_$(ver_cut '1-2')/"
+
+       use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}