sci-biology/sim4: Modernise to EAPI 6
authorDavid Seifert <soap@gentoo.org>
Sat, 25 Feb 2017 20:30:10 +0000 (21:30 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 25 Feb 2017 20:35:14 +0000 (21:35 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sci-biology/sim4/files/sim4-20030921-fix-build-system.patch [new file with mode: 0644]
sci-biology/sim4/sim4-20030921-r2.ebuild [new file with mode: 0644]

diff --git a/sci-biology/sim4/files/sim4-20030921-fix-build-system.patch b/sci-biology/sim4/files/sim4-20030921-fix-build-system.patch
new file mode 100644 (file)
index 0000000..8fd50fe
--- /dev/null
@@ -0,0 +1,21 @@
+Fix build system to honour user flags.
+
+--- a/Makefile
++++ b/Makefile
+@@ -1,13 +1,11 @@
+-
+ # For better performance, replace ``-O'' with whatever
+ # the best optimization flag is for your computer.
+ # For Sun's compilers under Solaris, ``-fast'' works well.
+ # For gcc, ``-O2'' works well.
+-CC=cc
+-CFLAGS=-O
+-LDLIBS=-lm
++CC ?= gcc
++LDLIBS = -lm
+  
+ sim4:
+-      $(CC) -o sim4 -I. $(CFLAGS) *.c $(LDLIBS)
++      $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -o sim4 -I. *.c $(LDLIBS)
+ clean:
+       rm -f sim4 *.o
diff --git a/sci-biology/sim4/sim4-20030921-r2.ebuild b/sci-biology/sim4/sim4-20030921-r2.ebuild
new file mode 100644 (file)
index 0000000..dcfe354
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A program to align cDNA and genomic DNA"
+HOMEPAGE="http://globin.cse.psu.edu/html/docs/sim4.html"
+SRC_URI="http://globin.cse.psu.edu/ftp/dist/sim4/sim4.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}.2003-09-21
+
+PATCHES=( "${FILESDIR}"/${PN}-20030921-fix-build-system.patch )
+
+src_configure() {
+       tc-export CC
+}
+
+src_install() {
+       dobin ${PN}
+       einstalldocs
+}