dev-python/llvmlite: Reintroduce llvmlite-0.1{5,6}.0
authorJan Vesely <jano.vesely@gmail.com>
Sat, 22 Jul 2017 01:40:50 +0000 (21:40 -0400)
committerMichał Górny <mgorny@gentoo.org>
Sat, 22 Jul 2017 06:36:55 +0000 (08:36 +0200)
Partially reverts cf5e834b711289a1cfd70b5b99228a577eb32d57
Different versions work with different versions of LLVM.
See https://github.com/numba/llvmlite

Closes: https://github.com/gentoo/gentoo/pull/5165
Signed-off-by: Jan Vesely <jano.vesely@gmail.com>
dev-python/llvmlite/Manifest
dev-python/llvmlite/llvmlite-0.15.0.ebuild [new file with mode: 0644]
dev-python/llvmlite/llvmlite-0.16.0.ebuild [new file with mode: 0644]

index 0a6100b321e5d10e99bfa93a575cac78224c1fdd..b4f071ac63a024e74a08899d8ec90698e649144d 100644 (file)
@@ -1,2 +1,4 @@
 DIST llvmlite-0.12.1.tar.gz 88271 SHA256 3ce71beebd4cbc7a49abe4eadfc99725477fd43caeb7405650ebb746c7a1d0df SHA512 f5b448f0ae3d84a0d3438dd7bb4c7f87055e551191c4fefb6282539029d25e8c5e1cca9dec5b90c0d99ec0a720719133b2ccf8b9551aa818c3b4626cc522d8d9 WHIRLPOOL 82b3e60520eda83d0e4082d75ca377bd34c9baf7c67688814e6dd3a7ae687b1eacf7ddd9758254e0c61f39ea5af77c847a15f1f8071cf030d9dd07bb2b1020a5
+DIST llvmlite-0.15.0.tar.gz 95009 SHA256 c855835537eda61f3a0d19aedc44f006d5084a2d322aee8ffa87aa06bb800dc4 SHA512 db49ed82eae989e7e7abbd72f1c1da5129887f7fce447c684085f98ae2aaf47d24e73b79c5916802edbb8dc55dda92efeac833cb903300560b1aa89f2aeb5dca WHIRLPOOL 66336fa610ae2706c9281f5e7febc8e76e0cacf8cbc151952f6978adb104bcc6b98ac65d9661c7289f258e1e63a1e6e4a139f93efc45cdfd2a26f50c35bc03fb
+DIST llvmlite-0.16.0.tar.gz 95284 SHA256 ef3bae32482f91742d91571b5225a6943804291eb9405b98090a7b50942ec5e9 SHA512 97a251ef9d840fc5a25bd673c644207750f2e653ccad5850dec0a7f1bc77170c6ce85d5cd663ab5c109cb1b51ced9545493d35ef81dfe04a3696b5a0c37fa768 WHIRLPOOL ab629a507c2cc27756109162469a0eed8f4dbb059b7c3957df65e059c6e613581fed6380b58686812ed5378a9d2ebe5f754e6de1a5132c89a323b221da203e91
 DIST llvmlite-0.19.0.tar.gz 97109 SHA256 fbaeb3d584e0f6bac82a33776e9b5f0b5b4a3415a03edeff5d66f6176f0edbe2 SHA512 93551bbab519021abdc66ca099b9090b3af54b048adbce8d16f3700c066bbc4f5c24e5234a8a1ac4bfcdf8bf74d0ac52bb7023251ac948af6ef99fbd5a5324c8 WHIRLPOOL ee6170c09ac897862fee4705b8131f6dfb97a980c8aec73a9316f7d0d57dfeb4a0e3bd629f536cfeb51df682b4838b1c4e267ff3ebaf54f2f5db7193062014f5
diff --git a/dev-python/llvmlite/llvmlite-0.15.0.ebuild b/dev-python/llvmlite/llvmlite-0.15.0.ebuild
new file mode 100644 (file)
index 0000000..9649c7d
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper around the llvm C++ library"
+HOMEPAGE="http://llvmlite.pydata.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+       dev-python/six[${PYTHON_USEDEP}]
+       =sys-devel/llvm-3.8*
+       sys-libs/zlib:0=
+       virtual/python-enum34[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+PATCHES=(
+       "${FILESDIR}"/${P}-use-system-six.patch
+)
+
+python_prepare_all() {
+       sed -e 's/-flto$/-flto -fPIC/' \
+               -i ffi/Makefile.linux || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       use examples && local EXAMPLES=( examples/. )
+       distutils-r1_python_install_all
+}
diff --git a/dev-python/llvmlite/llvmlite-0.16.0.ebuild b/dev-python/llvmlite/llvmlite-0.16.0.ebuild
new file mode 100644 (file)
index 0000000..47ce82f
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper around the llvm C++ library"
+HOMEPAGE="http://llvmlite.pydata.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+       dev-python/six[${PYTHON_USEDEP}]
+       =sys-devel/llvm-3.9*
+       sys-libs/zlib:0=
+       virtual/python-enum34[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+PATCHES=(
+       "${FILESDIR}"/llvmlite-0.15.0-use-system-six.patch
+)
+
+python_prepare_all() {
+       # remove -static-libstdc++, it makes no sense with shared LLVM
+       # add -fPIC, needed to link against shared libraries
+       # disable -flto, we do not force it against user's wishes
+       sed -e 's/-static-libstdc++/-fPIC/' \
+               -e '/^(CXX|LD)_FLTO_FLAGS/d' \
+               -i ffi/Makefile.linux || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       use examples && local EXAMPLES=( examples/. )
+       distutils-r1_python_install_all
+}