app-editors/emacs-vcs: Output warning message for USE="-gtk gtk2".
authorUlrich Müller <ulm@gentoo.org>
Fri, 24 Aug 2018 05:25:45 +0000 (07:25 +0200)
committerUlrich Müller <ulm@gentoo.org>
Fri, 24 Aug 2018 05:25:45 +0000 (07:25 +0200)
Package-Manager: Portage-2.3.47, Repoman-2.3.10

app-editors/emacs-vcs/emacs-vcs-26.1.9999.ebuild
app-editors/emacs-vcs/emacs-vcs-27.0.50_pre20180731.ebuild
app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild

index 1f69edf59adedc270a088f47dcdb37023fe11b48..4b2ebe730b27a03ea15004335279299559e08697 100644 (file)
@@ -234,8 +234,12 @@ src_configure() {
                        einfo "Configuring to build with no toolkit"
                        myconf+=" --with-x-toolkit=no"
                fi
-               ! use gtk && use xwidgets && ewarn \
-                       "USE flag \"xwidgets\" has no effect if \"gtk\" is not set."
+               if ! use gtk; then
+                       use gtk2 && ewarn \
+                               "USE flag \"gtk2\" has no effect if \"gtk\" is not set."
+                       use xwidgets && ewarn \
+                               "USE flag \"xwidgets\" has no effect if \"gtk\" is not set."
+               fi
        elif use aqua; then
                einfo "Configuring to build with Nextstep (Cocoa) support"
                myconf+=" --with-ns --disable-ns-self-contained"
index c5898b1c2dd7022d0c773b6c2c540897ef46df72..65e8e0a1bbaf2b3068f7c1f9a2e9584f389b8c56 100644 (file)
@@ -235,8 +235,12 @@ src_configure() {
                        einfo "Configuring to build with no toolkit"
                        myconf+=" --with-x-toolkit=no"
                fi
-               ! use gtk && use xwidgets && ewarn \
-                       "USE flag \"xwidgets\" has no effect if \"gtk\" is not set."
+               if ! use gtk; then
+                       use gtk2 && ewarn \
+                               "USE flag \"gtk2\" has no effect if \"gtk\" is not set."
+                       use xwidgets && ewarn \
+                               "USE flag \"xwidgets\" has no effect if \"gtk\" is not set."
+               fi
        elif use aqua; then
                einfo "Configuring to build with Nextstep (Cocoa) support"
                myconf+=" --with-ns --disable-ns-self-contained"
index 3cb2cdf754ad664dd4d957880ebd8aea53a33048..2862235ef56e5ae1a2e80c5f82fd9abdf662685d 100644 (file)
@@ -237,8 +237,12 @@ src_configure() {
                        einfo "Configuring to build with no toolkit"
                        myconf+=" --with-x-toolkit=no"
                fi
-               ! use gtk && use xwidgets && ewarn \
-                       "USE flag \"xwidgets\" has no effect if \"gtk\" is not set."
+               if ! use gtk; then
+                       use gtk2 && ewarn \
+                               "USE flag \"gtk2\" has no effect if \"gtk\" is not set."
+                       use xwidgets && ewarn \
+                               "USE flag \"xwidgets\" has no effect if \"gtk\" is not set."
+               fi
        elif use aqua; then
                einfo "Configuring to build with Nextstep (Cocoa) support"
                myconf+=" --with-ns --disable-ns-self-contained"