dev-util/ccache: bump up to 3.7.2
authorSergei Trofimovich <slyfox@gentoo.org>
Fri, 19 Jul 2019 18:41:43 +0000 (19:41 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Fri, 19 Jul 2019 18:42:22 +0000 (19:42 +0100)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-util/ccache/Manifest
dev-util/ccache/ccache-3.7.2.ebuild [new file with mode: 0644]

index ebf3be2e50c947087826a971153eaa5c642cbbef..2ea5902cc8900f0bf5ac34b81a207d0436789cd7 100644 (file)
@@ -4,4 +4,5 @@ DIST ccache-3.5.1a.tar.xz 335888 BLAKE2B 66c044b39dd42c91327e02528a4d6c917ac012c
 DIST ccache-3.5.tar.xz 334668 BLAKE2B e3e2b63e8c4c8074514fb3a5794325fa05a4d52f48fc436ab0ad21b643ca4d1a1502c989cb47ed68972b105d4f1642e4fadc5ecef1235fe2bd3be5d218094a79 SHA512 92181fb794f06dc231baa4193c37e8f1d844c9281fd64bcb8f4b35c87b4a88dfc9bf36b810b37151ee85699778fcd3783818949a7010e619aeca7e3b33b7a2e3
 DIST ccache-3.6.tar.xz 340608 BLAKE2B fa92180f53612f84b71c68da4acccefee129e5bfc9b269caa45a9c16219ed835ccf034d61ff938a54f3673fa23410d960475cc37cf5d27d7be641e7518a43f0a SHA512 13ce4c9084983ce77617cf005235987715cd6b630dac13a17cb9badce24aab71bff505e63da4206878e32d337cc674f05fbf78540711ec5b33a0b8384c47fa0d
 DIST ccache-3.7.1.tar.xz 349276 BLAKE2B 4f36ccb378b614668777d8be32dd343a0e59e36885a845ba004082f7ca0f69a5e4d01ed08af445c33bff218d33ad0385ed6ade383c06da20e3d0271b2f7423dd SHA512 c2f369c861998f82600272deedc436840af7f85baa355a1e119dacea8f41275d601a0805c3e2a8bc434df621a4e52647bd8654a71c2329542a8b160f7f179cdf
+DIST ccache-3.7.2.tar.xz 351168 BLAKE2B 6e5c8847f961bd5aa2cf325e582ece9e8bfb9c015fe3dcb01c8ca1e1834fdfb82a351ec49e203721486817df58c6aebf28e0af011f470fb739d5016f72191654 SHA512 3290f0609c27a2f063e632392be01ef163273115700f87a6d2954fcfd52fcc14bf66fc147ecbd2b692258317e113bf8be9f7efdf377560e2e8d9dd67cef58147
 DIST ccache-3.7.tar.xz 348764 BLAKE2B a80ac0d5d94ff5d1aaee45a186037a9c8346c5e44d00afd29a4ba40b4fca877cd30b82357f344bed77f5caeb333bacfde8aff46d8fb866b484a3a1d3e5f513f5 SHA512 b8a5944072fcf8280b63ddbd6e2fcbc04d4ee99c0b2d3bfb9b47f61e760ce1dc5e191cf3f6437431b6d08af6cfb2162d6a2021ad49fd6746e531eb03cc26fd2e
diff --git a/dev-util/ccache/ccache-3.7.2.ebuild b/dev-util/ccache/ccache-3.7.2.ebuild
new file mode 100644 (file)
index 0000000..b8912dd
--- /dev/null
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="https://ccache.dev/"
+SRC_URI="https://github.com/ccache/ccache/releases/download/v${PV}/ccache-${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+IUSE=""
+
+DEPEND="app-arch/xz-utils
+       sys-libs/zlib"
+RDEPEND="${DEPEND}
+       dev-util/shadowman
+       sys-apps/gentoo-functions"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-3.4-size-on-disk.patch #456178
+       "${FILESDIR}"/${PN}-3.5-nvcc-test.patch
+       "${FILESDIR}"/${PN}-3.6-disable-sized-cleanup.patch #649440
+)
+
+src_prepare() {
+       default
+
+       # make sure we always use system zlib
+       rm -rf src/zlib || die
+       sed \
+               -e "/^EPREFIX=/s:'':'${EPREFIX}':" \
+               "${FILESDIR}"/ccache-config-3 > ccache-config || die
+}
+
+src_compile() {
+       emake V=1
+}
+
+src_test() {
+       emake check V=1
+}
+
+src_install() {
+       DOCS=( doc/{AUTHORS,MANUAL,NEWS}.adoc CONTRIBUTING.md README.md )
+       default
+
+       dobin ccache-config
+       insinto /usr/share/shadowman/tools
+       newins - ccache <<<'/usr/lib/ccache/bin'
+
+       DOC_CONTENTS="
+To use ccache with **non-Portage** C compiling, add
+'${EPREFIX}/usr/lib/ccache/bin' to the beginning of your path, before
+'${EPREFIX}/usr/bin'. Portage will automatically take advantage of ccache with
+no additional steps.  If this is your first install of ccache, type
+something like this to set a maximum cache size of 2GB:\\n
+# ccache -M 2G\\n
+If you are upgrading from an older version than 3.x you should clear all of your caches like so:\\n
+# CCACHE_DIR='${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}' ccache -C\\n
+ccache now supports sys-devel/clang and dev-lang/icc, too!"
+
+       readme.gentoo_create_doc
+}
+
+pkg_prerm() {
+       if [[ -z ${REPLACED_BY_VERSION} && ${ROOT:-/} == / ]] ; then
+               eselect compiler-shadow remove ccache
+       fi
+}
+
+pkg_postinst() {
+       if [[ ${ROOT:-/} == / ]]; then
+               eselect compiler-shadow update ccache
+       fi
+
+       # nuke broken symlinks from previous versions that shouldn't exist
+       rm -rf "${EROOT}"/usr/lib/ccache.backup || die
+
+       readme.gentoo_print_elog
+}