games-misc/typespeed: Stop using games.eclass
authorPacho Ramos <pacho@gentoo.org>
Tue, 1 May 2018 09:48:45 +0000 (11:48 +0200)
committerPacho Ramos <pacho@gentoo.org>
Tue, 1 May 2018 19:31:47 +0000 (21:31 +0200)
Package-Manager: Portage-2.3.31, Repoman-2.3.9

games-misc/typespeed/files/typespeed-0.6.5-musl.patch
games-misc/typespeed/typespeed-0.6.5-r1.ebuild [new file with mode: 0644]

index 3fd53b328ebdc00a9aabf2c8074ef1eb28662048..3967b10f3428f17ce141c7f7e1be0eefbeeaafb8 100644 (file)
@@ -1,6 +1,6 @@
 diff -ur a/typespeed-0.6.5/src/typespeed.h b/typespeed-0.6.5/src/typespeed.h
---- a/typespeed-0.6.5/src/typespeed.h  2008-08-13 15:36:51.000000000 +0100
-+++ b/typespeed-0.6.5/src/typespeed.h  2016-01-01 10:41:54.919998820 +0100
+--- typespeed-0.6.5/src/typespeed.h    2008-08-13 15:36:51.000000000 +0100
++++ typespeed-0.6.5/src/typespeed.h    2016-01-01 10:41:54.919998820 +0100
 @@ -27,10 +27,10 @@
  
  #include <stdint.h>
diff --git a/games-misc/typespeed/typespeed-0.6.5-r1.ebuild b/games-misc/typespeed/typespeed-0.6.5-r1.ebuild
new file mode 100644 (file)
index 0000000..354c9eb
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Test your typing speed, and get your fingers CPS"
+HOMEPAGE="http://typespeed.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+       sys-libs/ncurses:0=
+       nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}
+       nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+       default
+       sed -i \
+               -e 's/testsuite//' \
+               -e 's/doc//' \
+               Makefile.am || die
+       sed -i -e '/^CC =/d' src/Makefile.am || die
+       eapply "${FILESDIR}"/${P}-musl.patch
+       rm -rf m4 #417265
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --localedir=/usr/share/locale \
+               --docdir=/usr/share/doc/${PF} \
+               $(use_enable nls)
+}
+
+src_install() {
+       default
+       dodoc doc/README
+}