net-libs/libsoup: bump to 2.66.4
authorMart Raudsepp <leio@gentoo.org>
Sun, 13 Oct 2019 08:23:19 +0000 (11:23 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 13 Oct 2019 08:23:36 +0000 (11:23 +0300)
Package-Manager: Portage-2.3.69, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
net-libs/libsoup/Manifest
net-libs/libsoup/libsoup-2.66.4.ebuild [new file with mode: 0644]

index 026594a0380bd826a06a7232b87b9e40ff6cb2c0..51d3c604f96e0ebc2f1622c3c23ab9ff0ab28989 100644 (file)
@@ -3,3 +3,4 @@ DIST libsoup-2.62.3.tar.xz 1851780 BLAKE2B e3a3518f485d4ab1fe133f5b382d32e4b949e
 DIST libsoup-2.64.2.tar.xz 1793440 BLAKE2B 77a41ad62e0e419711cb26f510b6c0ca09c0430300f72144a0d0563a24e24639d1ca430784051b8de279623193a273510d5c95de6edb4a54a3aee0bd7903d9cd SHA512 c001495be4e1eafd169b904431b22e961b52f5a3202f2e75b0657281cbfd91153148765bd95378bba3e85a66d7eaca428750641f20c07ca3232d1f9bdabdc90f
 DIST libsoup-2.66.2.tar.xz 1446024 BLAKE2B 2953b91e3bf28b80189a87ecff3a9d103d57bb090f62121dc441e9bfa65750b67f2ab4f50e7a7a0cf5691b79139ae84de5aeaff69e7505b5c2fdd3f375536724 SHA512 1df443470239f23d22301e37e36f3d34963352ee0122f317cd15b19d90115831091bddcee27bc6f0d4994adcf4e5bd9c0395de2bd7f39ae305ba0edea7789092
 DIST libsoup-2.66.3.tar.xz 1448924 BLAKE2B 82edc5afe06d41dcd18989fb5cb439047f52c52bd13406fddaa3cafc5540d4c54924c244bb9d58839eb0cf7187da8da82158ddb01f16a7913f543f95df4f285d SHA512 166559480ab84c9bd5407abbed51f4ed76b5c061e647441bf2657ed2c918402985a0a3b9caaf14639f11a40e0b9130bf270a94b32fb72ade3782fac8692bc2ef
+DIST libsoup-2.66.4.tar.xz 1451200 BLAKE2B 4ee37592beb9227eb5a61901e4b100b613fef2be512b7c61052a8df17184783e4b6e4e898893d6f63f1fa32b97fac935ad0f4b4d5ae1c56fedd62c0c8f41a8ea SHA512 c1d57c6c5099ac345373409dd3f384dd454e47218cc6bd8be1c6b2de967d7753bfcc3010836f7131f049b1ab9c49318d6ae5203be0bcc0ca5d4b62a0c64f27ad
diff --git a/net-libs/libsoup/libsoup-2.66.4.ebuild b/net-libs/libsoup/libsoup-2.66.4.ebuild
new file mode 100644 (file)
index 0000000..af731bf
--- /dev/null
@@ -0,0 +1,95 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org meson multilib-minimal vala xdg
+
+DESCRIPTION="HTTP client/server library for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/libsoup"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.4"
+
+IUSE="gssapi gtk-doc +introspection samba ssl test +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+DEPEND="
+       >=dev-libs/glib-2.38:2[${MULTILIB_USEDEP}]
+       >=dev-db/sqlite-3.8.2:3[${MULTILIB_USEDEP}]
+       >=dev-libs/libxml2-2.9.1-r4:2[${MULTILIB_USEDEP}]
+       >=net-libs/libpsl-0.20[${MULTILIB_USEDEP}]
+       gssapi? ( virtual/krb5[${MULTILIB_USEDEP}] )
+       introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+       samba? ( net-fs/samba )
+"
+RDEPEND="${DEPEND}
+       >=net-libs/glib-networking-2.38.2[ssl?,${MULTILIB_USEDEP}]
+"
+BDEPEND="
+       dev-util/glib-utils
+       gtk-doc? ( >=dev-util/gtk-doc-1.20
+               app-text/docbook-xml-dtd:4.1.2 )
+       >=sys-devel/gettext-0.19.8
+       >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+       vala? ( $(vala_depend) )
+"
+#      test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
+#              apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
+#              apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
+#              dev-lang/php[apache2,xmlrpc]
+#              net-misc/curl
+#              net-libs/glib-networking[ssl])"
+
+PATCHES=(
+       # Disable apache tests until they are usable on Gentoo, bug #326957
+       "${FILESDIR}"/disable-apache-tests.patch
+       # Fix libsoup-2.4.vapi to be compatible with vala:0.46 and onwards. Included in 2.67.2
+       "${FILESDIR}"/2.66.2-vala-0.46-compat.patch
+       "${FILESDIR}"/2.66.2-meson-ntlm_auth-fix.patch
+)
+
+src_prepare() {
+       use vala && vala_src_prepare
+       xdg_src_prepare
+}
+
+src_configure() {
+       # FIXME: we need addpredict to workaround bug #324779 until
+       # root cause (bug #249496) is solved
+       # But necessary while apache tests are disabled
+       #addpredict /usr/share/snmp/mibs/.index
+
+       multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+       local emesonargs=(
+               $(meson_use gssapi)
+               -Dkrb5_config="${CHOST}-krb5-config"
+               $(meson_use samba ntlm)
+               -Dntlm_auth="${EPREFIX}/usr/bin/ntlm_auth"
+               -Dtls_check=false # disables check, we still rdep on glib-networking
+               -Dgnome=false
+               -Dintrospection=$(multilib_native_usex introspection true false)
+               -Dvapi=$(multilib_native_usex vala true false)
+               -Dgtk_doc=$(multilib_native_usex gtk-doc true false)
+               $(meson_use test tests)
+       )
+       meson_src_configure
+}
+
+multilib_src_compile() {
+       meson_src_compile
+}
+
+multilib_src_test() {
+       meson_src_test
+}
+
+multilib_src_install() {
+       meson_src_install
+}