dev-haskell/monad-logger: avoid underscores in USE flags
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 22 Sep 2019 08:56:45 +0000 (09:56 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 22 Sep 2019 08:56:45 +0000 (09:56 +0100)
Reported-by: Michał Górny
Closes: https://bugs.gentoo.org/695046
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-haskell/monad-logger/metadata.xml
dev-haskell/monad-logger/monad-logger-0.3.17.ebuild
dev-haskell/monad-logger/monad-logger-0.3.18.ebuild
dev-haskell/monad-logger/monad-logger-0.3.20.1.ebuild

index b83f7e64803f7040e5a6267412a4ee7b84005f7e..d83f8eff0123801efc76ec43b03ca21f317b12f3 100644 (file)
@@ -6,7 +6,7 @@
                <name>Gentoo Haskell</name>
        </maintainer>
        <use>
-               <flag name="template_haskell">Enable Template Haskell support.</flag>
+               <flag name="template-haskell">Enable Template Haskell support.</flag>
        </use>
        <longdescription>
                This package uses template-haskell for determining source code locations of messages.
index ae088f8898f8467cbec00740157906726497be8b..e84d8f4f22867db08b84b48cbd5858df77d5ba6b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -15,7 +15,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0/${PV}"
 KEYWORDS="~amd64 ~x86"
-IUSE="+template_haskell"
+IUSE="+template-haskell"
 
 RDEPEND="dev-haskell/blaze-builder:=[profile?]
        >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
@@ -41,5 +41,5 @@ DEPEND="${RDEPEND}
 
 src_configure() {
        haskell-cabal_src_configure \
-               $(cabal_flag template_haskell template_haskell)
+               $(cabal_flag template-haskell template_haskell)
 }
index ae088f8898f8467cbec00740157906726497be8b..e84d8f4f22867db08b84b48cbd5858df77d5ba6b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -15,7 +15,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0/${PV}"
 KEYWORDS="~amd64 ~x86"
-IUSE="+template_haskell"
+IUSE="+template-haskell"
 
 RDEPEND="dev-haskell/blaze-builder:=[profile?]
        >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
@@ -41,5 +41,5 @@ DEPEND="${RDEPEND}
 
 src_configure() {
        haskell-cabal_src_configure \
-               $(cabal_flag template_haskell template_haskell)
+               $(cabal_flag template-haskell template_haskell)
 }
index 42ee80ded7b9a3c2e6307c7b1bbb0652db4bf862..cf88a7efec3f8d2eb210e9a4c4325ed0d58caaec 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -15,7 +15,7 @@ SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0/${PV}"
 KEYWORDS="~amd64 ~x86"
-IUSE="+template_haskell"
+IUSE="+template-haskell"
 
 RDEPEND="dev-haskell/blaze-builder:=[profile?]
        >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
@@ -40,5 +40,5 @@ DEPEND="${RDEPEND}
 
 src_configure() {
        haskell-cabal_src_configure \
-               $(cabal_flag template_haskell template_haskell)
+               $(cabal_flag template-haskell template_haskell)
 }