x11-misc/xkeyboard-config: Bump to version 2.28
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 22 Oct 2019 11:02:21 +0000 (13:02 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 22 Oct 2019 11:05:00 +0000 (13:05 +0200)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
x11-misc/xkeyboard-config/Manifest
x11-misc/xkeyboard-config/xkeyboard-config-2.28.ebuild [new file with mode: 0644]

index cc004ae4c20a4176b648ba3f61195970b2da2681..c8814c5bc7b1aee112ecd0ecdb018b7858609ac6 100644 (file)
@@ -1 +1,2 @@
 DIST xkeyboard-config-2.27.tar.bz2 1664454 BLAKE2B ac5e02903f46579a1df0423c01d2c07412642d00a5e73b05c0d112e4a65163c20c2df762438775afc52445eed47025c8e061fa0945140245679b693d740e904c SHA512 ae29177461f9d2c6ce1c56c0b8b147600e3f0ecd15e8754c9531811702d9a030a31f42679a88a9fb706bec458974c337ee2a0180f22573702caa7184eb94017e
+DIST xkeyboard-config-2.28.tar.bz2 1682987 BLAKE2B 8883787119bb46e4351d4023aee0f1a495b6acc87755b408ffa51d5082f84f4b1a083a8a0ee640b00afd35777bc8e8e0ef2187cd0bbb2600db81da8fef19298f SHA512 be38e61a7d3a1c03f9dc92fed5aada65fdb8b42272e874e01156a39de07f2a7c81846e9ba449aeb95661587f8d05217d549a1315ee0dd92facbb6158362e68ae
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.28.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.28.ebuild
new file mode 100644 (file)
index 0000000..d2d56f9
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config"
+
+if [[ ${PV} == 9999 ]]; then
+       EGIT_REPO_URI="https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config.git"
+       inherit autotools git-r3
+       # x11-misc/util-macros only required on live ebuilds
+       LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+else
+       SRC_URI="https://www.x.org/releases/individual/data/${PN}/${P}.tar.bz2"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+BDEPEND="
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig
+"
+RDEPEND="
+       !<x11-apps/xkbcomp-1.2.3
+       !<x11-libs/libX11-1.4.3
+"
+DEPEND="
+       ${LIVE_DEPEND}
+"
+
+src_prepare() {
+       default
+       [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+       local econfargs=(
+               --with-xkb-base="${EPREFIX}/usr/share/X11/xkb"
+               --enable-compat-rules
+               # do not check for runtime deps
+               --disable-runtime-deps
+               --with-xkb-rules-symlink=xorg
+       )
+
+       econf "${econfargs[@]}"
+}