Revert "profiles: Mask tomcat websockets flag on ppc64"
authorJames Le Cuirot <chewi@gentoo.org>
Sat, 15 Aug 2015 22:44:06 +0000 (23:44 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Sat, 15 Aug 2015 22:45:16 +0000 (23:45 +0100)
This reverts commit d35f94566069cb2d6ade51b1e5beac364e218956. It
contained more than I meant to commit, sorry!

profiles/arch/powerpc/ppc64/package.use.mask
www-servers/tomcat/files/tomcat-8.0.24-build.xml.patch [deleted file]
www-servers/tomcat/files/tomcat-r1.init [deleted file]
www-servers/tomcat/tomcat-7.0.63.ebuild [deleted file]
www-servers/tomcat/tomcat-8.0.24.ebuild [deleted file]

index 81777272f9a8a42689ac0463c46df2a5c4921998..9bce7a0413e6417d0cba6a5d011f6b0a00e38964 100644 (file)
@@ -2,10 +2,6 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-# James Le Cuirot <chewi@gentoo.org> (15 Aug 2015)
-# Java 7+ is required for websocket support.
-www-servers/tomcat websockets
-
 # Ben de Groot <yngwin@gentoo.org> (20 Jul 2015)
 # missing keywords
 media-sound/audacity midi
diff --git a/www-servers/tomcat/files/tomcat-8.0.24-build.xml.patch b/www-servers/tomcat/files/tomcat-8.0.24-build.xml.patch
deleted file mode 100644 (file)
index 9854c9d..0000000
+++ /dev/null
@@ -1,230 +0,0 @@
-diff -Naur apache-tomcat-8.0.24-src.orig/build.xml apache-tomcat-8.0.24-src/build.xml
---- apache-tomcat-8.0.24-src.orig/build.xml    2015-07-01 21:25:21.000000000 +0100
-+++ apache-tomcat-8.0.24-src/build.xml 2015-08-14 13:45:50.315788075 +0100
-@@ -697,24 +697,29 @@
-       manifest="${tomcat.manifests}/annotations-api.jar.manifest" />
-     <!-- Servlet 3.1 Implementation JAR File -->
-+<!--
-     <jarIt jarfile="${servlet-api.jar}"
-       filesDir="${tomcat.classes}"
-       filesId="files.servlet-api"
-       manifest="${tomcat.manifests}/servlet-api.jar.manifest"
-       notice="${tomcat.manifests}/servlet-api.jar.notice"
-       license="${tomcat.manifests}/servlet-api.jar.license" />
--
-+-->
-     <!-- JSP 2.3 Implementation JAR File -->
-+<!--
-     <jarIt jarfile="${jsp-api.jar}"
-       filesDir="${tomcat.classes}"
-       filesId="files.jsp-api"
-       manifest="${tomcat.manifests}/jsp-api.jar.manifest" />
-+-->
-     <!-- EL 3.0 Implementation JAR File -->
-+<!--
-     <jarIt jarfile="${el-api.jar}"
-       filesDir="${tomcat.classes}"
-       filesId="files.el-api"
-       manifest="${tomcat.manifests}/el-api.jar.manifest" />
-+-->
-     <!-- WebSocket 1.1 API JAR File -->
-     <jarIt jarfile="${websocket-api.jar}"
-@@ -982,14 +987,14 @@
-   <target name="deploy" depends="package,build-docs,build-tomcat-jdbc,compile-webapp-examples"
-           description="Default. Builds a working Tomcat instance">
--
-+<!--
-     <copy tofile="${tomcat.build}/bin/tomcat-native.tar.gz"
-             file="${tomcat-native.tar.gz}" />
-     <copy tofile="${tomcat.build}/bin/commons-daemon-native.tar.gz"
-             file="${commons-daemon.native.src.tgz}" />
-     <copy tofile="${tomcat.build}/bin/commons-daemon.jar" file="${commons-daemon.jar}" />
--
-+-->
-     <!-- Copy scripts -->
-     <copy todir="${tomcat.build}/bin">
-       <fileset dir="bin">
-@@ -1049,7 +1054,7 @@
-         <exclude name="${jdt.jar.filename}"/>
-       </fileset>
-     </delete>
--    <copy file="${jdt.jar}" todir="${tomcat.build}/lib"/>
-+<!--    <copy file="${jdt.jar}" todir="${tomcat.build}/lib"/> -->
-     <!-- Add sources for examples -->
-     <antcall target="examples-sources" />
-@@ -1083,7 +1088,7 @@
-     </javac>
-   </target>
--  <target name="build-tomcat-jdbc" depends="package">
-+  <target name="build-tomcat-jdbc" depends="package" unless="noget">
-     <!-- build the jdbc-pool jar and source jar-->
-     <echo message="Building Tomcat JDBC pool libraries"/>
-     <ant antfile="${tomcat.jdbc.dir}/build.xml" dir="${tomcat.jdbc.dir}"
-@@ -1098,7 +1103,7 @@
-     <copy file="${tomcat-jdbc.jar}" todir="${tomcat.build}/lib"/>
-   </target>
--  <target name="build-tomcat-jdbc-src">
-+  <target name="build-tomcat-jdbc-src" unless="noget">
-     <!-- build the jdbc-pool source jar-->
-     <echo message="Building Tomcat JDBC pool src JAR"/>
-     <ant antfile="${tomcat.jdbc.dir}/build.xml" dir="${tomcat.jdbc.dir}"
-@@ -1202,10 +1207,11 @@
-     <copy file="${basedir}/LICENSE" todir="${tomcat.embed}" />
-     <copy file="${basedir}/NOTICE" todir="${tomcat.embed}" />
-+<!--
-     <copy file="${tomcat-dbcp.jar}" todir="${tomcat.embed}"
-       failonerror="false"/>
-     <copy file="${jdt.jar}" todir="${tomcat.embed}" />
--
-+-->
-     <!-- Note the meta-inf below will work as long as there is only one JAR
-          that needs to add entries. If there is more than one a more complex
-          solution will be required. -->
-@@ -1542,7 +1548,7 @@
-   <target name="extras-commons-logging-prepare"
-           depends="extras-prepare"
--          description="Prepare to build web services extras package">
-+          description="Prepare to build web services extras package" unless="noget">
-     <antcall target="downloadfile-2">
-       <param name="sourcefile.1" value="${commons-logging-src.loc.1}"/>
-@@ -1681,7 +1687,7 @@
-   <target name="extras-webservices-prepare"
-           depends="extras-prepare"
--          description="Prepare to build web services extras package">
-+          description="Prepare to build web services extras package" unless="noget">
-     <antcall target="downloadfile">
-       <param name="sourcefile" value="${jaxrpc-lib.loc}"/>
-@@ -2739,7 +2745,7 @@
-   </target>
-   <target name="download-compile"
--          description="Download (and build) components necessary to compile" >
-+          description="Download (and build) components necessary to compile" unless="noget">
-     <antcall target="downloadfile-2">
-       <param name="sourcefile.1" value="${tomcat-native.loc.1}"/>
-@@ -2773,7 +2779,7 @@
-   </target>
-   <target name="download-test-compile"
--          description="Download additional components for the tests" >
-+          description="Download additional components for the tests" unless="noget">
-     <antcall target="downloadfile">
-       <param name="sourcefile" value="${junit.loc}"/>
-@@ -2819,7 +2825,7 @@
-   </target>
-   <target name="download-dist"
--          description="Download additional components for a distribution" >
-+          description="Download additional components for a distribution" unless="noget">
-     <antcall target="downloadzip-2">
-       <param name="sourcefile.1" value="${tomcat-native.win.1}"/>
-@@ -2845,18 +2851,18 @@
-   <!-- =============== Utility Targets to support downloads ================ -->
--  <target name="setproxy" if="${proxy.use}">
-+  <target name="setproxy" if="${proxy.use}" unless="noget">
-     <setproxy proxyhost="${proxy.host}" proxyport="${proxy.port}"
-               proxyuser="${proxy.user}" proxypassword="${proxy.password}" />
-     <echo message="Using ${proxy.host}:${proxy.port} to download ${sourcefile}"/>
-   </target>
--  <target name="testexist">
-+  <target name="testexist" unless="noget">
-     <echo message="Testing  for ${destfile}"/>
-     <available file="${destfile}" property="exist"/>
-   </target>
--  <target name="downloadgz" unless="exist" depends="testexist,setproxy">
-+  <target name="downloadgz" unless="noget" depends="testexist,setproxy">
-     <!-- Download and extract the package -->
-     <local name="temp.file"/>
-     <mkdir dir="${base.path}"/>
-@@ -2868,7 +2874,7 @@
-     <delete file="${temp.file}.tar.gz"/>
-   </target>
--  <target name="downloadgz-2" unless="exist" depends="testexist">
-+  <target name="downloadgz-2" unless="noget" depends="testexist">
-     <!-- Download and extract the package from the two alternative locations -->
-     <local name="temp.file"/>
-     <mkdir dir="${base.path}"/>
-@@ -2887,7 +2893,7 @@
-     <delete file="${temp.file}.tar.gz"/>
-   </target>
--  <target name="downloadzip" unless="exist" depends="testexist,setproxy">
-+  <target name="downloadzip" unless="noget" depends="testexist,setproxy">
-     <!-- Download and extract the package -->
-     <local name="temp.file"/>
-     <mkdir dir="${base.path}"/>
-@@ -2898,7 +2904,7 @@
-     <delete file="${temp.file}"/>
-   </target>
--  <target name="downloadzip-2" unless="exist" depends="testexist">
-+  <target name="downloadzip-2" unless="noget" depends="testexist">
-     <!-- Download and extract the package from the two alternative locations -->
-     <local name="temp.file"/>
-     <mkdir dir="${base.path}"/>
-@@ -2916,7 +2922,7 @@
-     <delete file="${temp.file}"/>
-   </target>
--  <target name="downloadfile" unless="exist" depends="testexist,setproxy">
-+  <target name="downloadfile" unless="noget" depends="testexist,setproxy">
-     <!-- Download the file -->
-     <local name="temp.file"/>
-     <mkdir dir="${base.path}"/>
-@@ -2926,7 +2932,7 @@
-     <move file="${temp.file}" tofile="${destfile}"/>
-   </target>
--  <target name="downloadfile-2" unless="exist" depends="testexist">
-+  <target name="downloadfile-2" unless="noget" depends="testexist">
-     <!-- Download the file from the two alternative locations -->
-     <local name="temp.file"/>
-     <mkdir dir="${base.path}"/>
-@@ -2949,7 +2955,7 @@
-     <move file="${temp.file}" tofile="${destfile}"/>
-   </target>
--  <target name="trydownload.check" depends="setproxy">
-+  <target name="trydownload.check" depends="setproxy" unless="noget">
-     <condition property="trydownload.run">
-       <and>
-         <not>
-@@ -2960,7 +2966,7 @@
-     </condition>
-   </target>
--  <target name="trydownload" if="trydownload.run" depends="trydownload.check">
-+  <target name="trydownload" if="trydownload.run" depends="trydownload.check" unless="noget">
-     <!-- Downloads a file if not yet downloaded and the source URL is available -->
-     <get src="${sourcefile}" httpusecaches="${trydownload.httpusecaches}" dest="${destfile}" />
-   </target>
-@@ -2971,7 +2977,7 @@
-   <target name="ide-eclipse"
-           depends="download-compile, extras-webservices-prepare, download-test-compile"
--          description="Prepares the source tree to be built in Eclipse">
-+          description="Prepares the source tree to be built in Eclipse" unless="noget">
-     <!-- Copy the sample project files into the root directory -->
-     <copy file="${tomcat.home}/res/ide-support/eclipse/eclipse.project" tofile="${tomcat.home}/.project"/>
diff --git a/www-servers/tomcat/files/tomcat-r1.init b/www-servers/tomcat/files/tomcat-r1.init
deleted file mode 100644 (file)
index ec09aa3..0000000
+++ /dev/null
@@ -1,110 +0,0 @@
-#!/@GENTOO_PORTAGE_EPREFIX@sbin/runscript
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-extra_commands="forcestop"
-
-PIDFILE=/@GENTOO_PORTAGE_EPREFIX@var/run/${RC_SVCNAME}.pid
-
-: ${CATALINA_HOME:=/@GENTOO_PORTAGE_EPREFIX@usr/share/tomcat-@SLOT@}
-: ${CATALINA_BASE:=/@GENTOO_PORTAGE_EPREFIX@var/lib/${RC_SVCNAME}}
-: ${CATALINA_TMPDIR:=/@GENTOO_PORTAGE_EPREFIX@var/tmp/${RC_SVCNAME}}
-: ${CATALINA_USER:=tomcat}
-: ${CATALINA_GROUP:=tomcat}
-
-: ${TOMCAT_START:=start}
-
-: ${JPDA_TRANSPORT:="dt_socket"}
-: ${JPDA_ADDRESS:="8000"}
-: ${JPDA_OPTS="-Xdebug -Xrunjdwp:transport=${JPDA_TRANSPORT},address=${JPDA_ADDRESS},server=y,suspend=n"}
-
-export JAVA_HOME=`java-config ${TOMCAT_JVM:+--select-vm ${TOMCAT_JVM}} --jre-home`
-export CLASSPATH="${CATALINA_HOME}/bin/bootstrap.jar:${CATALINA_HOME}/bin/tomcat-juli.jar"
-
-depend() {
-       use dns logger net
-}
-
-start()        {
-       ebegin "Starting ${RC_SVCNAME}"
-
-       if [ ! -e "${CATALINA_TMPDIR}" ]; then
-               eerror "CATALINA_TMPDIR does not exist. Unable to start tomcat."
-               eerror "Please see /@GENTOO_PORTAGE_EPREFIX@etc/conf.d/${RC_SVCNAME} for more information."
-               eend 1
-       fi
-
-       local DEPEND=$(java-config --query DEPEND --package tomcat-@SLOT@):${TOMCAT_EXTRA_JARS}
-       DEPEND=${DEPEND%:}
-
-       local GCLASSPATH=$(java-config --with-dependencies --classpath "${DEPEND//:/,}"):${TOMCAT_EXTRA_CLASSPATH}
-       GCLASSPATH=${GCLASSPATH%:}
-
-       local cmd=java args=
-       if [ "${TOMCAT_START}" = "debug" ] || [ "${TOMCAT_START}" = "-security debug" ] ; then
-               cmd=jdb
-               args="${args} -sourcepath ${CATALINA_HOME}/../../jakarta-tomcat-catalina/catalina/src/share"
-       fi
-       if [ "${TOMCAT_START}" = "-security debug" ] || [ "${TOMCAT_START}" = "-security start" ]; then
-               args="${args} -Djava.security.manager"
-               args="${args} -Djava.security.policy=${CATALINA_BASE}/conf/catalina.policy"
-       fi
-       if [ "${TOMCAT_START}" = "jpda start" ] ; then
-               args="${args} ${JPDA_OPTS}"
-       fi
-       if [ -r "${CATALINA_HOME}"/bin/tomcat-juli.jar ]; then
-               args="${args} -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager \
-               -Djava.util.logging.config.file=${CATALINA_BASE}/conf/logging.properties"
-       fi
-
-       start-stop-daemon  --start \
-               --quiet --background \
-               --chdir "${CATALINA_TMPDIR}" \
-               --user ${CATALINA_USER}:${CATALINA_GROUP} \
-               --make-pidfile --pidfile ${PIDFILE} \
-               --exec ${JAVA_HOME}/bin/${cmd} \
-               -- \
-                       ${JAVA_OPTS} \
-                       ${args} \
-                       -Dcatalina.base="${CATALINA_BASE}" \
-                       -Dcatalina.home="${CATALINA_HOME}" \
-                       -Djava.io.tmpdir="${CATALINA_TMPDIR}" \
-                       -Dgentoo.classpath="${GCLASSPATH//:/,}" \
-                       -classpath "${CLASSPATH}" \
-                       org.apache.catalina.startup.Bootstrap \
-                       ${CATALINA_OPTS} \
-                       ${TOMCAT_START}
-
-       eend $?
-}
-
-stop() {
-       ebegin "Stopping '${RC_SVCNAME}'"
-
-       start-stop-daemon --stop \
-               --quiet --retry=60 \
-               --pidfile ${PIDFILE} \
-               --exec ${JAVA_HOME}/bin/java \
-               -- \
-                       ${JAVA_OPTS} \
-                       -classpath "${CLASSPATH}" \
-                       ${CATALINA_OPTS} \
-                       stop ${STD_OUT}
-
-       eend $?
-}
-
-forcestop()    {
-       ebegin "Forcing '${RC_SVCNAME}' to stop"
-
-       start-stop-daemon --stop \
-               --quiet --retry=60 \
-               --pidfile ${PIDFILE} \
-               --signal=9
-
-       if service_started "${RC_SVCNAME}"; then
-               mark_service_stopped "${RC_SVCNAME}"
-       fi
-
-       eend $?
-}
diff --git a/www-servers/tomcat/tomcat-7.0.63.ebuild b/www-servers/tomcat/tomcat-7.0.63.ebuild
deleted file mode 100644 (file)
index 2781b13..0000000
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit eutils java-pkg-2 java-ant-2 prefix user
-
-MY_P="apache-${P}-src"
-
-DESCRIPTION="Tomcat Servlet-3.0/JSP-2.2 Container"
-HOMEPAGE="http://tomcat.apache.org/"
-SRC_URI="mirror://apache/${PN}/tomcat-7/v${PV}/src/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="7"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="extra-webapps websockets"
-
-RESTRICT="test" # can we run them on a production system?
-
-ECJ_SLOT="4.4"
-SAPI_SLOT="3.0"
-
-COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
-       dev-java/oracle-javamail:0
-       dev-java/tomcat-servlet-api:${SAPI_SLOT}"
-RDEPEND="${COMMON_DEP}
-       websockets? ( >=virtual/jre-1.7 )
-       !websockets? ( >=virtual/jre-1.6 )
-       !<dev-java/tomcat-native-1.1.24"
-DEPEND="${COMMON_DEP}
-       websockets? ( >=virtual/jdk-1.7 )
-       !websockets? ( >=virtual/jdk-1.6 )
-       >=dev-java/ant-core-1.8.1:0
-       test? (
-               dev-java/ant-junit:0
-       )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
-       java-pkg-2_pkg_setup
-       enewgroup tomcat 265
-       enewuser tomcat 265 -1 /dev/null tomcat
-}
-
-java_prepare() {
-       find -name '*.jar' -type f -delete -print || die
-
-       # Remove bundled javamail
-       rm -rv java/javax/mail || die
-
-       epatch "${FILESDIR}/${P}-build.xml.patch"
-
-       # For use of catalina.sh in netbeans
-       sed -i -e "/^# ----- Execute The Requested Command/ a\
-               CLASSPATH=\`java-config --classpath ${PN}-${SLOT}\`" \
-               bin/catalina.sh || die
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-
-EANT_BUILD_TARGET="deploy"
-EANT_GENTOO_CLASSPATH="eclipse-ecj-${ECJ_SLOT},oracle-javamail,tomcat-servlet-api-${SAPI_SLOT}"
-EANT_GENTOO_CLASSPATH_EXTRA="${S}/output/classes"
-EANT_NEEDS_TOOLS="true"
-EANT_EXTRA_ARGS="-Dversion=${PV}-gentoo -Dversion.number=${PV} -Dcompile.debug=false"
-
-# revisions of the scripts
-IM_REV="-r1"
-INIT_REV="-r1"
-
-src_compile() {
-       use websockets && EANT_EXTRA_ARGS+=" -Djava.7.home=${JAVA_HOME}"
-       EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only ant-core ant.jar)"
-       java-pkg-2_src_compile
-}
-
-src_test() {
-       java-pkg-2_src_test
-}
-
-src_install() {
-       local dest="/usr/share/${PN}-${SLOT}"
-
-       java-pkg_jarinto "${dest}"/bin
-       java-pkg_dojar output/build/bin/*.jar
-       exeinto "${dest}"/bin
-       doexe output/build/bin/*.sh
-
-       java-pkg_jarinto "${dest}"/lib
-       java-pkg_dojar output/build/lib/*.jar
-
-       dodoc RELEASE-NOTES RUNNING.txt
-       use doc && java-pkg_dojavadoc output/dist/webapps/docs/api
-       use source && java-pkg_dosrc java/*
-
-       ### Webapps ###
-
-       insinto "${dest}"/webapps
-       doins -r output/build/webapps/{host-manager,manager,ROOT}
-       use extra-webapps && doins -r output/build/webapps/{docs,examples}
-
-       ### Config ###
-
-       # create "logs" directory in $CATALINA_BASE
-       # and set correct perms, see #458890
-       dodir "${dest}"/logs
-       fperms 0750 "${dest}"/logs
-
-       # replace the default pw with a random one, see #92281
-       local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)
-       sed -i -e "s|SHUTDOWN|${randpw}|" output/build/conf/server.xml || die
-
-       # prepend gentoo.classpath to common.loader, see #453212
-       sed -i -e 's/^common\.loader=/\0${gentoo.classpath},/' output/build/conf/catalina.properties || die
-
-       insinto "${dest}"
-       doins -r output/build/conf
-
-       ### rc ###
-
-       cp "${FILESDIR}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} "${T}" || die
-       eprefixify "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash}
-       sed -i -e "s|@SLOT@|${SLOT}|g" "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} || die
-
-       insinto "${dest}"/gentoo
-       doins "${T}"/tomcat.conf
-       exeinto "${dest}"/gentoo
-       newexe "${T}"/tomcat${INIT_REV}.init tomcat.init
-       newexe "${T}"/tomcat-instance-manager${IM_REV}.bash tomcat-instance-manager.bash
-}
-
-pkg_postinst() {
-       elog "New ebuilds of Tomcat support running multiple instances. If you used prior version"
-       elog "of Tomcat (<7.0.32), you have to migrate your existing instance to work with new Tomcat."
-       elog "You can find more information at https://wiki.gentoo.org/wiki/Apache_Tomcat"
-
-       elog "To manage Tomcat instances, run:"
-       elog "  ${EPREFIX}/usr/share/${PN}-${SLOT}/gentoo/tomcat-instance-manager.bash --help"
-
-       ewarn "tomcat-dbcp.jar is not built at this time. Please fetch jar"
-       ewarn "from upstream binary if you need it. Gentoo Bug # 144276"
-
-#      einfo "Please read http://www.gentoo.org/proj/en/java/tomcat6-guide.xml for more information."
-}
diff --git a/www-servers/tomcat/tomcat-8.0.24.ebuild b/www-servers/tomcat/tomcat-8.0.24.ebuild
deleted file mode 100644 (file)
index aa31dea..0000000
+++ /dev/null
@@ -1,148 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit eutils java-pkg-2 java-ant-2 prefix user
-
-MY_P="apache-${P}-src"
-
-DESCRIPTION="Tomcat Servlet-3.1/JSP-2.3 Container"
-HOMEPAGE="http://tomcat.apache.org/"
-SRC_URI="mirror://apache/${PN}/tomcat-8/v${PV}/src/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="8"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="extra-webapps"
-
-RESTRICT="test" # can we run them on a production system?
-
-ECJ_SLOT="4.4"
-SAPI_SLOT="3.1"
-
-COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
-       dev-java/oracle-javamail:0
-       dev-java/tomcat-servlet-api:${SAPI_SLOT}"
-RDEPEND="${COMMON_DEP}
-       !<dev-java/tomcat-native-1.1.24
-       >=virtual/jre-1.7"
-DEPEND="${COMMON_DEP}
-       >=virtual/jdk-1.7
-       >=dev-java/ant-core-1.8.1:0
-       test? (
-               >=dev-java/ant-junit-1.9:0
-               dev-java/easymock:3.2
-       )"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
-       java-pkg-2_pkg_setup
-       enewgroup tomcat 265
-       enewuser tomcat 265 -1 /dev/null tomcat
-}
-
-java_prepare() {
-       find -name '*.jar' -type f -delete -print || die
-
-       # Remove bundled javamail
-       rm -rv java/javax/mail || die
-
-       epatch "${FILESDIR}/${P}-build.xml.patch"
-
-       # For use of catalina.sh in netbeans
-       sed -i -e "/^# ----- Execute The Requested Command/ a\
-               CLASSPATH=\`java-config --classpath ${PN}-${SLOT}\`" \
-               bin/catalina.sh || die
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="true"
-
-EANT_BUILD_TARGET="deploy"
-EANT_GENTOO_CLASSPATH="eclipse-ecj-${ECJ_SLOT},oracle-javamail,tomcat-servlet-api-${SAPI_SLOT}"
-EANT_TEST_GENTOO_CLASSPATH="easymock-3.2"
-EANT_GENTOO_CLASSPATH_EXTRA="${S}/output/classes"
-EANT_NEEDS_TOOLS="true"
-EANT_EXTRA_ARGS="-Dversion=${PV}-gentoo -Dversion.number=${PV} -Dcompile.debug=false"
-
-# revisions of the scripts
-IM_REV="-r1"
-INIT_REV="-r1"
-
-src_compile() {
-       EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only ant-core ant.jar)"
-       java-pkg-2_src_compile
-}
-
-src_test() {
-       java-pkg-2_src_test
-}
-
-src_install() {
-       local dest="/usr/share/${PN}-${SLOT}"
-
-       java-pkg_jarinto "${dest}"/bin
-       java-pkg_dojar output/build/bin/*.jar
-       exeinto "${dest}"/bin
-       doexe output/build/bin/*.sh
-
-       java-pkg_jarinto "${dest}"/lib
-       java-pkg_dojar output/build/lib/*.jar
-
-       dodoc RELEASE-NOTES RUNNING.txt
-       use doc && java-pkg_dojavadoc output/dist/webapps/docs/api
-       use source && java-pkg_dosrc java/*
-
-       ### Webapps ###
-
-       insinto "${dest}"/webapps
-       doins -r output/build/webapps/{host-manager,manager,ROOT}
-       use extra-webapps && doins -r output/build/webapps/{docs,examples}
-
-       ### Config ###
-
-       # create "logs" directory in $CATALINA_BASE
-       # and set correct perms, see #458890
-       dodir "${dest}"/logs
-       fperms 0750 "${dest}"/logs
-
-       # replace the default pw with a random one, see #92281
-       local randpw=$(echo ${RANDOM}|md5sum|cut -c 1-15)
-       sed -i -e "s|SHUTDOWN|${randpw}|" output/build/conf/server.xml || die
-
-       # prepend gentoo.classpath to common.loader, see #453212
-       sed -i -e 's/^common\.loader=/\0${gentoo.classpath},/' output/build/conf/catalina.properties || die
-
-       insinto "${dest}"
-       doins -r output/build/conf
-
-       ### rc ###
-
-       cp "${FILESDIR}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} "${T}" || die
-       eprefixify "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash}
-       sed -i -e "s|@SLOT@|${SLOT}|g" "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} || die
-
-       insinto "${dest}"/gentoo
-       doins "${T}"/tomcat.conf
-       exeinto "${dest}"/gentoo
-       newexe "${T}"/tomcat${INIT_REV}.init tomcat.init
-       newexe "${T}"/tomcat-instance-manager${IM_REV}.bash tomcat-instance-manager.bash
-}
-
-pkg_postinst() {
-       elog "New ebuilds of Tomcat support running multiple instances. If you used prior version"
-       elog "of Tomcat (<7.0.32), you have to migrate your existing instance to work with new Tomcat."
-       elog "You can find more information at https://wiki.gentoo.org/wiki/Apache_Tomcat"
-
-       elog "To manage Tomcat instances, run:"
-       elog "  ${EPREFIX}/usr/share/${PN}-${SLOT}/gentoo/tomcat-instance-manager.bash --help"
-
-       ewarn "tomcat-dbcp.jar is not built at this time. Please fetch jar"
-       ewarn "from upstream binary if you need it. Gentoo Bug # 144276"
-
-#      einfo "Please read http://www.gentoo.org/proj/en/java/tomcat6-guide.xml for more information."
-}