Version bump. Remove obsolete versions.
authorAlin Năstac <mrness@gentoo.org>
Tue, 16 Jan 2007 17:55:25 +0000 (17:55 +0000)
committerAlin Năstac <mrness@gentoo.org>
Tue, 16 Jan 2007 17:55:25 +0000 (17:55 +0000)
Package-Manager: portage-2.1.1-r2

app-mobilephone/bitpim/ChangeLog
app-mobilephone/bitpim/bitpim-0.9.10.ebuild [new file with mode: 0644]
app-mobilephone/bitpim/files/bitpim-0.9.10-gentoo.patch [new file with mode: 0644]
app-mobilephone/bitpim/files/digest-bitpim-0.9.10 [new file with mode: 0644]

index ec5b7bc7d671ebb3b9a58b2822d3f1734e054f9e..7399fe0df04682854a4bedb51ed4f1c263967b80 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for app-mobilephone/bitpim
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bitpim/ChangeLog,v 1.17 2006/12/02 14:18:48 mrness Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bitpim/ChangeLog,v 1.18 2007/01/16 17:55:25 mrness Exp $
+
+*bitpim-0.9.10 (16 Jan 2007)
+
+  16 Jan 2007; Alin Năstac <mrness@gentoo.org>
+  -files/bitpim-0.9.07-gentoo.patch, +files/bitpim-0.9.10-gentoo.patch,
+  -bitpim-0.9.07-r2.ebuild, +bitpim-0.9.10.ebuild:
+  Version bump. Remove obsolete versions.
 
 *bitpim-0.9.08 (02 Dec 2006)
 
diff --git a/app-mobilephone/bitpim/bitpim-0.9.10.ebuild b/app-mobilephone/bitpim/bitpim-0.9.10.ebuild
new file mode 100644 (file)
index 0000000..b5575c1
--- /dev/null
@@ -0,0 +1,163 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/bitpim/bitpim-0.9.10.ebuild,v 1.1 2007/01/16 17:55:25 mrness Exp $
+
+inherit distutils multilib
+
+DESCRIPTION="This program allows you to view and manipulate data on LG VX4400/VX6000 and many Sanyo Sprint mobile phones"
+HOMEPAGE="http://www.bitpim.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt usb evo"
+
+DEPEND=">=dev-python/wxpython-2.6.3.2
+       >=dev-python/apsw-3
+       >=dev-python/python-dsv-1.4.0
+       >=dev-python/pyserial-2.0
+       crypt? ( >=dev-python/paramiko-1.5.4 )
+       usb? ( >=dev-lang/swig-1.3.21 >=dev-libs/libusb-0.1.10a )"
+RDEPEND="${DEPEND}
+       media-video/ffmpeg
+       media-libs/netpbm"
+
+#For Gentoo devs only: uncomment this line when you want to make the tarball
+#then COMMENT IT BACK!
+#pkg_setup() { maketarball; } 
+maketarball() { #For building the tarball. To be used only by ebuild maintainers
+       local x svnrev
+       svnrev=$(svn log -q --limit 1 https://svn.sourceforge.net/svnroot/${PN}/releases/${PV} | sed -r '/^[^r]/d;s/^r([0-9]+) .*$/\1/')
+       [ $? = 0 ] || return 1
+
+       #Fetch the source (only those directories that are needed)
+       cd "${DISTDIR}" && mkdir ${P} || return 1
+       for x in resources packaging src ; do
+               svn export https://svn.sourceforge.net/svnroot/${PN}/releases/${PV}/${x} ${P}/${x} || return 1
+       done
+
+       #Remove unneeded stuff
+       rm ${P}/resources/*.chm ${P}/src/package.py
+
+       #Freeze version and set vendor name to Gentoo
+       sed -i -e 's/\(^__FROZEN__="[$]Id: \).*\( $"\)/\1'${svnrev}'\2/' \
+               -e 's/^vendor=".*"/vendor="Gentoo"/' \
+               ${P}/src/version.py || return 1
+
+       #Make the tarball
+       tar -cjf ${P}.tar.bz2 ${P}
+       rm -r ${P}
+}
+
+src_unpack() {
+       unpack ${A}
+
+       epatch "${FILESDIR}/${P}-gentoo.patch"
+       sed -i "s/python2.3/${python}/" "${S}/src/native/usb/build.sh"
+}
+
+src_compile() {
+       # USB stuff
+       if use usb; then
+               cd "${S}/src/native/usb" || die "compilation of native/usb failed"
+               sh ./build.sh
+       fi
+
+       # strings
+       cd "${S}/src/native/strings"
+       ${python} setup.py build || die "compilation of native/strings failed"
+
+       # bmp2avi
+       cd "${S}/src/native/av/bmp2avi"
+       PLATFORM=linux make || die "compilation of native/bmp2avi failed"
+}
+
+src_install() {
+       cd "${S}"
+
+       # Install files into right place
+       #
+       # BitPim is a self-contained app, so jamming it into 
+       # Python's site-packages might not be worthwhile.  We'll
+       # Put it in its own home, and add the PYTHONPATH in the 
+       # wrapper executables below.
+       distutils_python_version
+       local RLOC=/usr/$(get_libdir)/${P}
+
+       # Main Python source
+       insinto ${RLOC}
+       doins src/*.py
+
+       # Phone specifics
+       insinto ${RLOC}/phones
+       doins src/phones/*.py
+
+       # Native products
+       insinto ${RLOC}/native
+       doins src/native/*.py
+       insinto ${RLOC}/native/qtopiadesktop
+       doins src/native/qtopiadesktop/*.py
+       insinto ${RLOC}/native/outlook
+       doins src/native/outlook/*.py
+       insinto ${RLOC}/native/egroupware
+       doins src/native/egroupware/*.py
+       if use evo ; then
+               insinto ${RLOC}/native/evolution
+               doins src/native/evolution/*.py
+       fi
+
+       # strings
+       cd "${S}/src/native/strings"
+       ${python} setup.py install --root="${D}" --no-compile "$@" || die "install of native/strings failed"
+       cd "${S}"
+       insinto $RLOC/native/strings
+       doins src/native/strings/__init__.py src/native/strings/jarowpy.py
+
+       # usb
+       if use usb; then
+               insinto ${RLOC}/native/usb
+               doins src/native/usb/*.py
+               doins src/native/usb/*.so
+       fi
+
+       # Helpers and resources
+       dobin src/native/av/bmp2avi/bmp2avi
+       insinto ${RLOC}/resources
+       doins resources/*
+
+       # Bitfling
+       if use crypt; then
+               FLINGDIR="${RLOC}/bitfling"
+               insinto $FLINGDIR
+               cd "${S}/src/bitfling"
+               doins *.py
+               cd "${S}"
+       fi
+
+       # Creating scripts
+       echo '#!/bin/sh' > "${T}/bitpim"
+       echo "exec python ${RLOC}/bp.py \"\$@\"" >> "${T}/bitpim"
+       dobin "${T}/bitpim"
+       if use crypt; then
+               echo '#!/bin/sh' > "${T}/bitfling"
+               echo "exec python ${RLOC}/bp.py \"\$@\" bitfling" >> "${T}/bitfling"
+               dobin "${T}/bitfling"
+       fi
+
+       # Desktop file
+       insinto /usr/share/applications
+       sed -i -e "s|%%INSTALLBINDIR%%|/usr/bin|" -e "s|%%INSTALLLIBDIR%%|${RLOC}|" \
+               packaging/bitpim.desktop
+       doins packaging/bitpim.desktop
+}
+
+pkg_postinst() {
+       # Optimize in installed directory
+       python_mod_optimize "${ROOT}usr/$(get_libdir)/${P}"
+}
+
+pkg_postrm() {
+       python_version
+       python_mod_cleanup "${ROOT}usr/$(get_libdir)/${P}"
+}
diff --git a/app-mobilephone/bitpim/files/bitpim-0.9.10-gentoo.patch b/app-mobilephone/bitpim/files/bitpim-0.9.10-gentoo.patch
new file mode 100644 (file)
index 0000000..4427ecc
--- /dev/null
@@ -0,0 +1,63 @@
+diff -Nru bitpim-0.9.10.orig/src/common.py bitpim-0.9.10/src/common.py
+--- bitpim-0.9.10.orig/src/common.py   2006-12-23 12:43:23.000000000 +0200
++++ bitpim-0.9.10/src/common.py        2007-01-16 19:36:41.000000000 +0200
+@@ -850,4 +850,4 @@
+         # windows running from exe, return as is
+         return os.path.abspath(os.path.dirname(sys.executable))
+     # running from src, up one
+-    return os.path.split(os.path.abspath(os.path.dirname(sys.argv[0])))[0]
++    return os.path.abspath(os.path.dirname(sys.argv[0]))
+diff -Nru bitpim-0.9.10.orig/src/conversions.py bitpim-0.9.10/src/conversions.py
+--- bitpim-0.9.10.orig/src/conversions.py      2006-05-28 06:10:52.000000000 +0300
++++ bitpim-0.9.10/src/conversions.py   2007-01-16 19:36:41.000000000 +0200
+@@ -20,11 +20,11 @@
+ class ConversionFailed(Exception): pass
+-helperdir=os.path.join(common.get_main_dir(), "helpers")
++helperdir="/usr/bin"
+ osext={'win32': '.exe',
+        'darwin': '.mbin',
+-       'linux2': '.lbin'} \
++       'linux2': ''} \
+        [sys.platform]
+ # This shortname crap is needed because Windows programs (including ffmpeg)
+@@ -125,14 +125,14 @@
+     p=sys.path[0]
+     if os.path.isfile(p):
+         p=os.path.dirname(p)
+-    helpersdirectory=os.path.abspath(os.path.join(p, 'helpers'))
++    helpersdirectory="/usr/bin"
+     print "Helper Directory: "+helpersdirectory
+     if sys.platform=='win32':
+         osext=".exe"
+     if sys.platform=='darwin':
+         osext=".mbin"
+     if sys.platform=='linux2':
+-        osext=".lbin"
++        osext=""
+         
+     pngtopnmbin=gethelperbinary('pngtopnm')
+     ppmquantbin=gethelperbinary('ppmquant')
+diff -Nru bitpim-0.9.10.orig/src/native/av/bmp2avi/Makefile bitpim-0.9.10/src/native/av/bmp2avi/Makefile
+--- bitpim-0.9.10.orig/src/native/av/bmp2avi/Makefile  2006-05-05 10:10:08.000000000 +0300
++++ bitpim-0.9.10/src/native/av/bmp2avi/Makefile       2007-01-16 19:36:41.000000000 +0200
+@@ -13,6 +13,6 @@
+ SRC=avi_file.cxx bmp_file.cxx b2a.cxx
+-bmp2avi.lbin bmp2avi.mbin bmp2avi.exe: $(SRC)
++bmp2avi bmp2avi.mbin bmp2avi.exe: $(SRC)
+       $(CXX) $(EXTRADEFINES) -O2 -o $@ $(SRC)
+diff -Nru bitpim-0.9.10.orig/src/native/usb/build.sh bitpim-0.9.10/src/native/usb/build.sh
+--- bitpim-0.9.10.orig/src/native/usb/build.sh 2006-03-04 06:57:24.000000000 +0200
++++ bitpim-0.9.10/src/native/usb/build.sh      2007-01-16 19:36:41.000000000 +0200
+@@ -4,4 +4,4 @@
+ swig -python -I/usr/include libusb.i
+ gcc -fPIC -Wall -fno-strict-aliasing -O2 -g  -shared  -I $INCLUDEDIR -o _libusb.so libusb_wrap.c -lusb 
+-strip _libusb.so
++#strip _libusb.so
diff --git a/app-mobilephone/bitpim/files/digest-bitpim-0.9.10 b/app-mobilephone/bitpim/files/digest-bitpim-0.9.10
new file mode 100644 (file)
index 0000000..367f794
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 563cf8ff2d48d6871a315ca4cc9e1237 bitpim-0.9.10.tar.bz2 4028416
+RMD160 a6693ebc6a5859af4138ee7c019912f395d6b1d6 bitpim-0.9.10.tar.bz2 4028416
+SHA256 b792e8f83a936a628177837ba4dacb6cdd48de1f56bf0f1a9925f876c5dcad34 bitpim-0.9.10.tar.bz2 4028416