app-crypt/tpm2-tools: Bump to 4.2
authorSalah Coronya <salah.coronya@gmail.com>
Sat, 11 Apr 2020 00:43:55 +0000 (19:43 -0500)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 13 May 2020 13:16:48 +0000 (16:16 +0300)
Closes: https://bugs.gentoo.org/722018
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Salah Coronya <salah.coronya@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-crypt/tpm2-tools/Manifest
app-crypt/tpm2-tools/files/tpm2-tools-4.2-libressl.patch [new file with mode: 0644]
app-crypt/tpm2-tools/metadata.xml
app-crypt/tpm2-tools/tpm2-tools-4.2.ebuild [new file with mode: 0644]

index 5c398b78b3c71dee788c8aae4f2f4ce826d2808f..27bb8e1ebee9fbde3093a8c3ba2517c74d1e0584 100644 (file)
@@ -1,2 +1,3 @@
 DIST tpm2-tools-3.1.4.tar.gz 589388 BLAKE2B aaaa9a0158d0658dc2db4734b18ea1d49bd6c0aef84c4f1236f3134245165dccdb0bada69d92f0e5a59ecb1f2973e5cd25924d2b9c4cad2891d9e4f9fb94a84b SHA512 c5e1be4ffab305ee42a8b4a9c9aa4373158259a58844e273465f97a74f913fb12098b9fd81127148be95ecba7378f6a45b96af256dde3101a237e5e33e8e8ccb
 DIST tpm2-tools-4.1.1.tar.gz 779914 BLAKE2B 5b347b00508183cbde407e01454df0a7eb3a8080cb5b8f73d153c4972b38b98ac7c066664b54aeedef03b9bfd97b3cff482dbc44d5f11215af9c3c7754380d75 SHA512 25952cf947f0acd16b1a8dbd3ac8573bce85ff970a7e24c290c4f9cd29418e77a3e48ac82c932fbd250887a9303ab301ff92db594c2fffaba47b873382444d26
+DIST tpm2-tools-4.2.tar.gz 889062 BLAKE2B 434b88e90f953785e57a9e9f18d717c8b6632206dabfc7478ae866e245eadf032ec4f26bb9597d04ea887bc23a8096d7e6fc2748b0e96806cb2989fd7edf9071 SHA512 7aaf549dd77307e5ad93d4b34737d684c8a7384996143124f10b188f5e99860940902cee83538e6957997859420dd430d6d27979b223beae515aab94ac8fb235
diff --git a/app-crypt/tpm2-tools/files/tpm2-tools-4.2-libressl.patch b/app-crypt/tpm2-tools/files/tpm2-tools-4.2-libressl.patch
new file mode 100644 (file)
index 0000000..2f39db3
--- /dev/null
@@ -0,0 +1,26 @@
+From a1ac2ee0c6592e6f730458c03a2abd1532c66046 Mon Sep 17 00:00:00 2001
+From: Salah Coronya <salah.coronya@gmail.com>
+Date: Sun, 12 Jan 2020 19:17:48 -0600
+Subject: [PATCH] lib/tpm2_openssl.c: Fix build for libressl
+
+Signed-off-by: Salah Coronya <salah.coronya@gmail.com>
+---
+ lib/tpm2_openssl.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/tpm2_openssl.c b/lib/tpm2_openssl.c
+index 505dd7a0..fd3861d9 100644
+--- a/lib/tpm2_openssl.c
++++ b/lib/tpm2_openssl.c
+@@ -14,7 +14,7 @@
+ #include "tpm2_openssl.h"
+ /* compatibility function for OpenSSL versions < 1.1.0 */
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
+ static int BN_bn2binpad(const BIGNUM *a, unsigned char *to, int tolen) {
+     int r;
+     int topad;
+-- 
+2.24.1
+
index b28056e8794181012ae4b4c0b7fcb55eae9e3d69..26b4dcbaf517cbba92da86b6ee927adcbb27bd0e 100644 (file)
@@ -9,6 +9,9 @@
                <email>proxy-maint@gentoo.org</email>
                <name>Proxy Maintainers</name>
        </maintainer>
+       <use>
+               <flag name="fapi">Enable feature API tools</flag>
+       </use>
        <upstream>
                <remote-id type="github">tpm2-software/tpm2-tools</remote-id>
        </upstream>
diff --git a/app-crypt/tpm2-tools/tpm2-tools-4.2.ebuild b/app-crypt/tpm2-tools/tpm2-tools-4.2.ebuild
new file mode 100644 (file)
index 0000000..f791854
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tools for the TPM 2.0 TSS"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+fapi libressl"
+
+# Integration test are now run as part of the testing suite, which will fail
+# because none of the supported TPM emulators are in Portage. In a future
+# version of tpm2-tools, swtpm will be supported and the tests can be run.
+RESTRICT="test"
+
+RDEPEND="net-misc/curl:=
+       fapi? ( >=app-crypt/tpm2-tss-2.4.0:=[fapi?] )
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+PATCHES=(
+       "${FILESDIR}/${P}-libressl.patch"
+)
+
+src_configure() {
+       econf \
+               $(use_enable fapi) \
+               $(use_enable !libressl hardening)
+}