dev-python/testfixtures: bump to 6.8.2
authorVirgil Dupras <vdupras@gentoo.org>
Wed, 8 May 2019 14:36:27 +0000 (10:36 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Wed, 8 May 2019 14:41:17 +0000 (10:41 -0400)
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-python/testfixtures/Manifest
dev-python/testfixtures/testfixtures-6.8.2.ebuild [new file with mode: 0644]

index 4617b7f06cf8561bda039829298dd16d71021076..fb3dc7057a923d70c20960cba95e338a5ec18e03 100644 (file)
@@ -1 +1,2 @@
 DIST testfixtures-4.9.1.tar.gz 90117 BLAKE2B 6560d4072f8b0108b7d7708c980f40df1a05af88df86dd01926bdf0eab107744fc89d75bdedaced7300c24a52a9d1c0685f5dd3f5f732121ff97af6d0859055a SHA512 20053d22297b7852382a4f2bf6d76bde6489f788a9073aaae407f68bb6b3d7bdc4a045868cf7c99fd294936768745ee7d652c86a4a96c33fb0e95fa0d96d2a59
+DIST testfixtures-6.8.2.tar.gz 110838 BLAKE2B 4b83a1459aec4bc4b4dcdff48603958bfd115806ce0c567faad37ac273e93096cf964af08d24b98c1743d6302d1b2f6f9c9498023c781ab3e9170e2eda74cefe SHA512 ce6561d976a0b8f79ae72aaca6f5ffa8d1cae30ad73d3d88625ed4fe55da5f0a913785fa3e9aeb4268dfb243a7b74dddc262554521a71c766089383aa5b0e022
diff --git a/dev-python/testfixtures/testfixtures-6.8.2.ebuild b/dev-python/testfixtures/testfixtures-6.8.2.ebuild
new file mode 100644 (file)
index 0000000..9944852
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of helpers and mock objects for unit tests and doc tests"
+HOMEPAGE="https://pypi.org/project/testfixtures/ https://github.com/Simplistix/testfixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/pkginfo[${PYTHON_USEDEP}]' python2_7 pypy )
+       )
+       test? (
+               dev-python/django[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pytest-django[${PYTHON_USEDEP}]
+               dev-python/sybil[${PYTHON_USEDEP}]
+               >=dev-python/twisted-18[${PYTHON_USEDEP}]
+       )"
+
+python_prepare_all() {
+       # Prevent un-needed download during build, fix Makefile for doc build
+       sed -e '/'sphinx.ext.intersphinx'/d' -i docs/conf.py || die
+
+       # remove test that tests the stripped zope-component test_components.ComponentsTests
+       rm -f testfixtures/tests/test_components.py docs/components.txt || die
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_test() {
+       PYTHONPATH="." \
+       DJANGO_SETTINGS_MODULE=testfixtures.tests.test_django.settings \
+       pytest -vv || die
+}
+
+python_install_all() {
+       use doc && HTML_DOCS=( docs/_build/html/. )
+       distutils-r1_python_install_all
+}