dev-python/pypy*: Fix USE=-ncurses and USE=-gdbm
authorMichał Górny <mgorny@gentoo.org>
Sat, 15 Aug 2015 05:42:19 +0000 (07:42 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 15 Aug 2015 05:44:57 +0000 (07:44 +0200)
Fix USE=-ncurses (and USE=-gdbm in pypy-2.6.0) not to try to regenerate
cffi modules for the two.

Bug: https://bugs.gentoo.org/show_bug.cgi?id=557540#c3

Package-Manager: portage-2.2.20

dev-python/pypy/pypy-2.4.0.ebuild
dev-python/pypy/pypy-2.5.1.ebuild
dev-python/pypy/pypy-2.6.0.ebuild
dev-python/pypy3/pypy3-2.4.0.ebuild

index 15faabb3d294d8d5740f4062cc5a4e4646aa8f5d..352913b2c2aa546803f8b3c78f444c578fe93dde 100644 (file)
@@ -203,11 +203,13 @@ src_install() {
 
        # Generate cffi cache
        # Please keep in sync with pypy/tool/release/package.py!
-       "${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
        "${PYTHON}" -c "import syslog" || die "Failed to import syslog (cffi)"
        if use gdbm; then
                "${PYTHON}" -c "import gdbm" || die "Failed to import gdbm (cffi)"
        fi
+       if use ncurses; then
+               "${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
+       fi
        if use sqlite; then
                "${PYTHON}" -c "import _sqlite3" || die "Failed to import _sqlite3 (cffi)"
        fi
index c07de498ec7dde129f90313f7346d5b856cac23d..109ebeb41543ad2e774fe4f35cdeb8e3a5d8d5a2 100644 (file)
@@ -203,11 +203,13 @@ src_install() {
 
        # Generate cffi cache
        # Please keep in sync with pypy/tool/release/package.py!
-       "${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
        "${PYTHON}" -c "import syslog" || die "Failed to import syslog (cffi)"
        if use gdbm; then
                "${PYTHON}" -c "import gdbm" || die "Failed to import gdbm (cffi)"
        fi
+       if use ncurses; then
+               "${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
+       fi
        if use sqlite; then
                "${PYTHON}" -c "import _sqlite3" || die "Failed to import _sqlite3 (cffi)"
        fi
index d73cb5e5c1c0ae1c2f618e843ba7a3a1ad57302b..18a8810327d8b801360dc4803485ea4ae2ec2869 100644 (file)
@@ -217,8 +217,9 @@ src_install() {
 #    "syslog": "_syslog_build.py" if sys.platform != "win32" else None,
 #    "gdbm": "_gdbm_build.py"  if sys.platform != "win32" else None,
 #    "pwdgrp": "_pwdgrp_build.py" if sys.platform != "win32" else None,
-       cffi_targets=( audioop curses syslog gdbm pwdgrp )
+       cffi_targets=( audioop syslog pwdgrp )
        use gdbm && cffi_targets+=( gdbm )
+       use ncurses && cffi_targets+=( curses )
        use sqlite && cffi_targets+=( sqlite3 )
        use tk && cffi_targets+=( tkinter/tklib )
 
index 20b01f34f5f5fe95b01d41ef284877441b0b3ab3..0c369adb0be0c850ef83d00617b73217f4af2895 100644 (file)
@@ -197,11 +197,13 @@ src_install() {
 
        # Generate cffi cache
        # Please keep in sync with pypy/tool/release/package.py!
-       "${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
        "${PYTHON}" -c "import syslog" || die "Failed to import syslog (cffi)"
        if use gdbm; then
                "${PYTHON}" -c "import _gdbm" || die "Failed to import gdbm (cffi)"
        fi
+       if use ncurses; then
+               "${PYTHON}" -c "import _curses" || die "Failed to import _curses (cffi)"
+       fi
        if use sqlite; then
                "${PYTHON}" -c "import _sqlite3" || die "Failed to import _sqlite3 (cffi)"
        fi