net-vpn/openvpn: Version bump to 2.4.3
authorManuel Rüger <mrueg@gentoo.org>
Wed, 21 Jun 2017 17:56:43 +0000 (19:56 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Wed, 21 Jun 2017 17:57:08 +0000 (19:57 +0200)
Gentoo-Bug: #622376
Package-Manager: Portage-2.3.6, Repoman-2.3.2

net-vpn/openvpn/Manifest
net-vpn/openvpn/openvpn-2.4.3.ebuild [new file with mode: 0644]

index f2ed081a0ccde73b008231e2f3f4a40fcb3d7256..ae855f747a526579a9f84f95d0c5096f594c07d7 100644 (file)
@@ -2,3 +2,4 @@ DIST mock_msg.h 1356 SHA256 d6c56a423753c0b938a5dc32c978984eebb97243a2671a165244
 DIST openvpn-2.3.12.tar.gz 1235262 SHA256 f5d39b8c55f75b0aab943059b20571452b494146d997b12d48ce9bd753c01cff SHA512 8de40e9177268cce64906915ddc0d23381b4040ed00e6eefe4784b04d48f50d5c5ce9e99886eb18fe45d22c5c047478b9aa942e4c4eeaf115cc443a1d3ebe631 WHIRLPOOL 4adeb0da83a4fbff27bc90a3941b593f97dfdc3f50c3ccf10c113293bb0e4f85ead680b53645a2a078f907026549c8dbf068dcc64c9f89b6a967b3eb919f2c8c
 DIST openvpn-2.3.15.tar.gz 1324132 SHA256 705cecebe67ff581db4654f2d7977771546dd0e33f4b09656b5377a6972d84c1 SHA512 bcd7cf01f6da45de6b234d614702242485745f1318a294938b29e750b104e345a8776b10b11a6b4e37f1523bd91db045cf210f4500afcf6d5a232ef859eb9a0e WHIRLPOOL fa269f7aee093c5ec56c28a1117c018a92248db3da3926cab76edc90ca73facaa42bc1b5293ededcca76f3d4ab903c10a82768f3b4d33e0769e86744919574e6
 DIST openvpn-2.4.2.tar.gz 1402516 SHA256 b24740c9d44a81eaf2befc4846d51445a520104321e32aaf0c135ed2e098a624 SHA512 9be3cef25f398c426087581d8bb2589ae2a3a1b3b812c73f7e9a4d3c35098421eea3099b33fc90606162d0429dcd7d9ae3449af89602e060e47cd4c053720e72 WHIRLPOOL 53343492084ac2c3a1672179521b89f0e4c0fda27c80ef4cf7a6e5fd61000e5ad0b0f3db420c1d03131b104c9c64e2fdccc4f689d3585351e54afee815804f7d
+DIST openvpn-2.4.3.tar.gz 1397306 SHA256 84a01aa3df0c12a3552ca3baaa39d700137b5bce4b6de683fe87fb79bfa5df0b SHA512 e6fbe65d9071832871dcd173f5031ae3615b32f122d03a798afa05d2e5af1a6019dcdcf5107c9ea2c47aedf86c8cb61305e429c24696262ca9bc76c54adc1370 WHIRLPOOL 9fcbf2e32106158c58fc44d60a580fd5a6e4e49cb3de96f97bad468a718df0f8c3c8be8b1b1bfc5bc7f8e9463073abba535a955f6dd4f04e30c61f102fec24f8
diff --git a/net-vpn/openvpn/openvpn-2.4.3.ebuild b/net-vpn/openvpn/openvpn-2.4.3.ebuild
new file mode 100644 (file)
index 0000000..8316057
--- /dev/null
@@ -0,0 +1,160 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic user systemd linux-info
+
+DESCRIPTION="Robust and highly flexible tunneling application compatible with many OSes"
+SRC_URI="http://swupdate.openvpn.net/community/releases/${P}.tar.gz
+       test? ( https://raw.githubusercontent.com/OpenVPN/${PN}/v${PV}/tests/unit_tests/${PN}/mock_msg.h )"
+HOMEPAGE="http://openvpn.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x86-macos"
+
+IUSE="down-root examples inotify iproute2 libressl lz4 +lzo mbedtls pam"
+IUSE+=" pkcs11 +plugins selinux +ssl static systemd test userland_BSD"
+
+REQUIRED_USE="static? ( !plugins !pkcs11 )
+       mbedtls? ( ssl !libressl )
+       pkcs11? ( ssl )
+       !plugins? ( !pam !down-root )
+       inotify? ( plugins )"
+
+CDEPEND="
+       kernel_linux? (
+               iproute2? ( sys-apps/iproute2[-minimal] )
+               !iproute2? ( sys-apps/net-tools )
+       )
+       pam? ( virtual/pam )
+       ssl? (
+               !mbedtls? (
+                       !libressl? ( >=dev-libs/openssl-0.9.8:* )
+                       libressl? ( dev-libs/libressl )
+               )
+               mbedtls? ( net-libs/mbedtls )
+       )
+       lz4? ( app-arch/lz4 )
+       lzo? ( >=dev-libs/lzo-1.07 )
+       pkcs11? ( >=dev-libs/pkcs11-helper-1.11 )
+       systemd? ( sys-apps/systemd )"
+DEPEND="${CDEPEND}
+       test? ( dev-util/cmocka )"
+RDEPEND="${CDEPEND}
+       selinux? ( sec-policy/selinux-openvpn )"
+
+CONFIG_CHECK="~TUN"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-external-cmocka.patch"
+)
+
+pkg_setup()  {
+       linux-info_pkg_setup
+}
+
+src_prepare() {
+       default
+       eautoreconf
+
+       if use test; then
+               cp "${DISTDIR}/mock_msg.h" tests/unit_tests/${PN} || die
+       fi
+}
+
+src_configure() {
+       use static && append-ldflags -Xcompiler -static
+       SYSTEMD_UNIT_DIR=$(systemd_get_systemunitdir) \
+       TMPFILES_DIR="/usr/lib/tmpfiles.d" \
+       econf \
+               $(usex mbedtls '--with-crypto-library=mbedtls' '') \
+               $(use_enable inotify async-push) \
+               $(use_enable ssl crypto) \
+               $(use_enable lz4) \
+               $(use_enable lzo) \
+               $(use_enable pkcs11) \
+               $(use_enable plugins) \
+               $(use_enable iproute2) \
+               $(use_enable pam plugin-auth-pam) \
+               $(use_enable down-root plugin-down-root) \
+               $(use_enable test tests) \
+               $(use_enable systemd)
+}
+
+src_test() {
+       make check || die "top-level tests failed"
+       pushd tests/unit_tests > /dev/null || die
+       make check || die "unit tests failed"
+       popd > /dev/null || die
+}
+
+src_install() {
+       default
+       find "${ED}/usr" -name '*.la' -delete
+       # install documentation
+       dodoc AUTHORS ChangeLog PORTS README README.IPv6
+
+       # Install some helper scripts
+       keepdir /etc/openvpn
+       exeinto /etc/openvpn
+       doexe "${FILESDIR}/up.sh"
+       doexe "${FILESDIR}/down.sh"
+
+       # Install the init script and config file
+       newinitd "${FILESDIR}/${PN}-2.1.init" openvpn
+       newconfd "${FILESDIR}/${PN}-2.1.conf" openvpn
+
+       # install examples, controlled by the respective useflag
+       if use examples ; then
+               # dodoc does not supportly support directory traversal, #15193
+               insinto /usr/share/doc/${PF}/examples
+               doins -r sample contrib
+       fi
+}
+
+pkg_postinst() {
+       # Add openvpn user so openvpn servers can drop privs
+       # Clients should run as root so they can change ip addresses,
+       # dns information and other such things.
+       enewgroup openvpn
+       enewuser openvpn "" "" "" openvpn
+
+       if path_exists -o "${EROOT%/}"/etc/openvpn/*/local.conf ; then
+               ewarn "WARNING: The openvpn init script has changed"
+               ewarn ""
+       fi
+
+       if use x64-macos; then
+               elog "You might want to install tuntaposx for TAP interface support:"
+               elog "http://tuntaposx.sourceforge.net"
+       fi
+
+       elog "The openvpn init script expects to find the configuration file"
+       elog "openvpn.conf in /etc/openvpn along with any extra files it may need."
+       elog ""
+       elog "To create more VPNs, simply create a new .conf file for it and"
+       elog "then create a symlink to the openvpn init script from a link called"
+       elog "openvpn.newconfname - like so"
+       elog "   cd /etc/openvpn"
+       elog "   ${EDITOR##*/} foo.conf"
+       elog "   cd /etc/init.d"
+       elog "   ln -s openvpn openvpn.foo"
+       elog ""
+       elog "You can then treat openvpn.foo as any other service, so you can"
+       elog "stop one vpn and start another if you need to."
+
+       if grep -Eq "^[ \t]*(up|down)[ \t].*" "${ROOT}/etc/openvpn"/*.conf 2>/dev/null ; then
+               ewarn ""
+               ewarn "WARNING: If you use the remote keyword then you are deemed to be"
+               ewarn "a client by our init script and as such we force up,down scripts."
+               ewarn "These scripts call /etc/openvpn/\$SVCNAME-{up,down}.sh where you"
+               ewarn "can move your scripts to."
+       fi
+
+       if use plugins ; then
+               einfo ""
+               einfo "plugins have been installed into /usr/$(get_libdir)/${PN}/plugins"
+       fi
+}