dev-python/pathlib2: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 11:31:19 +0000 (12:31 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 11:36:34 +0000 (12:36 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pathlib2/Manifest
dev-python/pathlib2/pathlib2-2.3.0.ebuild [deleted file]
dev-python/pathlib2/pathlib2-2.3.2.ebuild [deleted file]

index abe89efbe9657791c926dd610c6af60b7ea58587..941e0e9768053c2ef86b4f1c382a6847fb77d0d4 100644 (file)
@@ -1,3 +1 @@
-DIST pathlib2-2.3.0.tar.gz 34291 BLAKE2B ef1768f8a9cc9b28f85ef84c0dfdbfce0b0087c1ffb6718e2b13eb007ea3e0ab0eebe946a1bcc2683fed7db46867f415ad2b52abedcdc87fb67bd45d5998aea5 SHA512 715fbd981d42767862dcaf2cc0fee31b9ec5050915ef7d909d14587609a7a5939e32b39736b586a890e7625443bb163832896fcf138b5c2863c451b71c36a124
-DIST pathlib2-2.3.2.tar.gz 33764 BLAKE2B c652069d60f489e482c6d75c0a201c5ac67c6b18b4acd6c8b00f7f12832f7165a45293d93ca7f6c45f1451c842e59931b6b8c45608de1bac91ad822cc3536105 SHA512 46ba0cc8b26006bc4cb914118b7c453dc49cc8a80147ea7a4b3d5a17e97d5538c5d73a3029bd7e5b59f42f256baba30ea273382e57468df1a459ac6f7c237ddc
 DIST pathlib2-2.3.5.tar.gz 34393 BLAKE2B 7e03214a53f1ebf7718d04f653e24ffa4b06070b0ae21583d98ea0ce956c5aced5ea63bf6062d8e8d979bef4c82137cd2d2d5d6121dc3dda0ae1f713c1868d36 SHA512 3f0f212bf5208d0965ac02a590bef6ac0ec5e3b702828c06c3c9d37119b3db422cc7873de614fdc37ebfb3f52239a6517008d9672a176ca15d03fe13baeeddc8
diff --git a/dev-python/pathlib2/pathlib2-2.3.0.ebuild b/dev-python/pathlib2/pathlib2-2.3.0.ebuild
deleted file mode 100644 (file)
index d1a68f3..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Fork of pathlib aiming to support the full stdlib Python API"
-HOMEPAGE="https://github.com/mcmtroffaes/pathlib2"
-SRC_URI="mirror://pypi/p/pathlib2/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       $(python_gen_cond_dep 'dev-python/scandir[${PYTHON_USEDEP}]' -2 )
-       dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2) )"
-
-python_prepare_all() {
-       # stop using private Python API
-       # https://github.com/mcmtroffaes/pathlib2/issues/39
-       sed -i -e 's/support\.android_not_root/False/' test*.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       "${EPYTHON}" test_pathlib2.py -v || die
-       "${EPYTHON}" test_pathlib2_with_py2_unicode_literals.py -v || die
-}
diff --git a/dev-python/pathlib2/pathlib2-2.3.2.ebuild b/dev-python/pathlib2/pathlib2-2.3.2.ebuild
deleted file mode 100644 (file)
index aa5cc7b..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Fork of pathlib aiming to support the full stdlib Python API"
-HOMEPAGE="https://github.com/mcmtroffaes/pathlib2"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       $(python_gen_cond_dep 'dev-python/scandir[${PYTHON_USEDEP}]' -2 )
-       dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               ${RDEPEND}
-               $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
-       )
-"
-
-python_test() {
-       "${EPYTHON}" tests/test_pathlib2.py -v || \
-               die "tests failed with ${EPYTHON}"
-}