media-tv/ivtv-utils: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 13:20:27 +0000 (14:20 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 13:20:27 +0000 (14:20 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-tv/ivtv-utils/files/ivtv-utils-1.4.0-gentoo.patch
media-tv/ivtv-utils/files/ivtv-utils-1.4.1-overflow.patch
media-tv/ivtv-utils/ivtv-utils-1.4.1.ebuild

index 4b75d177e39118feb7667c3538258d545f27e9a0..5c03e6e737ee474c69828f8522e8bcdcb9b0a9a8 100644 (file)
@@ -10,8 +10,8 @@ https://bugs.gentoo.org/show_bug.cgi?id=321303
 
 Patch written by Kacper Kowalik <xarthisius.kk@gmail.com>
 
---- test/Makefile
-+++ test/Makefile
+--- a/test/Makefile
++++ b/test/Makefile
 @@ -7,13 +7,13 @@
        ivtv-osd-dma-test ivtv-fb-colormap-test \
        ivtv-fb-16-bit-test ps-analyzer
@@ -30,8 +30,8 @@ Patch written by Kacper Kowalik <xarthisius.kk@gmail.com>
 
  clean: 
        rm -f *.o $(EXES)
---- utils/Makefile.orig        2010-05-24 15:35:11.321677941 +0000
-+++ utils/Makefile     2010-05-24 15:35:15.595615306 +0000
+--- a/utils/Makefile
++++ b/utils/Makefile
 @@ -9,41 +9,39 @@
  X86_EXES := ivtvplay ivtv-mpegindex #ivtv-encoder
  endif
@@ -86,8 +86,8 @@ Patch written by Kacper Kowalik <xarthisius.kk@gmail.com>
        install -d $(DESTDIR)/$(BINDIR)
        install -m 0755 $(BIN) $(DESTDIR)/$(BINDIR)
  
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
 @@ -1,6 +1,6 @@
  all clean install:
 -      make -C utils $@
index 1c2a66159639b1bd146048926b7dbab157b23001..24f24d41acaa7ad06eedbbd4cbd76433e214702b 100644 (file)
@@ -1,7 +1,7 @@
 http://bugs.gentoo.org/339405
 
---- utils/cx25840ctl/cx25840ctl.c
-+++ utils/cx25840ctl/cx25840ctl.c
+--- a/utils/cx25840ctl/cx25840ctl.c
++++ b/utils/cx25840ctl/cx25840ctl.c
 @@ -57,7 +57,7 @@
                return 0;
        }
@@ -20,8 +20,8 @@ http://bugs.gentoo.org/339405
        if ((fp = fopen(sysfile, "r")) != NULL)
        {
                fgets(name, sizeof(name), fp);
---- utils/ivtv-ctl.c
-+++ utils/ivtv-ctl.c
+--- a/utils/ivtv-ctl.c
++++ b/utils/ivtv-ctl.c
 @@ -358,7 +358,7 @@
        __u32 reset = 0;
        int new_debug_level, gdebug_level;
@@ -49,8 +49,8 @@ http://bugs.gentoo.org/339405
                if (dowrite(buf, "/sys/module/ivtv/parameters/debug") == 0) {
                        printf(" set debug level: ");
                        print_debug_mask(new_debug_level);
---- utils/v4l2-ctl.cpp
-+++ utils/v4l2-ctl.cpp
+--- a/utils/v4l2-ctl.cpp
++++ b/utils/v4l2-ctl.cpp
 @@ -416,7 +416,7 @@
  {
        char buf[10];
index 14f05778ee08447828e671ad0bbbf53ffad03181..637e4c6bad13ae5e6f2cd759f24b48b152937393 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
 
 DESCRIPTION="IVTV utilities for Hauppauge PVR PCI cards"
 HOMEPAGE="http://www.ivtvdriver.org/"
@@ -20,24 +21,22 @@ RDEPEND="${DEPEND}
                dev-perl/Video-Frequencies
                dev-perl/Video-ivtv
                dev-perl/Config-IniFiles
-               virtual/perl-Getopt-Long
                dev-perl/Tk
-               )"
+               virtual/perl-Getopt-Long
+       )"
 
-src_prepare() {
-       epatch \
-               "${FILESDIR}"/${PN}-1.4.0-gentoo.patch \
-               "${FILESDIR}"/${PN}-1.4.1-overflow.patch
-}
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.4.0-gentoo.patch
+       "${FILESDIR}"/${PN}-1.4.1-overflow.patch
+)
 
-src_compile() {
+src_configure() {
        tc-export CC CXX
-       emake
 }
 
 src_install() {
        emake DESTDIR="${D}" PREFIX="/usr" install
-       dodoc ChangeLog README doc/*
+       dodoc -r ChangeLog README doc/.
 
        if use perl; then
                dobin utils/perl/*.pl