www-client/firefox: don't install -x11 shortcut/.desktop file when not needed
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 30 Mar 2020 15:34:36 +0000 (17:34 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 30 Mar 2020 15:43:00 +0000 (17:43 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
www-client/firefox/firefox-68.6.0-r3.ebuild
www-client/firefox/firefox-74.0-r2.ebuild

index 24ceeba5ece5cdd1657658bfd671663307dd02ed..035e41b50ae759bb3ec37066498c5eb2bc9c5a34 100644 (file)
@@ -762,11 +762,14 @@ PROFILE_EOF
                                newbin "${FILESDIR}"/firefox-wayland.sh firefox-wayland
                                ;;
                        X11)
-                               exec_command='firefox-x11 --name firefox-x11'
-                               if use wayland ; then
-                                       # Only needed when there's actually a choice
-                                       newbin "${FILESDIR}"/firefox-x11.sh firefox-x11
+                               if ! use wayland ; then
+                                       # Exit loop here because there's no choice so
+                                       # we don't need wrapper/.desktop file for X11.
+                                       continue
                                fi
+
+                               exec_command='firefox-x11 --name firefox-x11'
+                               newbin "${FILESDIR}"/firefox-x11.sh firefox-x11
                                ;;
                        *)
                                app_name="${name}"
index f6e5a2262fa652c47999810b6f4581b78343504c..2698ac6f81faf09330484aadf1fe544a2430b565 100644 (file)
@@ -781,11 +781,14 @@ PROFILE_EOF
                                newbin "${FILESDIR}"/firefox-wayland.sh firefox-wayland
                                ;;
                        X11)
-                               exec_command='firefox-x11 --name firefox-x11'
-                               if use wayland ; then
-                                       # Only needed when there's actually a choice
-                                       newbin "${FILESDIR}"/firefox-x11.sh firefox-x11
+                               if ! use wayland ; then
+                                       # Exit loop here because there's no choice so
+                                       # we don't need wrapper/.desktop file for X11.
+                                       continue
                                fi
+
+                               exec_command='firefox-x11 --name firefox-x11'
+                               newbin "${FILESDIR}"/firefox-x11.sh firefox-x11
                                ;;
                        *)
                                app_name="${name}"