app-text/jing: Package removal. Fixes bug 557210.
authorPatrice Clement <monsieurp@gentoo.org>
Sun, 13 Sep 2015 16:05:05 +0000 (16:05 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Sun, 13 Sep 2015 16:25:42 +0000 (16:25 +0000)
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
app-text/jing/Manifest [deleted file]
app-text/jing/files/build-patch.diff [deleted file]
app-text/jing/files/build-r1.xml [deleted file]
app-text/jing/files/jing-20030619-xerces.patch [deleted file]
app-text/jing/jing-20091111-r1.ebuild [deleted file]
app-text/jing/jing-20091111-r2.ebuild [deleted file]
app-text/jing/metadata.xml [deleted file]

diff --git a/app-text/jing/Manifest b/app-text/jing/Manifest
deleted file mode 100644 (file)
index ff25e5a..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST jing-20091111.zip 3207457 SHA256 57690280aa6b5521b570aaa5fe77e1b48d84b2a1b0a24da62f9b982c4416908c SHA512 d30e5569157cfb78d711a91d5a032a8c3ed3cba5579d15cc17fe963a591b4b5f1b6ae7c7c0b8042461ff5d04572dfd6eb355537767bf3b554baa67cfe35a2813 WHIRLPOOL 83242897d32ac7f617c24f99107abc239770706d742d58a576c2d15e7dc7e61474cc5b95eae8d96547755a8c5abc16f8b8bec9904bf7b30c4dcc8bdb9f66a5a7
diff --git a/app-text/jing/files/build-patch.diff b/app-text/jing/files/build-patch.diff
deleted file mode 100644 (file)
index f60d9af..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -uprN src.orig/com/thaiopensource/validate/schematron/SaxonSchemaReaderFactory.java src/com/thaiopensource/validate/schematron/SaxonSchemaReaderFactory.java
---- src.orig/com/thaiopensource/validate/schematron/SaxonSchemaReaderFactory.java      2004-11-07 02:12:02.231733296 +0100
-+++ src/com/thaiopensource/validate/schematron/SaxonSchemaReaderFactory.java   2004-11-07 02:11:40.888977888 +0100
-@@ -1,6 +1,6 @@
- package com.thaiopensource.validate.schematron;
--import com.icl.saxon.TransformerFactoryImpl;
-+import net.sf.saxon.TransformerFactoryImpl;
- import javax.xml.transform.TransformerFactory;
-diff -uprN src.orig/com/thaiopensource/validate/schematron/SchemaReaderImpl.java src/com/thaiopensource/validate/schematron/SchemaReaderImpl.java
---- src.orig/com/thaiopensource/validate/schematron/SchemaReaderImpl.java      2004-11-07 02:12:02.230733448 +0100
-+++ src/com/thaiopensource/validate/schematron/SchemaReaderImpl.java   2004-11-07 02:11:40.886978192 +0100
-@@ -85,7 +85,7 @@ class SchemaReaderImpl implements Schema
-   private void initTransformerFactory(TransformerFactory factory) {
-     String name = factory.getClass().getName();
-     try {
--      if (name.equals("com.icl.saxon.TransformerFactoryImpl"))
-+      if (name.equals("net.sf.saxon.TransformerFactoryImpl"))
-         factory.setAttribute("http://icl.com/saxon/feature/linenumbering",
-                              Boolean.TRUE);
-       else if (name.equals("org.apache.xalan.processor.TransformerFactoryImpl")) {
diff --git a/app-text/jing/files/build-r1.xml b/app-text/jing/files/build-r1.xml
deleted file mode 100644 (file)
index 8de4f9a..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-<?xml version="1.0"?>
-
-<project name="jing" default="jar">
-       <!-- compiles the sources -->
-       <target name="compile">
-               <mkdir dir="build" />
-       
-               <javac srcdir="src" 
-                       destdir="build"
-                       source="1.4">
-                       <classpath>
-                               <fileset dir="bin" includes="*.jar"/>
-                       </classpath>
-               </javac>
-               
-               <!-- we need the *.properties at the correct 
-                    position in the jar archive!        -->
-               <copy todir="build">
-               <fileset dir="src">
-                       <include name="**/*.properties" />
-               </fileset>
-               </copy>
-               <copy todir="build/META-INF">
-                       <fileset dir="src/META-INF" />
-               </copy>
-       </target>
-
-       <!-- create the jar archive -->
-       <target name="jar" depends="compile">
-               <jar jarfile="bin/jing.jar"
-                       basedir="build">
-               </jar>
-       </target>
-</project>
diff --git a/app-text/jing/files/jing-20030619-xerces.patch b/app-text/jing/files/jing-20030619-xerces.patch
deleted file mode 100644 (file)
index 5873822..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-Only in jing-20030619: META-INF
-diff -ru jing-20030619-orig/src/com/thaiopensource/relaxng/util/JingTask.java jing-20030619/src/com/thaiopensource/relaxng/util/JingTask.java
---- jing-20030619-orig/src/com/thaiopensource/relaxng/util/JingTask.java       2003-05-30 20:54:52.000000000 -0400
-+++ jing-20030619/src/com/thaiopensource/relaxng/util/JingTask.java    2006-01-22 00:14:34.000000000 -0500
-@@ -178,4 +178,11 @@
-     filesets.addElement(set);
-   }
-+  public String getXMLVersion() {
-+    throw new UnsupportedOperationException();
-+  }
-+
-+  public int getCharacterOffset() {
-+    throw new UnsupportedOperationException();
-+  }
- }
-diff -ru jing-20030619-orig/src/com/thaiopensource/validate/xerces/ValidatorImpl.java jing-20030619/src/com/thaiopensource/validate/xerces/ValidatorImpl.java
---- jing-20030619-orig/src/com/thaiopensource/validate/xerces/ValidatorImpl.java       2003-06-19 13:57:22.000000000 -0400
-+++ jing-20030619/src/com/thaiopensource/validate/xerces/ValidatorImpl.java    2006-01-22 00:15:10.000000000 -0500
-@@ -330,4 +330,12 @@
-       throw (RuntimeException)nested;
-     return new SAXException(nested);
-   }
-+
-+  public String getXMLVersion() {
-+    throw new UnsupportedOperationException();
-+  }
-+  public int getCharacterOffset() {
-+    throw new UnsupportedOperationException();
-+  }
-+               
- }
-Only in jing-20030619/src/com/thaiopensource/validate/xerces: .ValidatorImpl.java.swp
diff --git a/app-text/jing/jing-20091111-r1.ebuild b/app-text/jing/jing-20091111-r1.ebuild
deleted file mode 100644 (file)
index 3a14e77..0000000
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-JAVA_PKG_IUSE="doc examples source"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Jing: A RELAX NG validator in Java"
-HOMEPAGE="http://thaiopensource.com/relaxng/jing.html"
-SRC_URI="https://jing-trang.googlecode.com/files/${P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE=""
-
-COMMON_DEPEND="
-       dev-java/ant-core:0
-       dev-java/iso-relax:0
-       dev-java/relaxng-datatype:0
-       dev-java/saxon:9
-       dev-java/xalan:0
-       dev-java/xerces:2
-       dev-java/xml-commons-resolver:0"
-RDEPEND="${COMMON_DEPEND}
-       >=virtual/jre-1.5"
-DEPEND="${COMMON_DEPEND}
-       >=virtual/jdk-1.5
-       app-arch/unzip"
-
-# Avoid bogous QA warning, no usable build.xml. The one that exists belongs to
-# the examples.
-S="${WORKDIR}/${P}/src"
-
-src_unpack() {
-       default
-
-       mkdir -p "${S}" || die
-       pushd "${S}" >/dev/null || die
-               unpack ./../src.zip
-       popd >/dev/null
-
-       # get the resourses from prebuilt jar
-       # https://code.google.com/p/jing-trang/issues/detail?id=84
-       mkdir -p "${S}"/target/classes || die
-       pushd "${S}"/target/classes >/dev/null || die
-               unpack ./../../../bin/${PN}.jar
-               find -name '*.class' -exec rm {} + || die
-       popd >/dev/null
-}
-
-java_prepare() {
-       find "${WORKDIR}" -name '*.jar' -exec rm -v {} + || die
-
-       #remove bundled relaxng-datatype
-       rm -rv org || die
-
-       # for use with saxon:6.5
-       rm -v com/thaiopensource/validate/schematron/OldSaxonSchemaReaderFactory.java || die
-       sed -i -e '/OldSaxonSchemaReaderFactory/d' \
-               target/classes/META-INF/services/com.thaiopensource.validate.SchemaReaderFactory || die
-}
-
-JAVA_GENTOO_CLASSPATH="ant-core,iso-relax,relaxng-datatype,saxon-9,xalan,xerces-2,xml-commons-resolver"
-
-#src_test() {
-#      # would need some test files could probably take this from the gcj version
-#      #java -cp ${cp} com.thaiopensource.datatype.xsd.regex.test.TestDriver || die
-#      #java -cp ${cp} com.thaiopensource.datatype.relaxng.util.TestDriver || die
-#      #java -cp ${cp} com.thaiopensource.datatype.xsd.regex.test.CategoryTest \
-#      #       || die
-#}
-
-src_install() {
-       java-pkg-simple_src_install
-       java-pkg_dolauncher ${PN} --main com.thaiopensource.relaxng.util.Driver
-
-       use doc && dohtml ../doc/*html
-       use examples && java-pkg_doexamples ../sample
-}
diff --git a/app-text/jing/jing-20091111-r2.ebuild b/app-text/jing/jing-20091111-r2.ebuild
deleted file mode 100644 (file)
index 63c59d2..0000000
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc examples source"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Jing: A RELAX NG validator in Java"
-HOMEPAGE="http://thaiopensource.com/relaxng/jing.html"
-SRC_URI="https://jing-trang.googlecode.com/files/${P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-COMMON_DEPEND="
-       dev-java/ant-core:0
-       dev-java/iso-relax:0
-       dev-java/relaxng-datatype:0
-       dev-java/saxon:9
-       dev-java/xalan:0
-       dev-java/xerces:2
-       dev-java/xml-commons-resolver:0"
-RDEPEND="${COMMON_DEPEND}
-       >=virtual/jre-1.6"
-DEPEND="${COMMON_DEPEND}
-       >=virtual/jdk-1.6
-       app-arch/unzip"
-
-# Avoid bogous QA warning, no usable build.xml. The one that exists belongs to
-# the examples.
-S="${WORKDIR}/${P}/src"
-
-src_unpack() {
-       default
-
-       mkdir -p "${S}" || die
-       pushd "${S}" >/dev/null || die
-               unpack ./../src.zip
-       popd >/dev/null
-
-       # get the resourses from prebuilt jar
-       # https://code.google.com/p/jing-trang/issues/detail?id=84
-       mkdir -p "${S}"/target/classes || die
-       pushd "${S}"/target/classes >/dev/null || die
-               unpack ./../../../bin/${PN}.jar
-               find -name '*.class' -exec rm {} + || die
-       popd >/dev/null
-}
-
-java_prepare() {
-       find "${WORKDIR}" -name '*.jar' -exec rm -v {} + || die
-
-       #remove bundled relaxng-datatype
-       rm -rv org || die
-
-       # for use with saxon:6.5
-       rm -v com/thaiopensource/validate/schematron/OldSaxonSchemaReaderFactory.java || die
-       sed -i -e '/OldSaxonSchemaReaderFactory/d' \
-               target/classes/META-INF/services/com.thaiopensource.validate.SchemaReaderFactory || die
-}
-
-JAVA_GENTOO_CLASSPATH="ant-core,iso-relax,relaxng-datatype,saxon-9,xalan,xerces-2,xml-commons-resolver"
-
-#src_test() {
-#      # would need some test files could probably take this from the gcj version
-#      #java -cp ${cp} com.thaiopensource.datatype.xsd.regex.test.TestDriver || die
-#      #java -cp ${cp} com.thaiopensource.datatype.relaxng.util.TestDriver || die
-#      #java -cp ${cp} com.thaiopensource.datatype.xsd.regex.test.CategoryTest \
-#      #       || die
-#}
-
-src_install() {
-       java-pkg-simple_src_install
-       java-pkg_dolauncher ${PN} --main com.thaiopensource.relaxng.util.Driver
-
-       use doc && dohtml ../doc/*html
-       use examples && java-pkg_doexamples ../sample
-}
diff --git a/app-text/jing/metadata.xml b/app-text/jing/metadata.xml
deleted file mode 100644 (file)
index 838c00a..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>java</herd>
-</pkgmetadata>