dev-python/py-amqp: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 17:01:25 +0000 (18:01 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 17:07:02 +0000 (18:07 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/py-amqp/Manifest
dev-python/py-amqp/py-amqp-2.3.2.ebuild [deleted file]
dev-python/py-amqp/py-amqp-2.4.2.ebuild [deleted file]

index 6a6e3e472448a71939b3d2cc41f332af6b54fd36..be00d6a220c690ee600e91f7ece0c02e4b77665e 100644 (file)
@@ -1,3 +1 @@
-DIST amqp-2.3.2.tar.gz 105854 BLAKE2B 8bacae52f03118e2d0fb93a6494628f18f7139d655f1c4b3e7cda9fd81eba5d92f56038bc01dd4a28a89168be0fd51013db0060e945e7f7c63e1423892feaee6 SHA512 c9c99a238cf64ab5590eaea5756e9f68d58769b4d74af3405321d5c129171f34e6a5d20f2125ef2828e843b637fbd115d1ee9391726fe6ff09d233f0e6bdd511
-DIST amqp-2.4.2.tar.gz 116265 BLAKE2B 1615563ad4ea86ebd970641ed409d3f90aba86c4f4eb4af3fbd528cdbe68642a83e05bbed8b8bcc5f503c227003f078c2cbd444f56218af5d02961f1008319ec SHA512 dba880c07ee8b503e02f11ea5804f559ac2eb85717118d796558b1890032482babd15930af78f9d11b77530d496fce3ba8c8579eec71ce5a3f76b8d8a181af34
 DIST amqp-2.5.0.tar.gz 117022 BLAKE2B d05df3699a73ee3cc9540599b7947b4ad9fc1d74194cfbea81787d85c0f83262d109c153669d746ccfb67a1ecb21755da4615043ebfa67c84c8f108ef61ecd3c SHA512 c0675b85bb4d8bdc7c303bb694153c86eb503fa3c4fe6b6c4dac6b1f3aac2fbfa75a4ec39ea8bbdedc297a6a3407a0a5b560885df761e667e3c0770f5979156b
diff --git a/dev-python/py-amqp/py-amqp-2.3.2.ebuild b/dev-python/py-amqp/py-amqp-2.3.2.ebuild
deleted file mode 100644 (file)
index fad3bec..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_PN="amqp"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Low-level AMQP client for Python (fork of amqplib)"
-HOMEPAGE="https://github.com/celery/py-amqp https://pypi.org/project/amqp/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc extras test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/vine-1.1.3[${PYTHON_USEDEP}]
-       doc? (
-               dev-python/sphinx[${PYTHON_USEDEP}]
-               dev-python/sphinx_celery[${PYTHON_USEDEP}]
-       )
-       test? (
-               >=dev-python/case-1.3.1[${PYTHON_USEDEP}]
-               >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
-               dev-python/pytest-cov[${PYTHON_USEDEP}]
-               dev-python/pytest-mock[${PYTHON_USEDEP}]
-       )
-"
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       esetup.py test
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       if use extras; then
-               insinto /usr/share/${PF}/extras
-               doins -r extra
-       fi
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/py-amqp/py-amqp-2.4.2.ebuild b/dev-python/py-amqp/py-amqp-2.4.2.ebuild
deleted file mode 100644 (file)
index 4ef779d..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN="amqp"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Low-level AMQP client for Python (fork of amqplib)"
-HOMEPAGE="https://github.com/celery/py-amqp https://pypi.org/project/amqp/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc extras test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/vine-1.1.3[${PYTHON_USEDEP}]
-       doc? (
-               dev-python/sphinx[${PYTHON_USEDEP}]
-               dev-python/sphinx_celery[${PYTHON_USEDEP}]
-       )
-       test? (
-               >=dev-python/case-1.3.1[${PYTHON_USEDEP}]
-               >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
-               dev-python/pytest-cov[${PYTHON_USEDEP}]
-               dev-python/pytest-mock[${PYTHON_USEDEP}]
-       )
-"
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       esetup.py test
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       if use extras; then
-               insinto /usr/share/${PF}/extras
-               doins -r extra
-       fi
-       distutils-r1_python_install_all
-}