dev-python/uncompyle6: remove last-rited pkg
authorMikle Kolyada <zlogene@gentoo.org>
Mon, 6 Apr 2020 05:45:13 +0000 (08:45 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Mon, 6 Apr 2020 05:45:13 +0000 (08:45 +0300)
Closes: https://bugs.gentoo.org/711808

Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-python/uncompyle6/Manifest [deleted file]
dev-python/uncompyle6/metadata.xml [deleted file]
dev-python/uncompyle6/uncompyle6-2.10.1.ebuild [deleted file]

diff --git a/dev-python/uncompyle6/Manifest b/dev-python/uncompyle6/Manifest
deleted file mode 100644 (file)
index 6ee251a..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST uncompyle6-2.10.1.tar.gz 831835 BLAKE2B dbde4d8414804d55871d846ad42f9a4859913ee057dcea5f6f19e8104e39d3274e13c86538f3364e6829d2ca9ecd16929143e266a828558e870d0f78d3cdff1b SHA512 5be7c33749f3a2a02494aceebeeb2cb79bf71c39784dbe4e96cf9a5c6f02af89874bc25ba911308f01414e4ae4d9ac445864505c629d41a2c6f8b2eae2197b2b
diff --git a/dev-python/uncompyle6/metadata.xml b/dev-python/uncompyle6/metadata.xml
deleted file mode 100644 (file)
index bdb695e..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <maintainer type="project">
-               <email>python@gentoo.org</email>
-               <name>Python</name>
-       </maintainer>
-       <upstream>
-               <maintainer>
-                       <email>rb@dustyfeet.com</email>
-                       <name>Rocky Bernstein</name>
-               </maintainer>
-               <remote-id type="pypi">uncompyle6</remote-id>
-               <remote-id type="github">rocky/python-uncompyle6</remote-id>
-       </upstream>
-</pkgmetadata>
diff --git a/dev-python/uncompyle6/uncompyle6-2.10.1.ebuild b/dev-python/uncompyle6/uncompyle6-2.10.1.ebuild
deleted file mode 100644 (file)
index ee56d1e..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python cross-version byte-code deparser"
-HOMEPAGE="https://github.com/rocky/python-uncompyle6/ https://pypi.org/project/uncompyle6/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/xdis-3.3.1
-       <dev-python/xdis-3.4.0
-       >=dev-python/spark-parser-1.6.1
-       <dev-python/spark-parser-1.7.0"
-DEPEND="${RDEPEND}
-       test? (
-               >=dev-python/nose-1.0[${PYTHON_USEDEP}]
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/hypothesis[${PYTHON_USEDEP}]
-       )
-"
-
-python_prepare_all() {
-       distutils-r1_python_prepare_all
-}
-
-# only run the recommended "make check" tests
-python_test() {
-       distutils_install_for_testing
-
-       PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
-               emake check
-}