new upstream release.
authorAkinori Hattori <hattya@gentoo.org>
Fri, 1 Dec 2006 11:37:47 +0000 (11:37 +0000)
committerAkinori Hattori <hattya@gentoo.org>
Fri, 1 Dec 2006 11:37:47 +0000 (11:37 +0000)
Package-Manager: portage-2.1.1-r2

dev-lang/gauche/ChangeLog
dev-lang/gauche/files/digest-gauche-0.8.8 [new file with mode: 0644]
dev-lang/gauche/files/gauche-0.8.8-report-error.diff [new file with mode: 0644]
dev-lang/gauche/gauche-0.8.8.ebuild [new file with mode: 0644]

index 273d06d466aff6611d327e75b8503f957a8d5d19..d42ccb7d51c9a9e20a7d1dfb0a91f177a7affd43 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for dev-lang/gauche
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gauche/ChangeLog,v 1.26 2006/07/14 14:52:03 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gauche/ChangeLog,v 1.27 2006/12/01 11:37:47 hattya Exp $
+
+*gauche-0.8.8 (01 Dec 2006)
+
+  01 Dec 2006; Akinori Hattori <hattya@gentoo.org>
+  +files/gauche-0.8.8-report-error.diff, -gauche-0.8.6-r1.ebuild,
+  +gauche-0.8.8.ebuild:
+  new upstream release.
 
   14 Jul 2006; Akinori Hattori <hattya@gentoo.org> gauche-0.8.7.ebuild:
   stable on ia64.
diff --git a/dev-lang/gauche/files/digest-gauche-0.8.8 b/dev-lang/gauche/files/digest-gauche-0.8.8
new file mode 100644 (file)
index 0000000..5f21d6e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 ed12c4e28ec36f68629843c4e8725ccc Gauche-0.8.8.tgz 3022297
+RMD160 dbac8e0359eaa4bf9378d771485fadab678d77e9 Gauche-0.8.8.tgz 3022297
+SHA256 508834bd84a4c5446d6c8d7606246debea5bc88a8b6a06ee6c42f4f93d07cf11 Gauche-0.8.8.tgz 3022297
diff --git a/dev-lang/gauche/files/gauche-0.8.8-report-error.diff b/dev-lang/gauche/files/gauche-0.8.8-report-error.diff
new file mode 100644 (file)
index 0000000..e0f9559
--- /dev/null
@@ -0,0 +1,19 @@
+Index: src/main.c
+===================================================================
+RCS file: /cvsroot/gauche/Gauche/src/main.c,v
+retrieving revision 1.92
+retrieving revision 1.93
+diff -u -I$.*$ -r1.92 -r1.93
+--- src/main.c 13 Nov 2006 22:38:12 -0000      1.92
++++ src/main.c 18 Nov 2006 01:20:03 -0000      1.93
+@@ -442,7 +442,10 @@
+             if (r > 0) {
+                 ScmObj res = epak.results[0];
+                 if (SCM_INTP(res)) exit_code = SCM_INT_VALUE(res);
++                else exit_code = 70;  /* EX_SOFTWARE, see SRFI-22. */
+             } else {
++                /* NB: better error reporting for uncaptured errors? */
++                Scm_ReportError(epak.exception);
+                 exit_code = 70;  /* EX_SOFTWARE, see SRFI-22. */
+             }
+         }
diff --git a/dev-lang/gauche/gauche-0.8.8.ebuild b/dev-lang/gauche/gauche-0.8.8.ebuild
new file mode 100644 (file)
index 0000000..8b6c4e2
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gauche/gauche-0.8.8.ebuild,v 1.1 2006/12/01 11:37:47 hattya Exp $
+
+inherit autotools eutils flag-o-matic
+
+IUSE="ipv6"
+
+MY_P=${P/g/G}
+
+DESCRIPTION="A Unix system friendly Scheme Interpreter"
+HOMEPAGE="http://gauche.sf.net/"
+SRC_URI="mirror://sourceforge/gauche/${MY_P}.tgz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+SLOT="0"
+S=${WORKDIR}/${MY_P}
+
+DEPEND=">=sys-libs/gdbm-1.8.0"
+
+src_unpack() {
+
+       unpack ${A}
+       cd "${S}"
+
+       epatch "${FILESDIR}"/${PN}-dbm.ac.diff
+       epatch "${FILESDIR}"/${PN}-gauche.m4.diff
+       epatch "${FILESDIR}"/${PN}-runpath.diff
+       epatch "${FILESDIR}"/${P}-report-error.diff
+
+       eautoconf
+
+}
+
+src_compile() {
+
+       local myconf="--enable-threads=pthreads --enable-multibyte=utf8"
+
+       strip-flags
+
+       econf \
+               `use_enable ipv6` \
+               ${myconf} \
+               || die
+       emake || die
+
+}
+
+src_test() {
+
+       emake -j1 -s check || die
+
+}
+
+src_install() {
+
+       emake DESTDIR="${D}" install || die
+
+       dodoc AUTHORS ChangeLog HACKING README
+
+}
+
+pkg_postinst() {
+
+       echo
+       ewarn "As of version 0.8.6, Gauche switched the default character"
+       ewarn "encoding from euc-jp to utf-8."
+       echo
+
+}