sys-libs/glibc: Drop SPARC CHOST mangling
authorMatt Turner <mattst88@gentoo.org>
Wed, 25 Mar 2020 21:34:07 +0000 (14:34 -0700)
committerMatt Turner <mattst88@gentoo.org>
Wed, 1 Apr 2020 17:32:25 +0000 (10:32 -0700)
Somehow glibc-2.29 is also affected, even though it used to work. See
commit 7daa03609079 for the changes to later versions.

Signed-off-by: Matt Turner <mattst88@gentoo.org>
sys-libs/glibc/glibc-2.29-r7.ebuild

index b883c878e019ff16634c3a916e617c8475d74c29..1ffe9800d1dcd9fb1b2580d426e1ae42d2faf4f4 100644 (file)
@@ -281,77 +281,27 @@ setup_target_flags() {
                        filter-flags "-fcall-used-g7"
                        append-flags "-fcall-used-g6"
 
-                       # If the CHOST is the basic one (e.g. not sparcv9-xxx already),
-                       # try to pick a better one so glibc can use cpu-specific .S files.
-                       # We key off the CFLAGS to get a good value.  Also need to handle
-                       # version skew.
-                       # We can't force users to set their CHOST to their exact machine
-                       # as many of these are not recognized by config.sub/gcc and such :(.
-                       # Note: If the mcpu values don't scale, we might try probing CPP defines.
-                       # Note: Should we factor in -Wa,-AvXXX flags too ?  Or -mvis/etc... ?
-
                        local cpu
                        case ${CTARGET} in
                        sparc64-*)
+                               cpu="sparc64"
                                case $(get-flag mcpu) in
-                               niagara[234])
-                                       if ver_test -ge 2.8 ; then
-                                               cpu="sparc64v2"
-                                       elif ver_test -ge 2.4 ; then
-                                               cpu="sparc64v"
-                                       elif ver_test -ge 2.2.3 ; then
-                                               cpu="sparc64b"
-                                       fi
-                                       ;;
-                               niagara)
-                                       if ver_test -ge 2.4 ; then
-                                               cpu="sparc64v"
-                                       elif ver_test -ge 2.2.3 ; then
-                                               cpu="sparc64b"
-                                       fi
-                                       ;;
-                               ultrasparc3)
-                                       cpu="sparc64b"
-                                       ;;
-                               *)
+                               v9)
                                        # We need to force at least v9a because the base build doesn't
                                        # work with just v9.
                                        # https://sourceware.org/bugzilla/show_bug.cgi?id=19477
-                                       [[ -z ${cpu} ]] && append-flags "-Wa,-xarch=v9a"
+                                       append-flags "-Wa,-xarch=v9a"
                                        ;;
                                esac
                                ;;
                        sparc-*)
                                case $(get-flag mcpu) in
-                               niagara[234])
-                                       if ver_test -ge 2.8 ; then
-                                               cpu="sparcv9v2"
-                                       elif ver_test -ge 2.4 ; then
-                                               cpu="sparcv9v"
-                                       elif ver_test -ge 2.2.3 ; then
-                                               cpu="sparcv9b"
-                                       else
-                                               cpu="sparcv9"
-                                       fi
-                                       ;;
-                               niagara)
-                                       if ver_test -ge 2.4 ; then
-                                               cpu="sparcv9v"
-                                       elif ver_test -ge 2.2.3 ; then
-                                               cpu="sparcv9b"
-                                       else
-                                               cpu="sparcv9"
-                                       fi
-                                       ;;
-                               ultrasparc3)
-                                       cpu="sparcv9b"
-                                       ;;
-                               v9|ultrasparc)
-                                       cpu="sparcv9"
-                                       ;;
                                v8|supersparc|hypersparc|leon|leon3)
                                        cpu="sparcv8"
                                        ;;
+                               *)
+                                       cpu="sparcv9"
+                                       ;;
                                esac
                        ;;
                        esac