dev-libs/foma: -fno-common temporary fix
authorJoonas Niilola <juippis@gentoo.org>
Mon, 4 May 2020 16:10:30 +0000 (19:10 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 4 May 2020 16:24:47 +0000 (19:24 +0300)
Closes: https://bugs.gentoo.org/706562
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/foma/foma-0.9.18.ebuild

index 1831314c8e1d7790ea908c16bff10bc72fc11970..b8dab265d309bf1351a44a156bd963cbff4e93be 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
 
 DESCRIPTION="A set of utilities for constructing finite-state automata and transducers"
 HOMEPAGE="https://github.com/mhulden/foma"
@@ -24,6 +24,8 @@ src_prepare() {
 
        # Install to correct libdir
        sed "s|/lib|/$(get_libdir)|" -i Makefile || die
+
+       append-cflags -fcommon
 }
 
 src_compile() {