net-im/slack: fix installation on new systems
authorPatrick McLean <chutzpah@gentoo.org>
Thu, 7 May 2020 04:18:27 +0000 (21:18 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Thu, 7 May 2020 04:19:45 +0000 (21:19 -0700)
this is just a hack, should be done properly

Bug: https://bugs.gentoo.org/720134
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
net-im/slack/slack-4.4.2.ebuild

index c36c8da0ee24e6e23af57d19d2238a28ab144561..48b3a778dd01b81cdf61179976445b3af5155dc5 100644 (file)
@@ -84,7 +84,17 @@ src_install() {
 
        insinto /opt/slack
        doins -r usr/lib/slack/.
-       for i in $(echo -n "${QA_PREBUILT}") ; do fperms +x "$i" ; done
+
+       # this really should be done a better way than trying to parse
+       # the QA_PREBUILT variable
+       local path
+       for path in ${QA_PREBUILT}; do
+               local -a paths=(${D}/${path})
+               for path in "${paths[@]}"; do
+                       fperms +x "${path#${D}/}"
+               done
+       done
+
        use suid && fperms u+s /opt/slack/chrome-sandbox # wrt 713094
        dosym ../../opt/slack/slack usr/bin/slack