Cleanup.
authorLuca Longinotti <chtekk@gentoo.org>
Sat, 13 Jan 2007 20:25:36 +0000 (20:25 +0000)
committerLuca Longinotti <chtekk@gentoo.org>
Sat, 13 Jan 2007 20:25:36 +0000 (20:25 +0000)
Package-Manager: portage-2.1.2_rc4-r8

net-www/mod_auth_mysql/ChangeLog
net-www/mod_auth_mysql/files/12_mod_auth_mysql.conf [new file with mode: 0644]
net-www/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild
net-www/mod_auth_mysql/mod_auth_mysql-3.0.0-r2.ebuild

index 482ec1bd57205f364d92a8db84c70d1f9e9a7247..5fcee53f46cf0833707896661c55bbccecd318a8 100644 (file)
@@ -1,12 +1,17 @@
 # ChangeLog for net-www/mod_auth_mysql
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/ChangeLog,v 1.25 2007/01/09 21:27:49 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/ChangeLog,v 1.26 2007/01/13 20:25:36 chtekk Exp $
 
  07 Dec 2006; Luca Longinotti <chtekk@gentoo.org>
   -files/12_mod_auth_mysql.conf, -files/mod_auth_mysql.patch, metadata.xml,
   -mod_auth_mysql-3.0.0.ebuild, mod_auth_mysql-3.0.0-r1.ebuild:
   Ebuild cleanup, set mysql as herd too.
 
+  13 Jan 2007; Luca Longinotti <chtekk@gentoo.org>
+  +files/12_mod_auth_mysql.conf, -files/2.8.1/12_mod_auth_mysql.conf,
+  mod_auth_mysql-3.0.0-r1.ebuild, mod_auth_mysql-3.0.0-r2.ebuild:
+  Cleanup.
+
 *mod_auth_mysql-3.0.0-r2 (09 Jan 2007)
 
   09 Jan 2007; Christian Heim <phreak@gentoo.org>
diff --git a/net-www/mod_auth_mysql/files/12_mod_auth_mysql.conf b/net-www/mod_auth_mysql/files/12_mod_auth_mysql.conf
new file mode 100644 (file)
index 0000000..cd3007e
--- /dev/null
@@ -0,0 +1,129 @@
+<IfDefine AUTH_MYSQL>
+  <IfModule !mod_auth_mysql.c>
+    LoadModule mysql_auth_module    modules/mod_auth_mysql.so
+  </IfModule>
+</IfDefine>
+
+<IfModule mod_auth_mysql.c>
+
+#
+# mod_auth_mysql can be used to limit access to documents by checking
+# data in a MySQL database.
+#
+
+# This will enable user-based MySQL authentication of everything
+# within /home/httpd.  You'll need to do the following as the MySQL
+# root user beforehand:
+#
+#    CREATE DATABASE auth;
+#    USE auth;
+#    CREATE TABLE users (
+#      user_name CHAR(30) NOT NULL,
+#      user_passwd CHAR(20) NOT NULL,
+#      PRIMARY KEY (user_name)
+#    );
+#    GRANT SELECT
+#      ON auth.users
+#      TO authuser@localhost
+#      IDENTIFIED BY 'PaSsW0Rd';
+#
+#    INSERT INTO users VALUES ('testuser', ENCRYPT('testpass'));
+#
+#<Directory /home/httpd>
+#    AuthName "MySQL authenticated zone"
+#    AuthType Basic
+#
+#    AuthMySQLUser authuser
+#    AuthMySQLPassword PaSsW0Rd
+#    AuthMySQLDB auth
+#    AuthMySQLUserTable users
+#    AuthMySQLNameField user_name
+#    AuthMySQLPasswordField user_passwd
+#
+#    require valid-user
+#</Directory>
+
+# This will enable group-based MySQL authentication of everything
+# within /home/httpd.  You'll need to do the following as the MySQL
+# root user beforehand:
+#
+#    CREATE DATABASE auth;
+#    USE auth;
+#    CREATE TABLE users (
+#      user_name CHAR(30) NOT NULL,
+#      user_passwd CHAR(20) NOT NULL,
+#      user_group CHAR(20) NOT NULL,
+#      PRIMARY KEY (user_name)
+#    );
+#    GRANT SELECT
+#      ON auth.users
+#      TO authuser@localhost
+#      IDENTIFIED BY 'PaSsW0Rd';
+#
+#    INSERT INTO users VALUES ('testuser',  ENCRYPT('testpass'), 'user');
+#    INSERT INTO users VALUES ('testadmin', ENCRYPT('testpass'), 'admin');
+#
+#<Directory /home/httpd>
+#    AuthName "MySQL group authenticated zone"
+#    AuthType Basic
+#
+#    AuthMySQLUser authuser
+#    AuthMySQLPassword PaSsW0Rd
+#    AuthMySQLDB auth
+#    AuthMySQLUserTable users
+#    AuthMySQLNameField user_name
+#    AuthMySQLPasswordField user_passwd
+#    AuthMySQLGroupField user_group
+#
+#    require group admin
+#</Directory>
+
+# Like the above this enables group-based MySQL authentication of
+# everything within /home/httpd, but this configuration allows users to
+# belong to more than one group.  You'll need to do the following as
+# the MySQL root user beforehand:
+#
+#    CREATE DATABASE auth;
+#    USE auth;
+#    CREATE TABLE users (
+#      user_name CHAR(30) NOT NULL,
+#      user_passwd CHAR(20) NOT NULL,
+#      PRIMARY KEY (user_name)
+#    );
+#    CREATE TABLE groups (
+#      user_name CHAR(30) NOT NULL,
+#      user_group CHAR(20) NOT NULL,
+#      PRIMARY KEY (user_name, user_group)
+#    );
+#    GRANT SELECT
+#      ON auth.users
+#      TO authuser@localhost
+#      IDENTIFIED BY 'PaSsW0Rd';
+#    GRANT SELECT
+#      ON auth.groups
+#      TO authuser@localhost
+#      IDENTIFIED BY 'PaSsW0Rd';
+#
+#    INSERT INTO users VALUES ('testuser',  ENCRYPT('testpass'));
+#    INSERT INTO groups VALUES ('testuser', 'user');
+#    INSERT INTO users VALUES ('testadmin', ENCRYPT('testpass'));
+#    INSERT INTO groups VALUES ('testadmin', 'admin');
+#    INSERT INTO groups VALUES ('testadmin', 'user');
+#
+#<Directory /home/httpd>
+#    AuthName "MySQL group authenticated zone"
+#    AuthType Basic
+#
+#    AuthMySQLUser authuser
+#    AuthMySQLPassword PaSsW0Rd
+#    AuthMySQLDB auth
+#    AuthMySQLUserTable users
+#    AuthMySQLNameField user_name
+#    AuthMySQLPasswordField user_passwd
+#    AuthMySQLGroupTable groups
+#    AuthMySQLGroupField user_group
+#
+#    require group user
+#</Directory>
+
+</IfModule>
index 092f3e9bcf87fbbb5181c073626933af3466b36c..3685e54444a36a081f8067388242d83cd0a15b17 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild,v 1.3 2006/12/07 16:36:01 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-3.0.0-r1.ebuild,v 1.4 2007/01/13 20:25:36 chtekk Exp $
 
 inherit apache-module
 
@@ -16,14 +16,12 @@ DEPEND="virtual/mysql
                sys-libs/zlib"
 RDEPEND="${DEPEND}"
 
-BASE_CONFIG_PVR="2.8.1"
-
 APXS1_ARGS="-DENABLE=0 -c -I/usr/include/mysql -lmysqlclient -lm -lz ${PN}.c"
-APACHE1_MOD_CONF="${BASE_CONFIG_PVR}/12_mod_auth_mysql"
+APACHE1_MOD_CONF="12_mod_auth_mysql"
 APACHE1_MOD_DEFINE="AUTH_MYSQL"
 
 APXS2_ARGS="-c -I/usr/include/mysql -lmysqlclient -lm -lz ${PN}.c"
-APACHE2_MOD_CONF="${BASE_CONFIG_PVR}/12_mod_auth_mysql"
+APACHE2_MOD_CONF="12_mod_auth_mysql"
 APACHE2_MOD_DEFINE="AUTH_MYSQL"
 
 DOCFILES="README"
index 8dda92f2c450b66a2cc7f6b48a2776831138b591..c7f85cb6bf564268c9d607b64d1c553bd31ff981 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-3.0.0-r2.ebuild,v 1.1 2007/01/09 21:27:49 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_mysql/mod_auth_mysql-3.0.0-r2.ebuild,v 1.2 2007/01/13 20:25:36 chtekk Exp $
 
 inherit apache-module eutils
 
@@ -16,14 +16,12 @@ DEPEND="virtual/mysql
                sys-libs/zlib"
 RDEPEND="${DEPEND}"
 
-BASE_CONFIG_PVR="2.8.1"
-
 APXS1_ARGS="-DENABLE=0 -c -I/usr/include/mysql -lmysqlclient -lm -lz ${PN}.c"
-APACHE1_MOD_CONF="${BASE_CONFIG_PVR}/12_mod_auth_mysql"
+APACHE1_MOD_CONF="12_mod_auth_mysql"
 APACHE1_MOD_DEFINE="AUTH_MYSQL"
 
 APXS2_ARGS="-c -I/usr/include/mysql -lmysqlclient -lm -lz ${PN}.c"
-APACHE2_MOD_CONF="${BASE_CONFIG_PVR}/12_mod_auth_mysql"
+APACHE2_MOD_CONF="12_mod_auth_mysql"
 APACHE2_MOD_DEFINE="AUTH_MYSQL"
 
 DOCFILES="README"